Bug 181483 - [PATCH] science/py27-h5py: update to 2.1.1_3
Summary: [PATCH] science/py27-h5py: update to 2.1.1_3
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: Rusmir Dusko
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-08-23 12:20 UTC by Johannes Meixner
Modified: 2013-10-30 21:40 UTC (History)
1 user (show)

See Also:


Attachments
py27-h5py-2.1.1_3.patch (21.19 KB, patch)
2013-08-23 12:20 UTC, Johannes Meixner
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Johannes Meixner 2013-08-23 12:20:00 UTC
- Update to 2.1.1_3
- Force LIB_DEPEND on science/hdf5-18
- Add regression-tests

portlint: ok
porttest: ok
testport: ok
redports: https://redports.org/buildarchive/20130822182000-31799/

Port maintainer (fmysh@iijmio-mail.jp) is cc'd.

Generated with FreeBSD Port Tools 0.99_8 (mode: update, diff: ports)
Comment 1 Edwin Groothuis freebsd_committer 2013-08-23 12:20:10 UTC
State Changed
From-To: open->feedback

Awaiting maintainers feedback (via the GNATS Auto Assign Tool)
Comment 2 Edwin Groothuis freebsd_committer 2013-08-23 12:20:10 UTC
Maintainer of science/py-h5py,

Please note that PR ports/181483 has just been submitted.

If it contains a patch for an upgrade, an enhancement or a bug fix
you agree on, reply to this email stating that you approve the patch
and a committer will take care of it.

The full text of the PR can be found at:
    http://www.freebsd.org/cgi/query-pr.cgi?pr=ports/181483

-- 
Edwin Groothuis via the GNATS Auto Assign Tool
edwin@FreeBSD.org
Comment 3 Kubilay Kocak freebsd_committer freebsd_triage 2013-09-07 12:12:51 UTC
State Changed
From-To: feedback->open

Maintainer timeout
Comment 4 Rusmir Dusko freebsd_committer 2013-10-24 17:21:01 UTC
Responsible Changed
From-To: freebsd-ports-bugs->nemysis

I'll take it.
Comment 5 dfilter service freebsd_committer 2013-10-30 21:34:25 UTC
Author: nemysis
Date: Wed Oct 30 21:34:16 2013
New Revision: 332177
URL: http://svnweb.freebsd.org/changeset/ports/332177

Log:
  - Update to 2.1.1
  - Remove leading article from COMMENT
  - Use default dependency for science/hdf5-18
  - Add patch
  
  PR:		ports/181483
  Submitted by:	Johannes Meixner <xmj@chaot.net>
  Approved by:	wg (mentor)

Added:
  head/science/py-h5py/files/
  head/science/py-h5py/files/patch-setup.py   (contents, props changed)
Deleted:
  head/science/py-h5py/pkg-plist
Modified:
  head/science/py-h5py/Makefile
  head/science/py-h5py/distinfo   (contents, props changed)
  head/science/py-h5py/pkg-descr

Modified: head/science/py-h5py/Makefile
==============================================================================
--- head/science/py-h5py/Makefile	Wed Oct 30 21:28:24 2013	(r332176)
+++ head/science/py-h5py/Makefile	Wed Oct 30 21:34:16 2013	(r332177)
@@ -2,32 +2,27 @@
 # $FreeBSD$
 
 PORTNAME=	h5py
-PORTVERSION=	1.2.1
-PORTREVISION=	3
+PORTVERSION=	2.1.1
 CATEGORIES=	science python
 MASTER_SITES=	${MASTER_SITE_GOOGLE_CODE}
 PKGNAMEPREFIX=	${PYTHON_PKGNAMEPREFIX}
 
 MAINTAINER=	fmysh@iijmio-mail.jp
-COMMENT=	A general-purpose Python interface to the HDF5 library
+COMMENT=	General-purpose Python interface to the HDF5 library
 
 BUILD_DEPENDS=	${PYNUMPY}
 RUN_DEPENDS=	${PYNUMPY}
+LIB_DEPENDS=	libhdf5.so:${PORTSDIR}/science/hdf5-18
 
-OPTIONS_DEFINE=	NEW_HDF5
-NEW_HDF5_DESC=	Use port science/hdf5-18 instead of science/hdf5
-OPTIONSFILE?=	${PORT_DBDIR}/py-${PORTNAME}/options
-
-NO_STAGE=	yes
-.include <bsd.port.options.mk>
-.if ${PORT_OPTIONS:MNEW_HDF5}
-LIB_DEPENDS=	hdf5:${PORTSDIR}/science/hdf5-18
-.else
-LIB_DEPENDS=	hdf5:${PORTSDIR}/science/hdf5
-.endif
-
-USE_PYTHON=		2.5+
-USE_PYDISTUTILS=	easy_install
-PYEASYINSTALL_ARCHDEP=	yes
+USE_PYTHON=		yes
+USE_PYDISTUTILS=	yes
+PYDISTUTILS_AUTOPLIST=	yes
+
+post-patch:
+	${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|' \
+		${WRKSRC}/setup.py
+
+regression-test: build
+	@cd ${WRKSRC} && ${PYTHON_CMD} ${PYSETUP} test
 
 .include <bsd.port.mk>

Modified: head/science/py-h5py/distinfo
==============================================================================
--- head/science/py-h5py/distinfo	Wed Oct 30 21:28:24 2013	(r332176)
+++ head/science/py-h5py/distinfo	Wed Oct 30 21:34:16 2013	(r332177)
@@ -1,2 +1,2 @@
-SHA256 (h5py-1.2.1.tar.gz) = 2263c966a87adff606a677214d3af7593d3ae300b6b6b0a77412a9f3ae7a8e43
-SIZE (h5py-1.2.1.tar.gz) = 1462012
+SHA256 (h5py-2.1.1.tar.gz) = 6e4f135268436cda1dc19a081dc5384d431057344fa1121a886016cd8c89c716
+SIZE (h5py-2.1.1.tar.gz) = 984939

Added: head/science/py-h5py/files/patch-setup.py
==============================================================================
--- /dev/null	00:00:00 1970	(empty, because file is newly added)
+++ head/science/py-h5py/files/patch-setup.py	Wed Oct 30 21:34:16 2013	(r332177)
@@ -0,0 +1,12 @@
+--- ./setup.py.orig	2013-10-29 15:50:15.741120947 +0200
++++ ./setup.py	2013-10-29 15:51:01.621119992 +0200
+@@ -68,6 +68,9 @@
+     elif sys.platform == 'darwin':
+         COMPILER_SETTINGS['include_dirs'] += ['/opt/local/include']
+         COMPILER_SETTINGS['library_dirs'] += ['/opt/local/lib']
++    elif sys.platform.startswith('freebsd'):
++        COMPILER_SETTINGS['include_dirs'] += ['%%LOCALBASE%%/include']
++        COMPILER_SETTINGS['library_dirs'] += ['%%LOCALBASE%%/lib']
+     COMPILER_SETTINGS['runtime_library_dirs'] = [op.abspath(x) for x in COMPILER_SETTINGS['library_dirs']]
+ 
+ MODULES =  ['defs','_errors','_objects','_proxy', 'h5fd', 'h5z',

Modified: head/science/py-h5py/pkg-descr
==============================================================================
--- head/science/py-h5py/pkg-descr	Wed Oct 30 21:28:24 2013	(r332176)
+++ head/science/py-h5py/pkg-descr	Wed Oct 30 21:34:16 2013	(r332177)
@@ -1,6 +1,6 @@
 The h5py package provides both a high- and low-level interface to the HDF5
-library from Python. The low-level interface is intended to be a complete
-wrapping of the HDF5 1.6 and 1.8 APIs, while the high-level component supports
+library from Python.  The low-level interface is intended to be a complete
+wrapping of the HDF5 1.8 API, while the high-level component supports
 Python-style object-oriented access to HDF5 files, datasets and groups.
 
 The goal of this package is not to provide yet another scientific data
_______________________________________________
svn-ports-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/svn-ports-all
To unsubscribe, send any mail to "svn-ports-all-unsubscribe@freebsd.org"
Comment 6 Rusmir Dusko freebsd_committer 2013-10-30 21:35:24 UTC
State Changed
From-To: open->closed

Committed. Thanks!