Bug 181646 - [ral] [panic] Kernel panic, probably caused by wi-fi card Linksys WMP600N (PCI)
Summary: [ral] [panic] Kernel panic, probably caused by wi-fi card Linksys WMP600N (PCI)
Status: Closed DUPLICATE of bug 184084
Alias: None
Product: Base System
Classification: Unclassified
Component: kern (show other bugs)
Version: 9.1-RELEASE
Hardware: Any Any
: Normal Affects Only Me
Assignee: freebsd-wireless mailing list
URL:
Keywords: panic
Depends on:
Blocks:
 
Reported: 2013-08-29 11:10 UTC by k_georgiev
Modified: 2019-02-03 16:07 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description k_georgiev 2013-08-29 11:10:02 UTC
System reboots every few days. 

I am not sure about the real cause, but it looks like to me a driver problem of the wi-fi card.
I got messages in the syslog:


Aug 29 00:27:38 sentinel kernel: Limiting icmp unreach response from 241 to 200 packets/sec  ## Old event
Aug 29 11:35:59 sentinel syslogd: kernel boot file is /boot/kernel/kernel
Aug 29 11:35:59 sentinel kernel: 
Aug 29 11:35:59 sentinel kernel: 
Aug 29 11:35:59 sentinel kernel: Fatal trap 12: page fault while in kernel mode
Aug 29 11:35:59 sentinel kernel: cpuid = 0; apic id = 00
Aug 29 11:35:59 sentinel kernel: fault virtual address	= 0xffffff8003056000
Aug 29 11:35:59 sentinel kernel: fault code		= supervisor read data, page not present
Aug 29 11:35:59 sentinel kernel: instruction pointer	= 0x20:0xffffffff80661d75
Aug 29 11:35:59 sentinel kernel: stack pointer	        = 0x28:0xffffff808d6e5a40
Aug 29 11:35:59 sentinel kernel: frame pointer	        = 0x28:0xffffff808d6e5a80
Aug 29 11:35:59 sentinel kernel: code segment		= base rx0, limit 0xfffff, type 0x1b
Aug 29 11:35:59 sentinel kernel: = DPL 0, pres 1, long 1, def32 0, gran 1
Aug 29 11:35:59 sentinel kernel: processor eflags	= interrupt enabled, resume, IOPL = 0
Aug 29 11:35:59 sentinel kernel: current process		= 12 (irq17: ral0)
Aug 29 11:35:59 sentinel kernel: trap number		= 12
Aug 29 11:35:59 sentinel kernel: panic: page fault
Aug 29 11:35:59 sentinel kernel: cpuid = 0
Aug 29 11:35:59 sentinel kernel: KDB: stack backtrace:
Aug 29 11:35:59 sentinel kernel: #0 0xffffffff8092aab6 at kdb_backtrace+0x66
Aug 29 11:35:59 sentinel kernel: #1 0xffffffff808f4ace at panic+0x1ce
Aug 29 11:35:59 sentinel kernel: #2 0xffffffff80be2550 at trap_fatal+0x290
Aug 29 11:35:59 sentinel kernel: #3 0xffffffff80be288d at trap_pfault+0x1ed
Aug 29 11:35:59 sentinel kernel: #4 0xffffffff80be2eae at trap+0x3ce
Aug 29 11:35:59 sentinel kernel: #5 0xffffffff80bcd46f at calltrap+0x8
Aug 29 11:35:59 sentinel kernel: #6 0xffffffff806678e1 at rt2860_intr+0x891
Aug 29 11:35:59 sentinel kernel: #7 0xffffffff808c8ae4 at intr_event_execute_handlers+0x104
Aug 29 11:35:59 sentinel kernel: #8 0xffffffff808ca286 at ithread_loop+0xa6
Aug 29 11:35:59 sentinel kernel: #9 0xffffffff808c5bff at fork_exit+0x11f
Aug 29 11:35:59 sentinel kernel: #10 0xffffffff80bcd99e at fork_trampoline+0xe
Aug 29 11:35:59 sentinel kernel: Uptime: 3d10h10m26s
Aug 29 11:35:59 sentinel kernel: Automatic reboot in 15 seconds - press a key on the console to abort
Aug 29 11:35:59 sentinel kernel: Rebooting...
Aug 29 11:35:59 sentinel kernel: Copyright (c) 1992-2012 The FreeBSD Project. ## After reboot



## File: /etc/rc.conf:

create_args_wlan0="wlanmode hostap"
ifconfig_wlan0="channel 11 txpower 20"

cloned_interfaces="bridge0"
ifconfig_bridge0="addm re1 stp re1 addm wlan0 up"
ifconfig_bridge0_alias0="inet 192.168.1.1 netmask 255.255.255.0"
ifconfig_re1="up"

## OpenVPN bridge scripts:

root@sentinel:/var/log # cat /usr/local/etc/openvpn/up.sh 
#!/bin/sh
/sbin/ifconfig tap0 up
/sbin/ifconfig bridge0 addm tap0 up
root@sentinel:/var/log # 
root@sentinel:/var/log # cat /usr/local/etc/openvpn/down.sh 
#!/bin/sh
/sbin/ifconfig bridge0 deletem tap0

root@sentinel:/var/log # 

## File: /etc/hostapd.conf

interface=wlan0
driver=bsd
ctrl_interface=/var/run/hostapd
ctrl_interface_group=wheel
ssid=UnixFBSD
wpa=3
wpa_passphrase=my-pass-string
wpa_key_mgmt=WPA-PSK
wpa_pairwise=CCMP TKIP


## "ifconfig -a" after all interfaces are up and joined to the bridge:

re0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
	options=8209b<RXCSUM,TXCSUM,VLAN_MTU,VLAN_HWTAGGING,VLAN_HWCSUM,WOL_MAGIC,LINKSTATE>
	ether 00:19:d1:b6:38:e8
	inet6 fe80::219:d1ff:feb6:38e8%re0 prefixlen 64 scopeid 0x1 
	inet 1.2.3.4 netmask 0xffffff00 broadcast 1.2.3.4   ### Here stands my internet IP
	nd6 options=29<PERFORMNUD,IFDISABLED,AUTO_LINKLOCAL>
	media: Ethernet autoselect (100baseTX <full-duplex>)
	status: active
re1: flags=8943<UP,BROADCAST,RUNNING,PROMISC,SIMPLEX,MULTICAST> metric 0 mtu 1500
	options=82099<RXCSUM,VLAN_MTU,VLAN_HWTAGGING,VLAN_HWCSUM,WOL_MAGIC,LINKSTATE>
	ether e0:8f:ec:00:6e:f8
	inet6 fe80::e28f:ecff:fe00:6ef8%re1 prefixlen 64 scopeid 0x7 
	nd6 options=29<PERFORMNUD,IFDISABLED,AUTO_LINKLOCAL>
	media: Ethernet autoselect (1000baseT <full-duplex>)
	status: active
ral0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 2290
	ether 00:1e:e5:e8:d4:6d
	nd6 options=29<PERFORMNUD,IFDISABLED,AUTO_LINKLOCAL>
	media: IEEE 802.11 Wireless Ethernet autoselect mode 11g <hostap>
	status: running
lo0: flags=8049<UP,LOOPBACK,RUNNING,MULTICAST> metric 0 mtu 16384
	options=600003<RXCSUM,TXCSUM,RXCSUM_IPV6,TXCSUM_IPV6>
	inet6 ::1 prefixlen 128 
	inet6 fe80::1%lo0 prefixlen 64 scopeid 0x9 
	inet 127.0.0.1 netmask 0xff000000 
	nd6 options=21<PERFORMNUD,AUTO_LINKLOCAL>
bridge0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
	ether 02:74:c6:6d:ec:00
	inet 192.168.1.1 netmask 0xffffff00 broadcast 192.168.1.255
	nd6 options=29<PERFORMNUD,IFDISABLED,AUTO_LINKLOCAL>
	id 00:bd:da:40:00:00 priority 32768 hellotime 2 fwddelay 15
	maxage 20 holdcnt 6 proto rstp maxaddr 2000 timeout 1200
	root id 00:bd:da:40:00:00 priority 32768 ifcost 0 port 0
	member: wlan0 flags=143<LEARNING,DISCOVER,AUTOEDGE,AUTOPTP>
	        ifmaxaddr 0 port 11 priority 128 path cost 370370
	member: tap0 flags=143<LEARNING,DISCOVER,AUTOEDGE,AUTOPTP>
	        ifmaxaddr 0 port 13 priority 128 path cost 2000000
	member: re1 flags=1e7<LEARNING,DISCOVER,STP,EDGE,AUTOEDGE,PTP,AUTOPTP>
	        ifmaxaddr 0 port 7 priority 128 path cost 20000 proto rstp
	        role designated state forwarding
pflog0: flags=100<PROMISC> metric 0 mtu 33152
	nd6 options=29<PERFORMNUD,IFDISABLED,AUTO_LINKLOCAL>
tap0: flags=8942<BROADCAST,RUNNING,PROMISC,SIMPLEX,MULTICAST> metric 0 mtu 1500
	options=80000<LINKSTATE>
	ether 00:bd:da:40:00:00
	inet6 fe80::2bd:daff:fe40:0%tap0 prefixlen 64 tentative scopeid 0xd 
	nd6 options=29<PERFORMNUD,IFDISABLED,AUTO_LINKLOCAL>
	Opened by PID 1447
wlan0: flags=8943<UP,BROADCAST,RUNNING,PROMISC,SIMPLEX,MULTICAST> metric 0 mtu 1500
	ether 00:1e:e5:e8:d4:6d
	nd6 options=29<PERFORMNUD,IFDISABLED,AUTO_LINKLOCAL>
	media: IEEE 802.11 Wireless Ethernet autoselect mode 11g <hostap>
	status: running
	ssid UnixFBSD channel 11 (2462 MHz 11g) bssid 00:1e:e5:e8:d4:6d
	country US authmode WPA1+WPA2/802.11i privacy MIXED deftxkey 3
	TKIP 2:128-bit TKIP 3:128-bit txpower 0 scanvalid 60 protmode CTS wme
	dtimperiod 1 -dfs

How-To-Repeat: I have no idea what event directly cause the problem, it just reboots randomly in random hours and days.
root@sentinel:/var/log # last | grep -i boot |head
boot time                                  Thu Aug 29 11:36
boot time                                  Mon Aug 26 01:24
boot time                                  Sat Aug 24 00:46
boot time                                  Sun Aug 18 22:22
boot time                                  Sun Aug 18 21:52
boot time                                  Sat Aug 17 20:13
root@sentinel:/var/log #
Comment 1 Eitan Adler freebsd_committer freebsd_triage 2017-12-31 07:59:17 UTC
For bugs matching the following criteria:

Status: In Progress Changed: (is less than) 2014-06-01

Reset to default assignee and clear in-progress tags.

Mail being skipped
Comment 2 Andriy Voskoboinyk freebsd_committer 2019-01-26 04:56:33 UTC
Reassign to the wireless list
Comment 3 Andriy Voskoboinyk freebsd_committer 2019-02-03 16:07:27 UTC
Most likely the reason is the same as for bug #184084 - there is nothing suspicious in other interrupt handler parts.

*** This bug has been marked as a duplicate of bug 184084 ***