Bug 182565 - devel/apr1 fails to build in when MYSQL=on and WITH_MYSQL_VER=55m
Summary: devel/apr1 fails to build in when MYSQL=on and WITH_MYSQL_VER=55m
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: Olli Hauer
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-10-02 10:50 UTC by Vincent Hoffman-Kazlauskas
Modified: 2013-10-17 06:20 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Vincent Hoffman-Kazlauskas 2013-10-02 10:50:00 UTC
looks like this started at r328885. I'll try and look a bit closer when i get time.

I am building using poudriere in a 9.1 and 8.4 amd64 jail. 
Log of the failed build available at http://unsane.co.uk/fbsd/apr-1.4.8.1.5.2.log
This should contain any required config or environment information but let me know if you need more provided.

How-To-Repeat: try and build devel/apr1 with the option MYSQL=on and with WITH_MYSQL_VER=55m in make.conf
Comment 1 Edwin Groothuis freebsd_committer 2013-10-02 10:50:10 UTC
Responsible Changed
From-To: freebsd-ports-bugs->apache

Over to maintainer (via the GNATS Auto Assign Tool)
Comment 2 Olli Hauer freebsd_committer 2013-10-06 14:56:00 UTC
State Changed
From-To: open->analyzed

apr builds fine wit mysql55 and percona55, 
so I suspect it is compatibility issue is in mariadb55 



Comment 3 Olli Hauer freebsd_committer 2013-10-06 14:56:00 UTC
Responsible Changed
From-To: apache->ohauer

I'll take it
Comment 4 Olli Hauer 2013-10-06 15:33:51 UTC
On 2013-10-06 16:15, Florian Smeets wrote:
> On 06.10.13 15:58, ohauer@FreeBSD.org wrote:
>> Synopsis: devel/apr1 fails to build in when MYSQL=on and WITH_MYSQL_VER=55m
>>
>> State-Changed-From-To: open->analyzed
>> State-Changed-By: ohauer
>> State-Changed-When: Sun Oct 6 13:56:00 UTC 2013
>> State-Changed-Why:
>> apr builds fine wit mysql55 and percona55,
>> so I suspect it is compatibility issue is in mariadb55
>>
> 
> I already looked into this yesterday, the problem is this
> 
> configure:20208: cc -o conftest -O2 -pipe -fno-strict-aliasing -I/usr/local/include -I/usr/local/include/mysql -DHAVE_MYSQL_H -I/usr/include -I/usr/local/include/mysql/..  -L/usr/local/lib/mysql -L/usr/lib -Wl,-rpath=/usr/lib:/usr/local/lib -lmysqlclient_r -pthread -lz -lm -lexecinfo conftest.c -lmysqlclient_r  -L/usr/local/lib/mysql -lmysqlclient_r  -pthread -lz -lm -lexecinfo >&5
> /usr/bin/ld: cannot find -lexecinfo
> 
> And this is caused by
> 
> flo@zoidberg:~/dev/checkouts/ports/databases/mariadb55-client % /usr/local/bin/mysql_config
> Usage: /usr/local/bin/mysql_config [OPTIONS]
> Options:
>         --cflags         [-I/usr/local/include/mysql -I/usr/local/include/mysql/.. -pipe -fstack-protector -fno-strict-aliasing -g -DNDEBUG]
>         --include        [-I/usr/local/include/mysql -I/usr/local/include/mysql/..]
>         --libs           [-L/usr/local/lib/mysql -lmysqlclient -pthread -lz -lm -lexecinfo]
>         --libs_r         [-L/usr/local/lib/mysql -lmysqlclient_r -pthread -lz -lm -lexecinfo]
>         --plugindir      [/usr/local/lib/mysql/plugin]
>         --socket         [/tmp/mysql.sock]
>         --port           [0]
>         --version        [5.5.33a]
>         --libmysqld-libs [-L/usr/local/lib/mysql -lmysqld]
>         --variable=VAR   VAR is one of:
>                 pkgincludedir [/usr/local/include/mysql]
>                 pkglibdir     [/usr/local/lib/mysql]
>                 plugindir     [/usr/local/lib/mysql/plugin]
> 
> --libs should include -L/usr/local/lib as that's where execinfo is (or /usr/lib on head, but that's in the standard flags anyway)
> 
> I haven't found a way to tell the mariadb build system how to also include that patch in the mysql_config script.
> 
> So this is a mariadb PR.
> 

Hi Florian,

thanks for confirming it is a mariadb issue.
I will close the apr PR.

-- 
olli
Comment 5 Olli Hauer freebsd_committer 2013-10-06 15:57:55 UTC
State Changed
From-To: analyzed->closed

Close PR as it is a confirmed mariadb issue
Comment 6 never 2013-10-15 20:29:20 UTC
Hello,

Fix submitted: http://www.freebsd.org/cgi/query-pr.cgi?pr=183001

On Wed, Oct 2, 2013 at 12:45 PM, Vincent Hoffman-Kazlauskas
<vince@unsane.co.uk> wrote:
>
>>Number:         182565
>>Category:       ports
>>Synopsis:       devel/apr1 fails to build in when MYSQL=on and WITH_MYSQL_VER=55m
>>Confidential:   no
>>Severity:       non-critical
>>Priority:       low
>>Responsible:    freebsd-ports-bugs
>>State:          open
>>Quarter:
>>Keywords:
>>Date-Required:
>>Class:          sw-bug
>>Submitter-Id:   current-users
>>Arrival-Date:   Wed Oct 02 09:50:00 UTC 2013
>>Closed-Date:
>>Last-Modified:
>>Originator:     Vincent Hoffman-Kazlauskas
>>Release:        10.0-ALPHA4
>>Organization:
>>Environment:
> FreeBSD bsdpkgbuild.namesco.net 10.0-ALPHA4 FreeBSD 10.0-ALPHA4 #27 r255948: Mon Sep 30 12:57:55 BST 2013     root@bsdpkgbuild.namesco.net:/usr/obj/usr/src/sys/bsdpkgbuild  amd64
>>Description:
> looks like this started at r328885. I'll try and look a bit closer when i get time.
>
> I am building using poudriere in a 9.1 and 8.4 amd64 jail.
> Log of the failed build available at http://unsane.co.uk/fbsd/apr-1.4.8.1.5.2.log
> This should contain any required config or environment information but let me know if you need more provided.
>>How-To-Repeat:
> try and build devel/apr1 with the option MYSQL=on and with WITH_MYSQL_VER=55m in make.conf
>>Fix:
>
>
>>Release-Note:
>>Audit-Trail:
>>Unformatted:
> _______________________________________________
> freebsd-ports-bugs@freebsd.org mailing list
> http://lists.freebsd.org/mailman/listinfo/freebsd-ports-bugs
> To unsubscribe, send any mail to "freebsd-ports-bugs-unsubscribe@freebsd.org"
Comment 7 dfilter service freebsd_committer 2013-10-17 06:16:52 UTC
Author: flo
Date: Thu Oct 17 05:16:44 2013
New Revision: 330601
URL: http://svnweb.freebsd.org/changeset/ports/330601

Log:
  Fix linking to mariadb libs [1]
  
  PR:		ports/183001 [1]
  PR:		ports/182565 [2]
  Submitted by:	Alexandr Kovalenko <never@nevermind.kiev.ua> [1]
  Reported by:	Vincent Hoffman-Kazlauskas <vince@unsane.co.uk> [2]

Added:
  head/databases/mariadb55-client/files/patch-scripts_mysql_config.sh   (contents, props changed)
  head/databases/mariadb55-server/files/patch-scripts_mysql_config.sh   (contents, props changed)
Modified:
  head/databases/mariadb55-client/Makefile
  head/databases/mariadb55-server/Makefile

Modified: head/databases/mariadb55-client/Makefile
==============================================================================
--- head/databases/mariadb55-client/Makefile	Thu Oct 17 04:01:01 2013	(r330600)
+++ head/databases/mariadb55-client/Makefile	Thu Oct 17 05:16:44 2013	(r330601)
@@ -1,6 +1,7 @@
 # $FreeBSD$
 
 PORTNAME=	mariadb
+PORTREVISION=	1
 PKGNAMESUFFIX=	55-client
 
 COMMENT=	Multithreaded SQL database (client)

Added: head/databases/mariadb55-client/files/patch-scripts_mysql_config.sh
==============================================================================
--- /dev/null	00:00:00 1970	(empty, because file is newly added)
+++ head/databases/mariadb55-client/files/patch-scripts_mysql_config.sh	Thu Oct 17 05:16:44 2013	(r330601)
@@ -0,0 +1,14 @@
+--- scripts/mysql_config.sh.orig	2013-09-20 01:34:23.000000000 +0300
++++ scripts/mysql_config.sh	2013-10-15 21:23:34.000000000 +0300
+@@ -108,8 +108,11 @@
+ # We intentionally add a space to the beginning and end of lib strings, simplifies replace later
+ libs=" $ldflags -L$pkglibdir -lmysqlclient @ZLIB_DEPS@ @NON_THREADED_LIBS@"
+ libs="$libs @openssl_libs@ @STATIC_NSS_FLAGS@ "
++libs="$libs -L%%LOCALBASE%%/lib "
+ libs_r=" $ldflags -L$pkglibdir -lmysqlclient_r @ZLIB_DEPS@ @CLIENT_LIBS@ @openssl_libs@ "
++libs_r="$libs_r -L%%LOCALBASE%%/lib "
+ embedded_libs=" $ldflags -L$pkglibdir -lmysqld @LIBDL@ @ZLIB_DEPS@ @LIBS@ @WRAPLIBS@ @openssl_libs@ "
++embedded_libs="$embedded_libs -L%%LOCALBASE%%/lib "
+ 
+ if [ -r "$pkglibdir/libmygcc.a" ]; then
+   # When linking against the static library with a different version of GCC

Modified: head/databases/mariadb55-server/Makefile
==============================================================================
--- head/databases/mariadb55-server/Makefile	Thu Oct 17 04:01:01 2013	(r330600)
+++ head/databases/mariadb55-server/Makefile	Thu Oct 17 05:16:44 2013	(r330601)
@@ -2,7 +2,7 @@
 
 PORTNAME?=	mariadb
 PORTVERSION=	5.5.33a
-PORTREVISION?=	0
+PORTREVISION?=	1
 CATEGORIES=	databases ipv6
 MASTER_SITES=	http://ftp.osuosl.org/pub/mariadb/${PORTNAME}-${PORTVERSION}/kvm-tarbake-jaunty-x86/ \
 		http://mirrors.supportex.net/mariadb/${PORTNAME}-${PORTVERSION}/kvm-tarbake-jaunty-x86/ \
@@ -133,6 +133,7 @@ EXTRA_PATCHES+=	${FILESDIR}/extra-patch-
 
 post-patch:
 	@${REINPLACE_CMD} 's/*.1/${MAN1}/' ${WRKSRC}/man/CMakeLists.txt
+	@${REINPLACE_CMD} 's|%%LOCALBASE%%|${LOCALBASE}|g' ${WRKSRC}/scripts/mysql_config.sh
 
 .include <bsd.port.pre.mk>
 

Added: head/databases/mariadb55-server/files/patch-scripts_mysql_config.sh
==============================================================================
--- /dev/null	00:00:00 1970	(empty, because file is newly added)
+++ head/databases/mariadb55-server/files/patch-scripts_mysql_config.sh	Thu Oct 17 05:16:44 2013	(r330601)
@@ -0,0 +1,14 @@
+--- scripts/mysql_config.sh.orig	2013-09-20 01:34:23.000000000 +0300
++++ scripts/mysql_config.sh	2013-10-15 21:23:34.000000000 +0300
+@@ -108,8 +108,11 @@
+ # We intentionally add a space to the beginning and end of lib strings, simplifies replace later
+ libs=" $ldflags -L$pkglibdir -lmysqlclient @ZLIB_DEPS@ @NON_THREADED_LIBS@"
+ libs="$libs @openssl_libs@ @STATIC_NSS_FLAGS@ "
++libs="$libs -L%%LOCALBASE%%/lib "
+ libs_r=" $ldflags -L$pkglibdir -lmysqlclient_r @ZLIB_DEPS@ @CLIENT_LIBS@ @openssl_libs@ "
++libs_r="$libs_r -L%%LOCALBASE%%/lib "
+ embedded_libs=" $ldflags -L$pkglibdir -lmysqld @LIBDL@ @ZLIB_DEPS@ @LIBS@ @WRAPLIBS@ @openssl_libs@ "
++embedded_libs="$embedded_libs -L%%LOCALBASE%%/lib "
+ 
+ if [ -r "$pkglibdir/libmygcc.a" ]; then
+   # When linking against the static library with a different version of GCC
_______________________________________________
svn-ports-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/svn-ports-all
To unsubscribe, send any mail to "svn-ports-all-unsubscribe@freebsd.org"