Bug 182647 - editors/lazarus doesn't install
Summary: editors/lazarus doesn't install
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: Jose Alonso Cardenas Marquez
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-10-04 21:10 UTC by dog
Modified: 2013-10-05 22:15 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description dog 2013-10-04 21:10:01 UTC
I try to install editors/lazarus and it stacks with the following error:

212295 lines compiled, 20.6 sec 
10 warning(s) issued
10 note(s) issued
/bin/cp -f Makefile.compiled units/x86_64-freebsd//IDEIntf.compiled
/bin/rm -f units/x86_64-freebsd//allsynedit.ppu
/usr/local/bin/gmkdir -p units/x86_64-freebsd/
/usr/local/bin/ppcx64 -Fl/usr/lib -MObjFPC -Scghi -CR -O1 -g -gl -vewnh -l -vm4055,5024 -dLCL -dLCL -CR -dgc -Fu../../ideintf/units/x86_64-freebsd/ -Fu../../lcl/units/x86_64-freebsd/ -Fu../../lcl/units/x86_64-freebsd -Fu../lazutils/lib/x86_64-freebsd -Fu../../packager/units/x86_64-freebsd -Fu. -Fu/usr/local/lib/fpc/2.6.2/units/x86_64-freebsd/rtl -FE. -FUunits/x86_64-freebsd/ -Cg -Sgic -Fu../lcl -Fu../lcl/widgetset -Fu../lcl/forms -Fu../../lcl  -Fu../../lcl/forms -Fu../../lcl/widgetset -Fu../../lcl/nonwin32  -Fu. -Fu/usr/local/lib/fpc/2.6.2/units/x86_64-freebsd/* -Fl/usr/local/lib -Fl/usr/local/lib/qt4   -Fi../lcl/include -Fi../../lcl/include  -Fu../components/lazutils -Fu../../components/lazutils -damd64 allsynedit.pas
Hint: Start of reading config file /usr/local/etc/fpc.cfg
Hint: End of reading config file /usr/local/etc/fpc.cfg
Free Pascal Compiler version 2.6.2 [2013/10/04] for x86_64
Copyright (c) 1993-2012 by Florian Klaempfl and others
Target OS: FreeBSD for x86-64
Compiling allsynedit.pas
Compiling synbeautifier.pas
Compiling syneditmiscclasses.pp
Compiling synedithighlighter.pp
synedithighlighter.pp(39,50) Fatal: Can't find unit Registry used by SynEditHighlighter
Fatal: Compilation aborted
gmake: *** [allsynedit.ppu] Error 1
*** [do-build] Error code 2

Stop in /usr/ports/editors/lazarus-lcl-units.
*** [build-depends] Error code 1

Stop in /usr/ports/editors/lazarus.
*** [install] Error code 1

Stop in /usr/ports/editors/lazarus



The build options are:

dog@dog:~> make -C /usr/ports/editors/lazarus/ showconfig
===> The following configuration options are available for lazarus-1.0.12_1:
====> Options available for the single LCL: you have to select exactly one of them
     GTK1=off: Use gtk12 interface
     GTK2=off: Use gtk20 interface
     QT4=on: Use qt4 interface

Fix: 

I have no idea
How-To-Repeat: Install editors/lazarus from ports
Comment 1 Edwin Groothuis freebsd_committer 2013-10-04 21:10:15 UTC
Responsible Changed
From-To: freebsd-ports-bugs->acm

Over to maintainer (via the GNATS Auto Assign Tool)
Comment 2 dfilter service freebsd_committer 2013-10-04 22:31:47 UTC
Author: acm
Date: Fri Oct  4 21:31:39 2013
New Revision: 329389
URL: http://svnweb.freebsd.org/changeset/ports/329389

Log:
  - Fix build [1]. Missing dependency
  - Remove identif and basecomponents targets from editors/lazarus. Now it is
    installed from lazarus-lcl-[nogui|qt|gtk1|gtk2] ports
  - Add some missing directories to PLIST
  - Some additional modifications
  
  PR:		ports/182647
  Submitted by:	Pavlo Greenberg <dog at virtual.org.ua>

Modified:
  head/editors/lazarus-lcl-units/Makefile
  head/editors/lazarus/Makefile
  head/editors/lazarus/Makefile.common

Modified: head/editors/lazarus-lcl-units/Makefile
==============================================================================
--- head/editors/lazarus-lcl-units/Makefile	Fri Oct  4 21:08:28 2013	(r329388)
+++ head/editors/lazarus-lcl-units/Makefile	Fri Oct  4 21:31:39 2013	(r329389)
@@ -6,7 +6,7 @@ PKGNAMESUFFIX=	-lcl-units
 
 COMMENT=	Lazarus components library units
 
-USE_FPC=	fcl-base fcl-db fcl-image fcl-process fcl-xml iconvenc
+USE_FPC=	fcl-base fcl-db fcl-image fcl-process fcl-registry fcl-xml iconvenc
 
 LCL_INTERFACE=	#
 

Modified: head/editors/lazarus/Makefile
==============================================================================
--- head/editors/lazarus/Makefile	Fri Oct  4 21:08:28 2013	(r329388)
+++ head/editors/lazarus/Makefile	Fri Oct  4 21:31:39 2013	(r329389)
@@ -104,21 +104,25 @@ post-extract:
 
 post-patch:
 	@${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|g' -e 's|%%DATADIR%%|${DATADIR}|g' \
-			-e 's|tools: lcl|tools:|g' -e '2744d' ${WRKSRC}/${MAKEFILE}
+			-e 's|tools: lcl|tools:|g' -e '2744d' -e '2746d' -e '2747d' ${WRKSRC}/${MAKEFILE}
 
 pre-build:
 	@${LN} -s ${LOCALBASE}/share/${PORTNAME}/lcl/units ${WRKSRC}/lcl/units
+	@${LN} -s ${LOCALBASE}/share/${PORTNAME}/ideintf/units ${WRKSRC}/ideintf/units
+	@${LN} -s ${LOCALBASE}/share/${PORTNAME}/components/synedit/units ${WRKSRC}/components/synedit/units
+	@${LN} -s ${LOCALBASE}/share/${PORTNAME}/components/lazcontrols/lib ${WRKSRC}/components/lazcontrols/lib
 
 do-build:
 	@cd ${WRKSRC} && \
-		${SETENV} ${MAKE_ENV} ${GMAKE} registration lazutils codetools ideintf basecomponents ide starter lazbuild LCL_PLATFORM=${LCL_PLATFORM}
+		${SETENV} ${MAKE_ENV} ${GMAKE} registration lazutils codetools ide starter lazbuild LCL_PLATFORM=${LCL_PLATFORM}
 	@cd ${WRKSRC} && \
 		${SETENV} ${MAKE_ENV} ${GMAKE} tools LCL_PLATFORM=${LCL_PLATFORM}
 
 post-build:
 	@cd ${WRKSRC} && \
 		${RM} -Rf COPYING* README* debian localize.bat test *.orig *.bak startlazarus.app \
-			ide/Makefile*.orig ide/Makefile*.bak
+			ide/Makefile*.orig ide/Makefile*.bak lcl/units ideintf/units \
+				components/synedit/units components/lazcontrols/lib
 
 pre-install:
 	@${ECHO} "#!/bin/sh" > ${WRKDIR}/lazarus-wrapper

Modified: head/editors/lazarus/Makefile.common
==============================================================================
--- head/editors/lazarus/Makefile.common	Fri Oct  4 21:08:28 2013	(r329388)
+++ head/editors/lazarus/Makefile.common	Fri Oct  4 21:31:39 2013	(r329389)
@@ -57,12 +57,15 @@ pre-install:
 .if ${PKGNAMESUFFIX} != "-lcl-units"
 	@${ECHO_CMD} "@dirrm %%DATADIR%%/lcl/units/%%BUILDNAME%%/${LCL_INTERFACE}" >> ${PLIST}
 .endif
+	@${ECHO_CMD} "@dirrmtry %%DATADIR%%/ideintf/units/%%BUILDNAME%%/${LCL_INTERFACE}" >> ${PLIST}
 	@${ECHO_CMD} "@dirrmtry %%DATADIR%%/ideintf/units/%%BUILDNAME%%" >> ${PLIST}
 	@${ECHO_CMD} "@dirrmtry %%DATADIR%%/ideintf/units" >> ${PLIST}
 	@${ECHO_CMD} "@dirrmtry %%DATADIR%%/ideintf" >> ${PLIST}
+	@${ECHO_CMD} "@dirrmtry %%DATADIR%%/components/synedit/units/%%BUILDNAME%%/${LCL_INTERFACE}" >> ${PLIST}
 	@${ECHO_CMD} "@dirrmtry %%DATADIR%%/components/synedit/units/%%BUILDNAME%%" >> ${PLIST}
 	@${ECHO_CMD} "@dirrmtry %%DATADIR%%/components/synedit/units" >> ${PLIST}
 	@${ECHO_CMD} "@dirrmtry %%DATADIR%%/components/synedit" >> ${PLIST}
+	@${ECHO_CMD} "@dirrmtry %%DATADIR%%/components/lazcontrols/lib/%%BUILDNAME%%/${LCL_INTERFACE}" >> ${PLIST}
 	@${ECHO_CMD} "@dirrmtry %%DATADIR%%/components/lazcontrols/lib/%%BUILDNAME%%" >> ${PLIST}
 	@${ECHO_CMD} "@dirrmtry %%DATADIR%%/components/lazcontrols/lib" >> ${PLIST}
 	@${ECHO_CMD} "@dirrmtry %%DATADIR%%/components/lazcontrols" >> ${PLIST}
_______________________________________________
svn-ports-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/svn-ports-all
To unsubscribe, send any mail to "svn-ports-all-unsubscribe@freebsd.org"
Comment 3 Jose Alonso Cardenas Marquez freebsd_committer 2013-10-04 22:31:55 UTC
State Changed
From-To: open->feedback

- Could you test my latest lazarus commit? it could work now
Comment 4 Jose Alonso Cardenas Marquez freebsd_committer 2013-10-05 22:14:14 UTC
State Changed
From-To: feedback->closed

- The problem was resolved (it was confirmed via email)