Bug 182658 - intel GMA 3150 doesn't work with kms(i915kms and xf86-video-intel)
Summary: intel GMA 3150 doesn't work with kms(i915kms and xf86-video-intel)
Status: Open
Alias: None
Product: Base System
Classification: Unclassified
Component: i386 (show other bugs)
Version: unspecified
Hardware: Any Any
: Normal Affects Only Me
Assignee: freebsd-i386 mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-10-05 04:10 UTC by Yue Wu
Modified: 2018-05-28 19:48 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Yue Wu 2013-10-05 04:10:00 UTC
PC is asus eee pc 1005pe, video card is intel GMA 3150.

If I load drm2 and i915kms, tty screen will get black, in this case, run Xorg which complied with WITH_KMS and WITH_NEW_XORG by typing cmd "startx" blindly will start xorg, the screen of xorg works again, but if switching to other ttys, the screen will be no response again, switching to xorg's tty will be fine again.

If I load drm and i915 instead, then xorg which complied with WITH_KMS and WITH_NEW_XORG will not use xf86-video-intel but xf86-video-vesa, even if I specified intel in xorg.conf.

How-To-Repeat: Get a asus epc 1005pe, start FreeBSD, kldload i915kms, now screen will be black.

Input cmd "startx" blindly at a tty, then xorg will invoked, the screen gets fine again.

Swithing to other ttys by ctrl-alt-Fn, screen will get no response. switching bac to xorg by ctrl-alt-f9 will get fine again.
Comment 1 Eitan Adler freebsd_committer freebsd_triage 2018-05-28 19:48:32 UTC
batch change:

For bugs that match the following
-  Status Is In progress 
AND
- Untouched since 2018-01-01.
AND
- Affects Base System OR Documentation

DO:

Reset to open status.


Note:
I did a quick pass but if you are getting this email it might be worthwhile to double check to see if this bug ought to be closed.