Bug 182713 - geli(8) devices does not forward TRIM requests to underlying SSD device
Summary: geli(8) devices does not forward TRIM requests to underlying SSD device
Status: Closed DUPLICATE of bug 198863
Alias: None
Product: Base System
Classification: Unclassified
Component: kern (show other bugs)
Version: 9.1-STABLE
Hardware: Any Any
: Normal Affects Only Me
Assignee: freebsd-bugs mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-10-05 21:30 UTC by Wojciech Puchar
Modified: 2019-11-30 16:09 UTC (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Wojciech Puchar 2013-10-05 21:30:00 UTC
no TRIM support on geli encrypted SSD, while SSD itself supports TRIM and it works fine without geli

How-To-Repeat: use geli on any device that support BIO_DELETE requests
Comment 1 fullermd 2016-02-07 23:26:10 UTC
Subsumed by bug 198863
Comment 2 Eitan Adler freebsd_committer freebsd_triage 2018-05-20 23:53:06 UTC
For bugs matching the following conditions:
- Status == In Progress
- Assignee == "bugs@FreeBSD.org"
- Last Modified Year <= 2017

Do
- Set Status to "Open"
Comment 3 Kamila Součková 2019-11-29 15:16:56 UTC
This is fixed and enabled by default, see geli(8), so it should be closed.
Comment 4 Andriy Gapon freebsd_committer 2019-11-30 16:09:41 UTC
Per comment #1 and comment #3.

*** This bug has been marked as a duplicate of bug 198863 ***