Bug 182748 - [maintainer-update] [patch] mail/trojita: Update to 0.3.96. Add stage support.
Summary: [maintainer-update] [patch] mail/trojita: Update to 0.3.96. Add stage support.
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: William Grzybowski
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-10-06 15:40 UTC by Marco Bröder
Modified: 2013-10-09 17:08 UTC (History)
0 users

See Also:


Attachments
file.diff (2.94 KB, patch)
2013-10-06 15:40 UTC, Marco Bröder
no flags Details | Diff
trojita.patch (2.53 KB, patch)
2013-10-09 16:28 UTC, Marco Bröder
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Marco Bröder 2013-10-06 15:40:00 UTC
Update to 0.3.96 release.

Support staging.

Use cmake. Tell cmake to use '/usr/bin/make' instead of an problably installed
gmake (because of errors).

Add desktop-file-utils dependency.

Add c++11 support check. We need either clang >= 3.3 and libc++ (from base), or
gcc >= 4.8.1 (from ports). The 'devel/libc++' port does not work. So it is not
useful to check for clang from ports.

Include <bsd.port.pre.mk> and <bsd.port.post.mk> instead of <bsd.port.mk>. This
is necessary, because ${MAKE} would complain about a malformed conditional in
the ${OSVERSION} check (syntax is correct). If using options (and so using
<bsd.port.options.mk> and <bsd.port.mk>) this error does not occur.

Tested (amd64) on head, stable/9, releng/9.2, releng/8.4.

Thanks!

Fix: Patch attached with submission follows:
Comment 1 William Grzybowski freebsd_committer 2013-10-07 12:12:57 UTC
Responsible Changed
From-To: freebsd-ports-bugs->wg

I'll take it.
Comment 2 Marco Bröder 2013-10-09 16:28:30 UTC
Please use this new patch.

Add the new 'compiler:c++11-lib' USES. Remove own c++11 check and switch back
to just include <bsd.port.mk>.

Currently, compiler.mk uses lang/gcc, which is at version 4.6.3 at the moment.
This version does NOT have full c++11 support. The first gcc version with full
c++11 support is 4.8.1. So the check for c++11 support for the gcc case is
broken / useless at the moment.

But that is not a problem for mail/trojita, because the necessary c++ features
are tested in configure stage and gcc 4.6.* meets the minimum requirements.

Originally I thought full c++11 compatibility was a requirement, but instead
it is only used if supported. The fallback works fine with gcc 4.6.3. There
are problems only with base gcc.

The new changelog:

Update to 0.3.96 release.

Support staging.

Use cmake. Tell cmake to use '/usr/bin/make' instead of an problably installed
gmake (because of errors).

Add 'compiler:c++11-lib' USES.

Add desktop-file-utils dependency.


-- 
Kind regards
Comment 3 William Grzybowski freebsd_committer 2013-10-09 17:08:18 UTC
State Changed
From-To: open->closed

Committed. Thanks!