Bug 182977 - [build] error of buildworld at the use of WITHOUT_OPENSSL (WITHOUT_CRYPT)
Summary: [build] error of buildworld at the use of WITHOUT_OPENSSL (WITHOUT_CRYPT)
Status: Closed DUPLICATE of bug 191951
Alias: None
Product: Base System
Classification: Unclassified
Component: misc (show other bugs)
Version: 10.0-BETA1
Hardware: Any Any
: Normal Affects Only Me
Assignee: freebsd-bugs mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-10-14 19:00 UTC by Valerij
Modified: 2016-01-09 21:12 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Valerij 2013-10-14 19:00:00 UTC
make buildworld fail when using WITHOUT_OPENSSL (WITHOUT_CRYPT).

/usr/src/usr.sbin/ctld/login.c:40:10: fatal error: 'openssl/err.h' file not found
#include <openssl/err.h>
         ^
1 error generated.

/usr/src/usr.sbin/iscsid/login.c:39:10: fatal error: 'openssl/err.h' file not found
#include <openssl/err.h>
         ^
1 error generated.

Files include depends OPENSSL:
#include <openssl/err.h>
#include <openssl/md5.h>
#include <openssl/rand.h>

How-To-Repeat: WITHOUT_OPENSSL="YES" >> /etc/src.conf
cd /usr/src && make buildworld
Comment 1 Bernard Spil freebsd_committer 2016-01-09 21:12:40 UTC

*** This bug has been marked as a duplicate of bug 191951 ***