Bug 183217 - ZFS from installer breaks/freezes install process
Summary: ZFS from installer breaks/freezes install process
Status: Open
Alias: None
Product: Base System
Classification: Unclassified
Component: misc (show other bugs)
Version: 10.0-BETA1
Hardware: Any Any
: Normal Affects Only Me
Assignee: freebsd-bugs mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-10-23 00:50 UTC by R Tyler Croy
Modified: 2017-12-31 22:27 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description R Tyler Croy freebsd_committer 2013-10-23 00:50:00 UTC
When trying to set up ZFS from the installer, I chose to use encryption. A step I'm not sure whether is related to the bug, but hopefully relevant information.

After entering my password twice, the installer seems to freeze/stall and has sat on that dialog screen for hours.

The emergency shell is responsive and works fine, but the "system console" screen (Alt+F3) shows the following:

--------8<--------8<---------

Running installation step: keymap
Running installation step: hostname
rm: /tmp/bsdinstall_etc/fstab: No such file or directory
[: -eq argument expected
Running installation step: zfsboot

--------8<--------8<---------
Comment 1 R. Tyler Croy 2013-10-23 00:54:29 UTC
As a followup on this, I tried going through the installer with ZFS but
*without* encryption, and things got past the ZFS part of the installation just
fine.

Comment 2 Eitan Adler freebsd_committer freebsd_triage 2017-12-31 07:59:19 UTC
For bugs matching the following criteria:

Status: In Progress Changed: (is less than) 2014-06-01

Reset to default assignee and clear in-progress tags.

Mail being skipped