Bug 183284 - misc/mc port broken
Summary: misc/mc port broken
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: Max Khon
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-10-24 23:00 UTC by Kenta Suzumoto
Modified: 2013-11-02 22:28 UTC (History)
0 users

See Also:


Attachments
mc.diff (444 bytes, patch)
2013-10-29 21:41 UTC, William Grzybowski
no flags Details | Diff
mc.diff (648 bytes, patch)
2013-10-29 22:04 UTC, William Grzybowski
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Kenta Suzumoto 2013-10-24 23:00:01 UTC
The misc/mc port fails to build in poudriere recently.

The maintainer has ignored emails so I submit a PR.

[snip]
checking for gnome-moz-remote... no
checking for mozilla... no
checking for firefox... no
checking for konqueror... no
checking for opera... no
checking for ar... (cached) ar
checking for CHECK... no
configure: WARNING: 'Check' utility not found. Check your environment
checking for GLIB... yes
checking for GMODULE... yes
checking for ncurses/ncurses.h and ncurses/term.h... no
configure: error: ncurses header not found
===>  Script "configure" failed unexpectedly.
Please report the problem to fjoe@FreeBSD.org [maintainer] and attach the
"/wrkdirs/usr/ports/misc/mc/work/mc-4.8.10/config.log" including the output
of the failure of your make command. Also, it might be a good idea to provide
an overview of all packages installed on your system (e.g. a
/usr/local/sbin/pkg-static info -g -Ea).
*** [do-configure] Error code 1

Stop in /usr/ports/misc/mc.
===>  Cleaning for mc-4.8.10
build of /usr/ports/misc/mc ended at Thu Oct 24 17:50:51 EDT 2013
build time: 00:00:43
Comment 1 Edwin Groothuis freebsd_committer 2013-10-24 23:00:28 UTC
Responsible Changed
From-To: freebsd-ports-bugs->fjoe

Over to maintainer (via the GNATS Auto Assign Tool)
Comment 2 bsd 2013-10-25 05:22:10 UTC
See PR ports/183170: misc/mc configure fails with ncurses option
selected - the same issue.
Comment 3 vsjcfm 2013-10-29 21:34:18 UTC
> From:Milan Obuch <bsd@dino.sk>
> To:bug-followup@FreeBSD.org, kentas@hush.com
> Date:Fri, 25 Oct 2013 06:22:10 +0200
> See PR ports/183170: misc/mc configure fails with ncurses option
> selected - the same issue.
No, you're wrong, this is not the same issue.
This problem caused by r331760 in ports/head commited Sun Oct 27
11:58:20 2013 UTC (5 days later after your report ports/183170) -
http://svnweb.freebsd.org/ports?view=revision&revision=331760
MC won't build (even configure) regardless of chosen screen library.
Reverting bsd.options.mk to previous version (r329293) helps (MC
builds with SLANG at least). But it's an incorrect fix, of course.

All involved persons CC'd.
Comment 4 vsjcfm 2013-10-29 21:40:12 UTC
Sorry, I mixed up PR numbers. ports/183284 is a duplicate for ports/183170.
My previous message was about ports/183402.
Comment 5 William Grzybowski 2013-10-29 21:41:15 UTC
This should fix the configure issue.

On Tue, Oct 29, 2013 at 7:34 PM, Anton Sayetsky <vsjcfm@gmail.com> wrote:
>> From:Milan Obuch <bsd@dino.sk>
>> To:bug-followup@FreeBSD.org, kentas@hush.com
>> Date:Fri, 25 Oct 2013 06:22:10 +0200
>> See PR ports/183170: misc/mc configure fails with ncurses option
>> selected - the same issue.
> No, you're wrong, this is not the same issue.
> This problem caused by r331760 in ports/head commited Sun Oct 27
> 11:58:20 2013 UTC (5 days later after your report ports/183170) -
> http://svnweb.freebsd.org/ports?view=revision&revision=331760
> MC won't build (even configure) regardless of chosen screen library.
> Reverting bsd.options.mk to previous version (r329293) helps (MC
> builds with SLANG at least). But it's an incorrect fix, of course.
>
> All involved persons CC'd.



-- 
William Grzybowski
------------------------------------------
Curitiba/PR - Brasil
Comment 6 William Grzybowski 2013-10-29 22:04:56 UTC
And this should fix NCURSES option as well.

On Tue, Oct 29, 2013 at 7:41 PM, William Grzybowski <william88@gmail.com> wrote:
> This should fix the configure issue.
>
> On Tue, Oct 29, 2013 at 7:34 PM, Anton Sayetsky <vsjcfm@gmail.com> wrote:
>>> From:Milan Obuch <bsd@dino.sk>
>>> To:bug-followup@FreeBSD.org, kentas@hush.com
>>> Date:Fri, 25 Oct 2013 06:22:10 +0200
>>> See PR ports/183170: misc/mc configure fails with ncurses option
>>> selected - the same issue.
>> No, you're wrong, this is not the same issue.
>> This problem caused by r331760 in ports/head commited Sun Oct 27
>> 11:58:20 2013 UTC (5 days later after your report ports/183170) -
>> http://svnweb.freebsd.org/ports?view=revision&revision=331760
>> MC won't build (even configure) regardless of chosen screen library.
>> Reverting bsd.options.mk to previous version (r329293) helps (MC
>> builds with SLANG at least). But it's an incorrect fix, of course.
>>
>> All involved persons CC'd.
>
>
>
> --
> William Grzybowski
> ------------------------------------------
> Curitiba/PR - Brasil



-- 
William Grzybowski
------------------------------------------
Curitiba/PR - Brasil
Comment 7 vsjcfm 2013-10-31 10:46:34 UTC
Please take a look at ports/183402.
...
> ===> Configuring for mc-4.8.10
> configure: error: invalid feature name: configdir=/usr/local/etc
> ===> Script "configure" failed unexpectedly.
...
configdir goes from SMB option. Can somebody explain me why this
evaluated even if the SMB option is off, as shown in that PR?
> root@eepc:/usr/ports/misc/deco # cat /var/db/ports/misc_mc/options
...
> OPTIONS_FILE_UNSET+=SMB
...

And this is incorrect, I think:
SMB_CONFIGURE_ON=      configdir=${LOCALBASE}/etc \
                   codepagedir=${LOCALBASE}/etc/codepages

Correct is (am I really right?):
SMB_CONFIGURE_ON        --with-smb-configdir=${LOCALBASE}/etc \
                        --with-smb-codepagedir=${LOCALBASE}/etc/codepages

According to http://www.midnight-commander.org/wiki/doc/buildAndInstall/confOptions:
--with-smb-configdir=DIR       Where to put configuration files
--with-smb-codepagedir=DIR     Where to put codepage files

SMB_CONFIGURE_WITH also isn't a correct because mc's configure doesn't
have option "--without-smb-configdir".

BTW, where is LIB_DEPENDS for SMB? AFAIK, FreeBSD doesn't have
built-in SMB client library, so any port that depend on it must
include right depends.
Comment 8 vsjcfm 2013-10-31 11:11:42 UTC
2013/10/31 Anton Sayetsky <vsjcfm@gmail.com>:
> Please take a look at ports/183402.
> ...
>> ===> Configuring for mc-4.8.10
>> configure: error: invalid feature name: configdir=/usr/local/etc
>> ===> Script "configure" failed unexpectedly.
> ...
> configdir goes from SMB option. Can somebody explain me why this
> evaluated even if the SMB option is off, as shown in that PR?
>> root@eepc:/usr/ports/misc/deco # cat /var/db/ports/misc_mc/options
> ...
>> OPTIONS_FILE_UNSET+=SMB
> ...
Taking a deeper look at bsd.options.mk explained this to me. If I
understand correctly, this happens because bsd.options.mk tries to
pass "--without-configdir=/usr/local/etc" to mc's configure when SMB
is off.
But other questions are still open.
Comment 9 dfilter service freebsd_committer 2013-11-02 22:08:10 UTC
Author: nemysis
Date: Sat Nov  2 22:08:01 2013
New Revision: 332543
URL: http://svnweb.freebsd.org/changeset/ports/332543

Log:
  - Change SMB and NCURSES
  - Change pkg-plist, fix MAN
  
  PR:		ports/183170 ports/183284 ports/183402
  Submitted by:	various
  Approved by:	pawel / wg (mentors, implicit)

Modified:
  head/misc/mc/Makefile
  head/misc/mc/pkg-plist

Modified: head/misc/mc/Makefile
==============================================================================
--- head/misc/mc/Makefile	Sat Nov  2 21:30:51 2013	(r332542)
+++ head/misc/mc/Makefile	Sat Nov  2 22:08:01 2013	(r332543)
@@ -45,8 +45,9 @@ NLS_USES=		gettext
 
 SLANG_LIB_DEPENDS=	libslang.so:${PORTSDIR}/devel/libslang2
 
-SMB_CONFIGURE_ENABLE=	vfs-smb configdir=${LOCALBASE}/etc \
-			codepagedir=${LOCALBASE}/etc/codepages
+SMB_CONFIGURE_ENABLE=	vfs-smb
+SMB_CONFIGURE_ON=	--with-smb-configdir=${LOCALBASE}/etc \
+			--with-smb-codepagedir=${LOCALBASE}/etc/codepages
 
 SUBSHELL_CONFIGURE_WITH=	subshell
 
@@ -77,7 +78,7 @@ CONFIGURE_ARGS+=--with-screen=slang --wi
 .endif
 
 .if ${PORT_OPTIONS:MNCURSES}
-CONFIGURE_ARGS+=--with-screen=ncurses --with-ncurses-includes=${LOCALBASE}/include
+CONFIGURE_ARGS+=--with-screen=ncurses
 .endif
 
 post-patch:

Modified: head/misc/mc/pkg-plist
==============================================================================
--- head/misc/mc/pkg-plist	Sat Nov  2 21:30:51 2013	(r332542)
+++ head/misc/mc/pkg-plist	Sat Nov  2 22:08:01 2013	(r332543)
@@ -2,7 +2,7 @@ bin/mc
 bin/mcdiff
 %%EDITOR%%bin/mcedit
 bin/mcview
-%%EDITOR%%etc/mc/edit.indent.rc
+etc/mc/edit.indent.rc
 etc/mc/filehighlight.ini
 etc/mc/mc.default.keymap
 etc/mc/mc.emacs.keymap
@@ -77,15 +77,15 @@ libexec/mc/mc-wrapper.csh
 libexec/mc/mc-wrapper.sh
 libexec/mc/mc.csh
 libexec/mc/mc.sh
-man/es/man1/mc.1.gz
-man/hu/man1/mc.1.gz
-man/it/man1/mc.1.gz
+%%NLS%%man/es/man1/mc.1.gz
+%%NLS%%man/hu/man1/mc.1.gz
+%%NLS%%man/it/man1/mc.1.gz
 man/man1/mc.1.gz
 man/man1/mcedit.1.gz
 man/man1/mcview.1.gz
-man/pl/man1/mc.1.gz
-man/ru/man1/mc.1.gz
-man/sr/man1/mc.1.gz
+%%NLS%%man/pl/man1/mc.1.gz
+%%NLS%%man/ru/man1/mc.1.gz
+%%NLS%%man/sr/man1/mc.1.gz
 %%NLS%%share/locale/az/LC_MESSAGES/mc.mo
 %%NLS%%share/locale/be/LC_MESSAGES/mc.mo
 %%NLS%%share/locale/bg/LC_MESSAGES/mc.mo
_______________________________________________
svn-ports-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/svn-ports-all
To unsubscribe, send any mail to "svn-ports-all-unsubscribe@freebsd.org"
Comment 10 Rusmir Dusko freebsd_committer 2013-11-02 22:28:50 UTC
State Changed
From-To: open->closed

Commited, fixed misc/mc. Thanks for the Report!