Bug 183342 - lang/gcc : fix build witch current texinfo
lang/gcc : fix build witch current texinfo
Status: Closed FIXED
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s)
Latest
Any Any
: Normal Affects Only Me
Assigned To: Gerald Pfeifer
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-26 19:30 UTC by Christoph Moench-Tegeder
Modified: 2013-12-08 19:00 UTC (History)
0 users

See Also:


Attachments
file.diff (714 bytes, patch)
2013-10-26 19:30 UTC, Christoph Moench-Tegeder
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Christoph Moench-Tegeder 2013-10-26 19:30:00 UTC
	the build of lang/gcc fails on building the documentation if
	print(texinfo is installed (the usual "@itemx must follow @item"
	error messages are seen).

Fix: This problem was fixed in gcc-4.6.4. Short of updating lang/gcc,
	I extracted the neccessary changes from the gcc-4.6.4 source.
	The following patch should be dropped into lang/gcc/files (with
	or without processing by splitpatch.pl).

	NOTE this is an additional patch for lang/gcc/files/, not a patch
	agains the ports tree



Regards,
Christoph--hrEKb8fjhcMNYJaV0lDbtVIV3kVyjXf8laJFBVNenz63OjSl
Content-Type: text/plain; name="file.diff"
Content-Transfer-Encoding: 7bit
Content-Disposition: attachment; filename="file.diff"

--- gcc/doc/cppopts.texi	2010-12-20 08:26:12.000000000 +0100
+++ gcc/doc/cppopts.texi	2013-03-20 12:08:52.000000000 +0100
@@ -769,7 +769,7 @@
 Enable special code to work around file systems which only permit very
 short file names, such as MS-DOS@.
 
-@itemx --help
+@item --help
 @itemx --target-help
 @opindex help
 @opindex target-help
--- gcc/doc/invoke.texi	2012-01-03 17:43:38.000000000 +0100
+++ gcc/doc/invoke.texi	2013-03-20 12:08:52.000000000 +0100
@@ -165,7 +165,7 @@
 -pipe  -pass-exit-codes  @gol
 -x @var{language}  -v  -###  --help@r{[}=@var{class}@r{[},@dots{}@r{]]}  --target-help  @gol
 --version -wrapper @@@var{file} -fplugin=@var{file} -fplugin-arg-@var{name}=@var{arg}  @gol
--fdump-ada-spec@r{[}-slim@r{]}} -fdump-go-spec=@var{file}
+-fdump-ada-spec@r{[}-slim@r{]} -fdump-go-spec=@var{file}}
 
 @item C Language Options
 @xref{C Dialect Options,,Options Controlling C Dialect}.
@@ -5085,11 +5086,11 @@
 @option{-fdump-rtl-ce3} enable dumping after the three
 if conversion passes.
 
-@itemx -fdump-rtl-cprop_hardreg
+@item -fdump-rtl-cprop_hardreg
 @opindex fdump-rtl-cprop_hardreg
 Dump after hard register copy propagation.
 
-@itemx -fdump-rtl-csa
+@item -fdump-rtl-csa
 @opindex fdump-rtl-csa
 Dump after combining stack adjustments.
 
@@ -5100,11 +5101,11 @@
 @option{-fdump-rtl-cse1} and @option{-fdump-rtl-cse2} enable dumping after
 the two common sub-expression elimination passes.
 
-@itemx -fdump-rtl-dce
+@item -fdump-rtl-dce
 @opindex fdump-rtl-dce
 Dump after the standalone dead code elimination passes.
 
-@itemx -fdump-rtl-dbr
+@item -fdump-rtl-dbr
 @opindex fdump-rtl-dbr
 Dump after delayed branch scheduling.
 
@@ -5149,7 +5150,7 @@
 @opindex fdump-rtl-initvals
 Dump after the computation of the initial value sets.
 
-@itemx -fdump-rtl-into_cfglayout
+@item -fdump-rtl-into_cfglayout
 @opindex fdump-rtl-into_cfglayout
 Dump after converting to cfglayout mode.
 
@@ -5179,7 +5180,7 @@
 @opindex fdump-rtl-rnreg
 Dump after register renumbering.
 
-@itemx -fdump-rtl-outof_cfglayout
+@item -fdump-rtl-outof_cfglayout
 @opindex fdump-rtl-outof_cfglayout
 Dump after converting from cfglayout mode.
 
@@ -5191,7 +5192,7 @@
 @opindex fdump-rtl-postreload
 Dump after post-reload optimizations.
 
-@itemx -fdump-rtl-pro_and_epilogue
+@item -fdump-rtl-pro_and_epilogue
 @opindex fdump-rtl-pro_and_epilogue
 Dump after generating the function pro and epilogues.
How-To-Repeat: 	type make
Comment 1 Edwin Groothuis freebsd_committer 2013-10-26 19:30:08 UTC
Responsible Changed
From-To: freebsd-ports-bugs->gerald

Over to maintainer (via the GNATS Auto Assign Tool)
Comment 2 gerald 2013-10-26 19:40:09 UTC
Thanks for the report, Christoph.  And all the more for already
providing a concrete patch/fix!  Really appreciated.

Since the update of lang/gcc to GCC 4.7 that I had been planning
seems stalled on a number of other ports failing (Let me know if
you'd like to help fixing, that would be awesome!) this report of
yours makes me wonder whether we shouldn't upgrade lang/gcc to
GCC 4.6.4 for now.  Which is one of the two options you mentioned.

What do you think?

Gerald
Comment 3 dfilter freebsd_committer 2013-11-02 23:20:28 UTC
Author: gerald
Date: Sat Nov  2 23:20:14 2013
New Revision: 332557
URL: http://svnweb.freebsd.org/changeset/ports/332557

Log:
  Update to GCC 4.6.4 which, among others, addresses document building
  with new versions of texinfo. [1]
  
  Adopt the new LIB_DEPENDS standard and replace USE_GMAKE by USES=gmake.
  
  Remove an obsolete dependency on bison. [2]
  
  STAGEify.
  
  PR:		183342 [1]
  Reported by:	Christoph Moench-Tegeder <cmt@burggraben.net> [1], marino [2]

Modified:
  head/lang/gcc/Makefile
  head/lang/gcc/distinfo
  head/lang/gcc/pkg-plist

Modified: head/lang/gcc/Makefile
==============================================================================
--- head/lang/gcc/Makefile	Sat Nov  2 23:19:02 2013	(r332556)
+++ head/lang/gcc/Makefile	Sat Nov  2 23:20:14 2013	(r332557)
@@ -2,8 +2,7 @@
 # $FreeBSD$
 
 PORTNAME=	gcc
-PORTVERSION=	4.6.3
-PORTREVISION=	1
+PORTVERSION=	4.6.4
 CATEGORIES=	lang java
 MASTER_SITES=	${MASTER_SITE_GCC}
 MASTER_SITE_SUBDIR=	releases/gcc-${DISTVERSION}
@@ -11,9 +10,9 @@ MASTER_SITE_SUBDIR=	releases/gcc-${DISTV
 MAINTAINER=	gerald@FreeBSD.org
 COMMENT=	GNU Compiler Collection 4.6
 
-LIB_DEPENDS=	gmp:${PORTSDIR}/math/gmp \
-		mpfr:${PORTSDIR}/math/mpfr \
-		mpc:${PORTSDIR}/math/mpc
+LIB_DEPENDS=	libgmp.so:${PORTSDIR}/math/gmp \
+		libmpfr.so:${PORTSDIR}/math/mpfr \
+		libmpc.so:${PORTSDIR}/math/mpc
 BUILD_DEPENDS+=	${LOCALBASE}/bin/as:${PORTSDIR}/devel/binutils
 RUN_DEPENDS+=	${LOCALBASE}/bin/as:${PORTSDIR}/devel/binutils
 
@@ -21,7 +20,7 @@ RUN_DEPENDS+=	${LOCALBASE}/bin/as:${PORT
 BUILD_DEPENDS+=	runtest:${PORTSDIR}/misc/dejagnu
 .endif
 
-CONFLICTS=	gcc-4.6.[4-9]*
+CONFLICTS=	gcc-4.6.4*,1
 
 # DISTVERSION relates to downloads, GCC_VERSION and SUFFIX to names
 # of executables and directories once installed.
@@ -29,7 +28,7 @@ DISTVERSION=	${PORTVERSION}
 GCC_VERSION=	${PORTVERSION:C/(.+)\.[0-9]{8}/\1/}
 SUFFIX=		${PORTVERSION:C/([0-9]+).([0-9]+).*/\1\2/}
 ONLY_FOR_ARCHS=	amd64 i386 ia64 powerpc sparc64
-USES=		bison gmake iconv perl5
+USES=		gmake iconv perl5
 USE_BINUTILS=	yes
 USE_BZIP2=	yes
 USE_PERL5=	build
@@ -45,7 +44,6 @@ OPTIONS_DEFAULT_i386=	JAVA
 OPTIONS_DEFAULT_amd64=	JAVA
 BOOTSTRAP_DESC=		Build using a full bootstrap
 
-NO_STAGE=	yes
 .include <bsd.port.pre.mk>
 
 .if ${ARCH} == "amd64"
@@ -82,11 +80,6 @@ USE_LDCONFIG=	${TARGLIB}
 PLIST_SUB=	GCC_VERSION=${GCC_VERSION} \
 		GNU_HOST=${CONFIGURE_TARGET} \
 		SUFFIX=${SUFFIX}
-MAN1=		cpp${SUFFIX}.1 \
-		g++${SUFFIX}.1 \
-		gcc${SUFFIX}.1 \
-		gcov${SUFFIX}.1 \
-		gfortran${SUFFIX}.1
 INFO=		gcc${SUFFIX}/cpp \
 		gcc${SUFFIX}/cppinternals \
 		gcc${SUFFIX}/gcc \
@@ -107,31 +100,6 @@ RUN_DEPENDS+=	${ECJ_JAR}:${PORTSDIR}/lan
 EXTRA_PATCHES+=	${FILESDIR}/java-patch-hier
 CONFIGURE_ARGS+=--with-ecj-jar=${ECJ_JAR}
 LANGUAGES:=	${LANGUAGES},java
-MAN1+=		aot-compile${SUFFIX}.1 \
-		gappletviewer${SUFFIX}.1 \
-		gc-analyze${SUFFIX}.1 \
-		gcj${SUFFIX}.1 \
-		gcj-dbtool${SUFFIX}.1 \
-		gcjh${SUFFIX}.1 \
-		gij${SUFFIX}.1 \
-		gjar${SUFFIX}.1 \
-		gjarsigner${SUFFIX}.1 \
-		gjavah${SUFFIX}.1 \
-		gjdoc${SUFFIX}.1 \
-		gkeytool${SUFFIX}.1 \
-		gnative2ascii${SUFFIX}.1 \
-		gorbd${SUFFIX}.1 \
-		grmic${SUFFIX}.1 \
-		grmid${SUFFIX}.1 \
-		grmiregistry${SUFFIX}.1 \
-		gserialver${SUFFIX}.1 \
-		gtnameserv${SUFFIX}.1 \
-		jcf-dump${SUFFIX}.1 \
-		jv-convert${SUFFIX}.1 \
-		rebuild-gcj-db${SUFFIX}.1
-MAN3=		ffi${SUFFIX}.3 \
-		ffi_call${SUFFIX}.3 \
-		ffi_prep_cif${SUFFIX}.3
 INFO+=		gcc${SUFFIX}/cp-tools \
 		gcc${SUFFIX}/gcj
 PLIST_SUB+=	JAVA=""
@@ -155,13 +123,11 @@ full-regression-test: build
 .endif
 
 post-install:
-	${RM} -f ${PREFIX}/man/man7/fsf-funding.7 \
-	         ${PREFIX}/man/man7/gfdl.7 ${PREFIX}/man/man7/gpl.7
-	${RM} -f ${TARGLIB}/*.la
+	${RM} -f ${STAGEDIR}${TARGLIB}/*.la
 	# Add target libraries and include files to packaging list.
 	${RM} -f ${WRKDIR}/PLIST.lib
 .for d in ${TARGLIB:S/^${PREFIX}\///} ${LIBEXEC:S/^${PREFIX}\///} include/gcj include/gnu include/java include/javax
-	cd ${PREFIX} ; if [ -d $d ]; then \
+	cd ${STAGEDIR}${PREFIX} ; if [ -d $d ]; then \
 	    ${FIND} $d -type f -o -type l >>${WRKDIR}/PLIST.lib ;\
 	    ${FIND} $d -type d | ${SORT} -r \
 	        | ${SED} -e 's/^/@dirrm /g' >>${WRKDIR}/PLIST.lib ;\

Modified: head/lang/gcc/distinfo
==============================================================================
--- head/lang/gcc/distinfo	Sat Nov  2 23:19:02 2013	(r332556)
+++ head/lang/gcc/distinfo	Sat Nov  2 23:20:14 2013	(r332557)
@@ -1,2 +1,2 @@
-SHA256 (gcc-4.6.3.tar.bz2) = e8f5853d4eec2f5ebaf8a72ae4d53c436aacf98153b2499f8635b48c4718a093
-SIZE (gcc-4.6.3.tar.bz2) = 71999439
+SHA256 (gcc-4.6.4.tar.bz2) = 35af16afa0b67af9b8eb15cafb76d2bc5f568540552522f5dc2c88dd45d977e8
+SIZE (gcc-4.6.4.tar.bz2) = 72006076

Modified: head/lang/gcc/pkg-plist
==============================================================================
--- head/lang/gcc/pkg-plist	Sat Nov  2 23:19:02 2013	(r332556)
+++ head/lang/gcc/pkg-plist	Sat Nov  2 23:20:14 2013	(r332557)
@@ -11,6 +11,11 @@ bin/gcc%%SUFFIX%%
 bin/gcov%%SUFFIX%%
 bin/gfortran%%SUFFIX%%
 info/gcc%%SUFFIX%%/dir
+man/man1/cpp%%SUFFIX%%.1.gz
+man/man1/g++%%SUFFIX%%.1.gz
+man/man1/gcc%%SUFFIX%%.1.gz
+man/man1/gcov%%SUFFIX%%.1.gz
+man/man1/gfortran%%SUFFIX%%.1.gz
 %%JAVA%%share/gcc-%%GCC_VERSION%%/python/libjava/aotcompile.py
 %%JAVA%%share/gcc-%%GCC_VERSION%%/python/libjava/classfile.py
 %%JAVA%%@dirrm share/gcc-%%GCC_VERSION%%/python/libjava
@@ -44,6 +49,31 @@ share/gcc-%%GCC_VERSION%%/python/libstdc
 %%JAVA%%bin/jv-convert%%SUFFIX%%
 %%JAVA%%bin/rebuild-gcj-db%%SUFFIX%%
 %%JAVA%%libdata/pkgconfig/libgcj-4.6.pc
+%%JAVA%%man/man1/aot-compile%%SUFFIX%%.1.gz
+%%JAVA%%man/man1/gappletviewer%%SUFFIX%%.1.gz
+%%JAVA%%man/man1/gc-analyze%%SUFFIX%%.1.gz
+%%JAVA%%man/man1/gcj%%SUFFIX%%.1.gz
+%%JAVA%%man/man1/gcj-dbtool%%SUFFIX%%.1.gz
+%%JAVA%%man/man1/gcjh%%SUFFIX%%.1.gz
+%%JAVA%%man/man1/gij%%SUFFIX%%.1.gz
+%%JAVA%%man/man1/gjar%%SUFFIX%%.1.gz
+%%JAVA%%man/man1/gjarsigner%%SUFFIX%%.1.gz
+%%JAVA%%man/man1/gjavah%%SUFFIX%%.1.gz
+%%JAVA%%man/man1/gjdoc%%SUFFIX%%.1.gz
+%%JAVA%%man/man1/gkeytool%%SUFFIX%%.1.gz
+%%JAVA%%man/man1/gnative2ascii%%SUFFIX%%.1.gz
+%%JAVA%%man/man1/gorbd%%SUFFIX%%.1.gz
+%%JAVA%%man/man1/grmic%%SUFFIX%%.1.gz
+%%JAVA%%man/man1/grmid%%SUFFIX%%.1.gz
+%%JAVA%%man/man1/grmiregistry%%SUFFIX%%.1.gz
+%%JAVA%%man/man1/gserialver%%SUFFIX%%.1.gz
+%%JAVA%%man/man1/gtnameserv%%SUFFIX%%.1.gz
+%%JAVA%%man/man1/jcf-dump%%SUFFIX%%.1.gz
+%%JAVA%%man/man1/jv-convert%%SUFFIX%%.1.gz
+%%JAVA%%man/man1/rebuild-gcj-db%%SUFFIX%%.1.gz
+%%JAVA%%man/man3/ffi%%SUFFIX%%.3.gz
+%%JAVA%%man/man3/ffi_call%%SUFFIX%%.3.gz
+%%JAVA%%man/man3/ffi_prep_cif%%SUFFIX%%.3.gz
 %%JAVA%%share/java/libgcj-%%GCC_VERSION%%.jar
 %%JAVA%%share/java/libgcj-tools-%%GCC_VERSION%%.jar
 @exec if type ccache-update-links >/dev/null 2>&1; then ccache-update-links -v; fi
_______________________________________________
svn-ports-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/svn-ports-all
To unsubscribe, send any mail to "svn-ports-all-unsubscribe@freebsd.org"
Comment 4 Gerald Pfeifer freebsd_committer 2013-11-02 23:31:56 UTC
State Changed
From-To: open->closed

I did go ahead and performed the wholesale update from 4.6.3 to 4.6.4 
which should be safe enough. 

Christoph and me also have a thread going on off-GNATS, and his analysis 
and report have been very helpful.  Thanks!
Comment 5 dfilter freebsd_committer 2013-12-03 23:14:43 UTC
Author: gerald
Date: Tue Dec  3 23:14:35 2013
New Revision: 335597
URL: http://svnweb.freebsd.org/changeset/ports/335597

Log:
  Fix the build with GCC 4.7 and later (which do fewer extraneous
  #includes of system include files). [1]
  
  On the way adjust to the new LIB_DEPENDS format.
  
  PR:		183342 [1]
  Submitted by:	Christoph Moench-Tegeder <cmt@burggraben.net> [1]

Added:
  head/games/battletanks/files/patch-mrt-base_file.h   (contents, props changed)
Modified:
  head/games/battletanks/Makefile

Modified: head/games/battletanks/Makefile
==============================================================================
--- head/games/battletanks/Makefile	Tue Dec  3 22:10:25 2013	(r335596)
+++ head/games/battletanks/Makefile	Tue Dec  3 23:14:35 2013	(r335597)
@@ -12,9 +12,9 @@ COMMENT=	Fast 2D tank arcade game with m
 
 BUILD_DEPENDS=	zip:${PORTSDIR}/archivers/zip
 LIB_DEPENDS=	sigc-2.0.0:${PORTSDIR}/devel/libsigc++20 \
-		expat.6:${PORTSDIR}/textproc/expat2 \
-		vorbisfile.6:${PORTSDIR}/audio/libvorbis \
-		smpeg.1:${PORTSDIR}/multimedia/smpeg
+		libexpat.so:${PORTSDIR}/textproc/expat2 \
+		libvorbisfile.so:${PORTSDIR}/audio/libvorbis \
+		libsmpeg.so:${PORTSDIR}/multimedia/smpeg
 
 USES=		pkgconfig
 USE_BZIP2=	yes

Added: head/games/battletanks/files/patch-mrt-base_file.h
==============================================================================
--- /dev/null	00:00:00 1970	(empty, because file is newly added)
+++ head/games/battletanks/files/patch-mrt-base_file.h	Tue Dec  3 23:14:35 2013	(r335597)
@@ -0,0 +1,10 @@
+--- mrt/base_file.h.orig	2013-11-16 13:43:12.000000000 +0100
++++ mrt/base_file.h	2013-11-16 13:44:09.000000000 +0100
+@@ -20,6 +20,7 @@
+ */
+ 
+ #include <string>
++#include <sys/types.h>
+ #include "export_mrt.h"
+ 
+ namespace mrt {
_______________________________________________
svn-ports-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/svn-ports-all
To unsubscribe, send any mail to "svn-ports-all-unsubscribe@freebsd.org"
Comment 6 dfilter freebsd_committer 2013-12-03 23:18:23 UTC
Author: gerald
Date: Tue Dec  3 23:18:16 2013
New Revision: 335598
URL: http://svnweb.freebsd.org/changeset/ports/335598

Log:
  Fix the build with GCC 4.7 and later (which do fewer extraneous
  #includes of system include files).
  
  PR:		183342
  Submitted by:	Christoph Moench-Tegeder <cmt@burggraben.net>

Added:
  head/net/pvm++/files/patch-mrt-base_file.h   (contents, props changed)

Added: head/net/pvm++/files/patch-mrt-base_file.h
==============================================================================
--- /dev/null	00:00:00 1970	(empty, because file is newly added)
+++ head/net/pvm++/files/patch-mrt-base_file.h	Tue Dec  3 23:18:16 2013	(r335598)
@@ -0,0 +1,10 @@
+--- mrt/base_file.h.orig	2013-11-16 13:43:12.000000000 +0100
++++ mrt/base_file.h	2013-11-16 13:44:09.000000000 +0100
+@@ -20,6 +20,7 @@
+ */
+ 
+ #include <string>
++#include <sys/types.h>
+ #include "export_mrt.h"
+ 
+ namespace mrt {
_______________________________________________
svn-ports-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/svn-ports-all
To unsubscribe, send any mail to "svn-ports-all-unsubscribe@freebsd.org"
Comment 7 dfilter freebsd_committer 2013-12-03 23:21:25 UTC
Author: gerald
Date: Tue Dec  3 23:21:18 2013
New Revision: 335599
URL: http://svnweb.freebsd.org/changeset/ports/335599

Log:
  Fix the build with GCC 4.7 and later (which do fewer extraneous
  #includes of system include files).
  
  PR:		183342
  Submitted by:	Christoph Moench-Tegeder <cmt@burggraben.net>

Added:
  head/net/xpvm/files/patch-mrt-base_file.h   (contents, props changed)

Added: head/net/xpvm/files/patch-mrt-base_file.h
==============================================================================
--- /dev/null	00:00:00 1970	(empty, because file is newly added)
+++ head/net/xpvm/files/patch-mrt-base_file.h	Tue Dec  3 23:21:18 2013	(r335599)
@@ -0,0 +1,10 @@
+--- mrt/base_file.h.orig	2013-11-16 13:43:12.000000000 +0100
++++ mrt/base_file.h	2013-11-16 13:44:09.000000000 +0100
+@@ -20,6 +20,7 @@
+ */
+ 
+ #include <string>
++#include <sys/types.h>
+ #include "export_mrt.h"
+ 
+ namespace mrt {
_______________________________________________
svn-ports-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/svn-ports-all
To unsubscribe, send any mail to "svn-ports-all-unsubscribe@freebsd.org"
Comment 8 dfilter freebsd_committer 2013-12-07 22:23:37 UTC
Author: gerald
Date: Sat Dec  7 22:23:29 2013
New Revision: 335853
URL: http://svnweb.freebsd.org/changeset/ports/335853

Log:
  Unbreak this port by applying a simplified version of the real patch that
  was submitted [1] which
  - adds USE_GCC since that's how libpvm3.a (a dependency) was built;
  - works around pvm's aimk build system to pass our LDFLAGS.
  
  While we are at it, migrate to the new LIB_DEPENDS format.
  
  PR:             183342 [1]
  Submitted by:   Christoph Moench-Tegeder <cmt@burggraben.net> [1]
  Pointyhat to:	gerald [1]

Deleted:
  head/net/xpvm/files/patch-mrt-base_file.h
Modified:
  head/net/xpvm/Makefile
  head/net/xpvm/files/patch-src:Makefile.aimk

Modified: head/net/xpvm/Makefile
==============================================================================
--- head/net/xpvm/Makefile	Sat Dec  7 22:08:49 2013	(r335852)
+++ head/net/xpvm/Makefile	Sat Dec  7 22:23:29 2013	(r335853)
@@ -13,13 +13,12 @@ EXTRACT_SUFX=	.tgz
 MAINTAINER=	ports@FreeBSD.org
 COMMENT=	A Graphical Console and Monitor for PVM
 
-BROKEN=		Fails to patch
-
 MAKE_JOBS_UNSAFE=	yes
 
+USE_GCC=	yes
 BUILD_DEPENDS=	${LOCALBASE}/lib/libpvm3.a:${PORTSDIR}/net/pvm
 RUN_DEPENDS:=	${BUILD_DEPENDS}
-LIB_DEPENDS=	tk84.1:${PORTSDIR}/x11-toolkits/tk84
+LIB_DEPENDS=	libtk84.so:${PORTSDIR}/x11-toolkits/tk84
 
 WRKSRC=		${WRKDIR}/xpvm
 PVM_ROOT?=	${LOCALBASE}/lib/pvm

Modified: head/net/xpvm/files/patch-src:Makefile.aimk
==============================================================================
--- head/net/xpvm/files/patch-src:Makefile.aimk	Sat Dec  7 22:08:49 2013	(r335852)
+++ head/net/xpvm/files/patch-src:Makefile.aimk	Sat Dec  7 22:23:29 2013	(r335853)
@@ -1,6 +1,14 @@
-diff -ruN xpvm.orig/src/Makefile.aimk xpvm/src/Makefile.aimk
---- src/Makefile.aimk	Fri Apr 10 05:11:22 1998
-+++ src/Makefile.aimk	Thu Apr  1 13:38:57 2004
+--- src/Makefile.aimk.orig	1998-04-09 23:11:22.000000000 +0200
++++ src/Makefile.aimk	2013-11-16 20:41:32.000000000 +0100
+@@ -29,7 +29,7 @@
+ #CC			=	gcc
+ 
+ CFLAGS		=	$(CFLOPTS) $(PVMVERSION) -DIMA_$(PVM_ARCH) $(ARCHCFLAGS)
+-LFLAGS		=	$(ARCHCFLAGS)
++LFLAGS		=	$(LDFLAGS) $(ARCHCFLAGS)
+ 
+ AIMK		=	$(PVM_ROOT)/lib/aimk
+ 
 @@ -39,36 +39,39 @@
  #
  
@@ -100,3 +108,4 @@ diff -ruN xpvm.orig/src/Makefile.aimk xp
 +				$(LOCALBASE)/include/pvmtev.h \
  				$(TRCDIR)/trcdef.h $(TRCDIR)/trctype.h \
  				$(TRCDIR)/trcproto.h $(TRCDIR)/trccompat.h
+ 
_______________________________________________
svn-ports-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/svn-ports-all
To unsubscribe, send any mail to "svn-ports-all-unsubscribe@freebsd.org"
Comment 9 gerald 2013-12-07 22:38:35 UTC
Oops, all those commits in the last week should have referred to
182136 instead.

Gerald
Comment 10 dfilter freebsd_committer 2013-12-08 18:50:58 UTC
Author: oliver
Date: Sun Dec  8 18:50:51 2013
New Revision: 335919
URL: http://svnweb.freebsd.org/changeset/ports/335919

Log:
  remove GCC version check to support GCC versions 4.7 and up
  
  PR:		184577, 183342
  Submitted by:	Christoph Moench-Tegeder <cmt@burggraben.net>

Added:
  head/x11-toolkits/gigi/files/patch-GG-adobe-cmath.hpp   (contents, props changed)

Added: head/x11-toolkits/gigi/files/patch-GG-adobe-cmath.hpp
==============================================================================
--- /dev/null	00:00:00 1970	(empty, because file is newly added)
+++ head/x11-toolkits/gigi/files/patch-GG-adobe-cmath.hpp	Sun Dec  8 18:50:51 2013	(r335919)
@@ -0,0 +1,24 @@
+--- GG/adobe/cmath.hpp.orig	2011-08-29 15:14:45.000000000 +0200
++++ GG/adobe/cmath.hpp	2013-12-08 12:40:51.000000000 +0100
+@@ -31,21 +31,7 @@
+ #define ADOBE_HAS_C99_STD_MATH_H
+ 
+ #elif defined(__GNUC__)
+-
+-// Guessing at gcc 3 support
+-#if  (__GNUC__ == 3) && (__GNUC_MINOR__ > 2)
+-
+-#define ADOBE_HAS_CPP_CMATH 
+-
+-#elif ((__GNUC__ == 4) && (__GNUC_MINOR__ <= 6))
+-/*
+-    The currently supported version of GNUC has C99 extensions in math.h. But no TR1 extensions.
+-*/
+ #define ADOBE_HAS_C99_MATH_H
+- 
+-#else
+-#error "Unknown GCC compiler configuration for cmath (last known version is 4.0.1)."
+-#endif
+ 
+ #elif defined(_MSC_VER)
+ 
_______________________________________________
svn-ports-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/svn-ports-all
To unsubscribe, send any mail to "svn-ports-all-unsubscribe@freebsd.org"