Bug 183402 - misc/mc port broken
Summary: misc/mc port broken
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: Max Khon
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-10-28 15:30 UTC by Dmitry
Modified: 2013-11-02 22:28 UTC (History)
0 users

See Also:


Attachments
smime.p7s (6.14 KB, application/pkcs7-signature)
2013-10-31 22:04 UTC, Ralf van der Enden
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Dmitry 2013-10-28 15:30:00 UTC
/usr/ports/misc/mc > make
===>   mc-4.8.10 depends on executable: gmake - found
===>   mc-4.8.10 depends on executable: pkgconf - found
===>   mc-4.8.10 depends on package: libtool>=2.4 - found
===>   mc-4.8.10 depends on file: /usr/local/bin/perl5.16.3 - found
===>   mc-4.8.10 depends on shared library: libssh2.so - found
===>   mc-4.8.10 depends on shared library: libiconv.so.3 - found
===>   mc-4.8.10 depends on shared library: libintl.so - found
===>   mc-4.8.10 depends on shared library: glib-2.0 - found
===>   mc-4.8.10 depends on shared library: pcre - found
===>  Configuring for mc-4.8.10
configure: error: invalid feature name: configdir=/usr/local/etc
===>  Script "configure" failed unexpectedly.

root@eepc:/usr/ports/misc/deco # cat /var/db/ports/misc_mc/options 
# This file is auto-generated by 'make config'.
# Options for mc-4.8.10
_OPTIONS_READ=mc-4.8.10
_FILE_COMPLETE_OPTIONS_LIST=DOCS EDITOR ICONV NLS SMB SUBSHELL X11 SLANG NCURSES
OPTIONS_FILE_UNSET+=DOCS
OPTIONS_FILE_SET+=EDITOR
OPTIONS_FILE_SET+=ICONV
OPTIONS_FILE_SET+=NLS
OPTIONS_FILE_UNSET+=SMB
OPTIONS_FILE_UNSET+=SUBSHELL
OPTIONS_FILE_UNSET+=X11
OPTIONS_FILE_UNSET+=SLANG
OPTIONS_FILE_SET+=NCURSES
Comment 1 Edwin Groothuis freebsd_committer 2013-10-28 15:30:09 UTC
Responsible Changed
From-To: freebsd-ports-bugs->fjoe

Over to maintainer (via the GNATS Auto Assign Tool)
Comment 2 vsjcfm 2013-10-29 21:21:29 UTC
It's a duplicate for ports/183284, so should be closed.
Comment 3 vsjcfm 2013-10-29 21:42:08 UTC
Sorry, I mixed up PR numbers. ports/183284 is a duplicate for ports/183170.
This problem caused by r331760 in ports/head commited Sun Oct 27
11:58:20 2013 UTC -
http://svnweb.freebsd.org/ports?view=revision&revision=331760
MC won't build (even configure) regardless of chosen screen library.
Reverting bsd.options.mk to previous version (r329293) helps (MC
builds with SLANG at least). But it's an incorrect fix, of course.
Comment 4 dfilter service freebsd_committer 2013-11-02 22:08:10 UTC
Author: nemysis
Date: Sat Nov  2 22:08:01 2013
New Revision: 332543
URL: http://svnweb.freebsd.org/changeset/ports/332543

Log:
  - Change SMB and NCURSES
  - Change pkg-plist, fix MAN
  
  PR:		ports/183170 ports/183284 ports/183402
  Submitted by:	various
  Approved by:	pawel / wg (mentors, implicit)

Modified:
  head/misc/mc/Makefile
  head/misc/mc/pkg-plist

Modified: head/misc/mc/Makefile
==============================================================================
--- head/misc/mc/Makefile	Sat Nov  2 21:30:51 2013	(r332542)
+++ head/misc/mc/Makefile	Sat Nov  2 22:08:01 2013	(r332543)
@@ -45,8 +45,9 @@ NLS_USES=		gettext
 
 SLANG_LIB_DEPENDS=	libslang.so:${PORTSDIR}/devel/libslang2
 
-SMB_CONFIGURE_ENABLE=	vfs-smb configdir=${LOCALBASE}/etc \
-			codepagedir=${LOCALBASE}/etc/codepages
+SMB_CONFIGURE_ENABLE=	vfs-smb
+SMB_CONFIGURE_ON=	--with-smb-configdir=${LOCALBASE}/etc \
+			--with-smb-codepagedir=${LOCALBASE}/etc/codepages
 
 SUBSHELL_CONFIGURE_WITH=	subshell
 
@@ -77,7 +78,7 @@ CONFIGURE_ARGS+=--with-screen=slang --wi
 .endif
 
 .if ${PORT_OPTIONS:MNCURSES}
-CONFIGURE_ARGS+=--with-screen=ncurses --with-ncurses-includes=${LOCALBASE}/include
+CONFIGURE_ARGS+=--with-screen=ncurses
 .endif
 
 post-patch:

Modified: head/misc/mc/pkg-plist
==============================================================================
--- head/misc/mc/pkg-plist	Sat Nov  2 21:30:51 2013	(r332542)
+++ head/misc/mc/pkg-plist	Sat Nov  2 22:08:01 2013	(r332543)
@@ -2,7 +2,7 @@ bin/mc
 bin/mcdiff
 %%EDITOR%%bin/mcedit
 bin/mcview
-%%EDITOR%%etc/mc/edit.indent.rc
+etc/mc/edit.indent.rc
 etc/mc/filehighlight.ini
 etc/mc/mc.default.keymap
 etc/mc/mc.emacs.keymap
@@ -77,15 +77,15 @@ libexec/mc/mc-wrapper.csh
 libexec/mc/mc-wrapper.sh
 libexec/mc/mc.csh
 libexec/mc/mc.sh
-man/es/man1/mc.1.gz
-man/hu/man1/mc.1.gz
-man/it/man1/mc.1.gz
+%%NLS%%man/es/man1/mc.1.gz
+%%NLS%%man/hu/man1/mc.1.gz
+%%NLS%%man/it/man1/mc.1.gz
 man/man1/mc.1.gz
 man/man1/mcedit.1.gz
 man/man1/mcview.1.gz
-man/pl/man1/mc.1.gz
-man/ru/man1/mc.1.gz
-man/sr/man1/mc.1.gz
+%%NLS%%man/pl/man1/mc.1.gz
+%%NLS%%man/ru/man1/mc.1.gz
+%%NLS%%man/sr/man1/mc.1.gz
 %%NLS%%share/locale/az/LC_MESSAGES/mc.mo
 %%NLS%%share/locale/be/LC_MESSAGES/mc.mo
 %%NLS%%share/locale/bg/LC_MESSAGES/mc.mo
_______________________________________________
svn-ports-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/svn-ports-all
To unsubscribe, send any mail to "svn-ports-all-unsubscribe@freebsd.org"
Comment 5 Rusmir Dusko freebsd_committer 2013-11-02 22:28:53 UTC
State Changed
From-To: open->closed

Commited, fixed misc/mc. Thanks for the Report!