Bug 183683 - multimedia/vlc 2.1.0_5,4 cannot build on FreeBSD 10.0-BETA2
multimedia/vlc 2.1.0_5,4 cannot build on FreeBSD 10.0-BETA2
Status: Closed DUPLICATE of bug 172185
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s)
Any Any
: Normal Affects Only Me
Assigned To: freebsd-multimedia
Depends on:
  Show dependency treegraph
Reported: 2013-11-05 13:20 UTC by lumiwa
Modified: 2014-06-11 12:28 UTC (History)
1 user (show)

See Also:


Note You need to log in before you can comment on or make changes to this bug.
Description lumiwa 2013-11-05 13:20:00 UTC
Try to build vlc 2.1.0_5,4 Previous version built without problem) and I got:

GEN      libvlc.pc
2 warnings generated.
1 warning generated.
1 warning generated.
9 warnings generated.
  CCLD     libvlc.la
config.status: creating lib/libvlc.pc
gmake[5]: Leaving directory `/usr/ports/multimedia/vlc/work/vlc-2.1.0/lib'
gmake[4]: Leaving directory `/usr/ports/multimedia/vlc/work/vlc-2.1.0/lib'
Making all in bin
gmake[4]: Entering directory `/usr/ports/multimedia/vlc/work/vlc-2.1.0/bin'
  CC       vlc.o
  CC       override.o
  CC       rootwrap.o
  CC       vlc_static-vlc.o
  CC       vlc_static-override.o
  CC       cachegen.o
  CCLD     vlc-cache-gen
  CCLD     vlc-wrapper
  CCLD     vlc-static
  CCLD     vlc
  GEN      ../modules/plugins.dat
gmake[4]: *** [../modules/plugins.dat] Bus error (core dumped)
gmake[4]: Leaving directory `/usr/ports/multimedia/vlc/work/vlc-2.1.0/bin'
gmake[3]: *** [all-recursive] Error 1
gmake[3]: Leaving directory `/usr/ports/multimedia/vlc/work/vlc-2.1.0'
gmake[2]: *** [all] Error 2
gmake[2]: Leaving directory `/usr/ports/multimedia/vlc/work/vlc-2.1.0'
===> Compilation failed unexpectedly.
Try to set MAKE_JOBS_UNSAFE=yes and rebuild before reporting the failure to
the maintainer.
*** Error code 1

make[1]: stopped in /usr/ports/multimedia/vlc
*** Error code 1

make: stopped in /usr/ports/multimedia/vlc

How-To-Repeat: It happened every time when I try to install port.
Comment 1 Mark Linimon freebsd_committer 2013-11-11 00:59:30 UTC
Responsible Changed
From-To: freebsd-amd64->freebsd-ports-bugs

ports PR.
Comment 2 Edwin Groothuis freebsd_committer 2013-11-11 00:59:51 UTC
Responsible Changed
From-To: freebsd-ports-bugs->freebsd-multimedia

Over to maintainer (via the GNATS Auto Assign Tool)
Comment 3 william88 2013-11-11 10:46:32 UTC
Try changing your options, it is some plugin that cause this error.

William Grzybowski
Curitiba/PR - Brasil
Comment 4 lumiwa 2013-11-21 14:54:34 UTC
It is build with qt4 plugin disabled but it is not what I want it.

Comment 5 Tijl Coosemans freebsd_committer 2014-06-11 12:28:19 UTC

*** This bug has been marked as a duplicate of bug 172185 ***