Bug 183759 - [iwn] [wlan] Interface dies, OACTIVE set on wlan0
Summary: [iwn] [wlan] Interface dies, OACTIVE set on wlan0
Status: Closed Overcome By Events
Alias: None
Product: Base System
Classification: Unclassified
Component: wireless (show other bugs)
Version: unspecified
Hardware: Any Any
: Normal Affects Only Me
Assignee: freebsd-wireless mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-11-07 18:50 UTC by Gavin Atkinson
Modified: 2019-01-03 22:14 UTC (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Gavin Atkinson freebsd_committer freebsd_triage 2013-11-07 18:50:00 UTC
With iwn(4) (Intel 5100) I often see the interface disassociate from the WPA2 11n network it is associated with.  wpa_supplicant gives reason=0.

When this happens, according to ifconfig OACTIVE is set on wlan0, and not on iwn0.  Once in this state, it seems that destroying wlan0 and recreating it is necessary in order to get things working again.

I have started binary searching for the commit that introduced this behaviour.  So far, I have not yet managed to recreate it with r252500, but it can happen within 10 minutes on r254080.  I have not yet proven it, but I believe that disabling ht (with ifconfig wlan0 -ht) prevents it from happening.

Gavin

How-To-Repeat: Associate to 11n network, pass some data, wait.
Comment 1 Gavin Atkinson freebsd_committer freebsd_triage 2013-11-07 20:29:05 UTC
Responsible Changed
From-To: freebsd-bugs->freebsd-wireless

Over to -wireless
Comment 2 rs.os 2016-01-08 10:52:02 UTC
The same behaviour occurs for me with an Intel Centrino Ultimate-N 6300 (I use the iwn6000fw driver). I have got the same wpa_supplicant reason.

I will test whether passing -ht prevents this behaviour.
Comment 3 Eitan Adler freebsd_committer freebsd_triage 2018-05-28 19:46:08 UTC
batch change:

For bugs that match the following
-  Status Is In progress 
AND
- Untouched since 2018-01-01.
AND
- Affects Base System OR Documentation

DO:

Reset to open status.


Note:
I did a quick pass but if you are getting this email it might be worthwhile to double check to see if this bug ought to be closed.
Comment 4 rs.os 2018-05-29 20:31:41 UTC
Hello,

thanks for the update. I cannot reproduce this after all the time.
Comment 5 Andriy Voskoboinyk freebsd_committer 2019-01-03 22:14:32 UTC
As I can see from comment #4 this issue is not relevant anymore (feel free to reopen if thats not true).