Bug 184166 - [PATCH] comms/lrzsz: fix StageDIR
Summary: [PATCH] comms/lrzsz: fix StageDIR
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: Dirk Meyer
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-11-22 10:00 UTC by takefu
Modified: 2013-11-22 19:40 UTC (History)
1 user (show)

See Also:


Attachments
lrzsz-0.12.20_4.patch (1.03 KB, patch)
2013-11-22 10:00 UTC, takefu
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description takefu 2013-11-22 10:00:00 UTC
fix StageDir

Port maintainer (dinoex@FreeBSD.org) is cc'd.
Comment 1 Edwin Groothuis freebsd_committer 2013-11-22 10:00:09 UTC
Responsible Changed
From-To: freebsd-ports-bugs->dinoex

Over to maintainer (via the GNATS Auto Assign Tool)
Comment 2 Dirk Meyer freebsd_committer 2013-11-22 18:47:57 UTC
State Changed
From-To: open->suspended


The patch introduce a regression: 

run as user: 
make clean stage check-orphans 

[...] 
rm -f /usr/local/bin/`echo lsx | sed -e 's,x,x,'` 
rm: /usr/local/bin/lsx: Permission denied 
*** [install-exec-local] Error code 1
Comment 3 dfilter service freebsd_committer 2013-11-22 19:33:49 UTC
Author: dinoex
Date: Fri Nov 22 19:33:41 2013
New Revision: 334608
URL: http://svnweb.freebsd.org/changeset/ports/334608

Log:
  - use STAGEDIR
  - honor NLS option
  PR:		184166

Added:
  head/comms/lrzsz/files/patch-Makefile.in   (contents, props changed)
  head/comms/lrzsz/files/patch-Makefile.in.in   (contents, props changed)
Modified:
  head/comms/lrzsz/Makefile
  head/comms/lrzsz/pkg-plist

Modified: head/comms/lrzsz/Makefile
==============================================================================
--- head/comms/lrzsz/Makefile	Fri Nov 22 19:24:37 2013	(r334607)
+++ head/comms/lrzsz/Makefile	Fri Nov 22 19:33:41 2013	(r334608)
@@ -10,10 +10,18 @@ MASTER_SITES=	http://ohse.de/uwe/release
 MAINTAINER=	dinoex@FreeBSD.org
 COMMENT=	Receive/Send files via X/Y/ZMODEM protocol.  (unrestrictive)
 
-NO_STAGE=	yes
+LICENSE=	GPLv2
 
 GNU_CONFIGURE=	yes
 ALL_TARGET=	all # vcheck
-MAN1=		lrz.1 lsz.1
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MNLS}
+USES+=		gettext
+PLIST_FILES+=	share/locale/de/LC_MESSAGES/lrzsz.mo
+.else
+CONFIGURE_ARGS+=	--disable-nls
+.endif
 
 .include <bsd.port.mk>

Added: head/comms/lrzsz/files/patch-Makefile.in
==============================================================================
--- /dev/null	00:00:00 1970	(empty, because file is newly added)
+++ head/comms/lrzsz/files/patch-Makefile.in	Fri Nov 22 19:33:41 2013	(r334608)
@@ -0,0 +1,19 @@
+--- src/Makefile.in.orig	1998-12-30 17:31:46.000000000 +0100
++++ src/Makefile.in	2013-11-22 19:52:13.000000000 +0100
+@@ -372,13 +372,13 @@
+ 	rm -f $(DESTDIR)/$(bindir)/`echo lsb | sed -e '$(transform)'`
+ 	ln $(DESTDIR)/$(bindir)/`echo lsz |sed -e '$(transform)'` \
+ 		$(DESTDIR)/$(bindir)/`echo lsb |sed -e '$(transform)'` 
+-	rm -f $(bindir)/`echo lsx | sed -e '$(transform)'`
++	rm -f $(DESTDIR)/$(bindir)/`echo lsx | sed -e '$(transform)'`
+ 	ln $(DESTDIR)/$(bindir)/`echo lsz |sed -e '$(transform)'` \
+ 		$(DESTDIR)/$(bindir)/`echo lsx |sed -e '$(transform)'` 
+-	rm -f $(bindir)/`echo lrb | sed -e '$(transform)'`
++	rm -f $(DESTDIR)/$(bindir)/`echo lrb | sed -e '$(transform)'`
+ 	ln $(DESTDIR)/$(bindir)/`echo lrz |sed -e '$(transform)'` \
+ 		$(DESTDIR)/$(bindir)/`echo lrb |sed -e '$(transform)'` 
+-	rm -f $(bindir)/`echo lrx | sed -e '$(transform)'`
++	rm -f $(DESTDIR)/$(bindir)/`echo lrx | sed -e '$(transform)'`
+ 	ln $(DESTDIR)/$(bindir)/`echo lrz |sed -e '$(transform)'` \
+ 		$(DESTDIR)/$(bindir)/`echo lrx |sed -e '$(transform)'` 
+ #	rm -f $(bindir)/`echo lrzszbug | sed -e '$(transform)'`

Added: head/comms/lrzsz/files/patch-Makefile.in.in
==============================================================================
--- /dev/null	00:00:00 1970	(empty, because file is newly added)
+++ head/comms/lrzsz/files/patch-Makefile.in.in	Fri Nov 22 19:33:41 2013	(r334608)
@@ -0,0 +1,39 @@
+--- po/Makefile.in.in.orig	1998-04-26 15:22:40.000000000 +0200
++++ po/Makefile.in.in	2013-11-22 20:12:26.000000000 +0100
+@@ -110,9 +110,9 @@
+ install-data-no: all
+ install-data-yes: all
+ 	if test -r $(MKINSTALLDIRS); then \
+-	  $(MKINSTALLDIRS) $(datadir); \
++	  $(MKINSTALLDIRS) ${DESTDIR}$(datadir); \
+ 	else \
+-	  $(top_srcdir)/mkinstalldirs $(datadir); \
++	  $(top_srcdir)/mkinstalldirs ${DESTDIR}$(datadir); \
+ 	fi
+ 	@catalogs='$(CATALOGS)'; \
+ 	for cat in $$catalogs; do \
+@@ -122,7 +122,7 @@
+ 	    *)     destdir=$(localedir);; \
+ 	  esac; \
+ 	  lang=`echo $$cat | sed 's/\$(CATOBJEXT)$$//'`; \
+-	  dir=$$destdir/$$lang/LC_MESSAGES; \
++	  dir=${DESTDIR}$$destdir/$$lang/LC_MESSAGES; \
+ 	  if test -r $(MKINSTALLDIRS); then \
+ 	    $(MKINSTALLDIRS) $$dir; \
+ 	  else \
+@@ -152,12 +152,12 @@
+ 	done
+ 	if test "$(PACKAGE)" = "gettext"; then \
+ 	  if test -r $(MKINSTALLDIRS); then \
+-	    $(MKINSTALLDIRS) $(gettextsrcdir); \
++	    $(MKINSTALLDIRS) ${DESTDIR}$(gettextsrcdir); \
+ 	  else \
+-	    $(top_srcdir)/mkinstalldirs $(gettextsrcdir); \
++	    $(top_srcdir)/mkinstalldirs ${DESTDIR}$(gettextsrcdir); \
+ 	  fi; \
+ 	  $(INSTALL_DATA) $(srcdir)/Makefile.in.in \
+-			  $(gettextsrcdir)/Makefile.in.in; \
++			  ${DESTDIR}$(gettextsrcdir)/Makefile.in.in; \
+ 	else \
+ 	  : ; \
+ 	fi

Modified: head/comms/lrzsz/pkg-plist
==============================================================================
--- head/comms/lrzsz/pkg-plist	Fri Nov 22 19:24:37 2013	(r334607)
+++ head/comms/lrzsz/pkg-plist	Fri Nov 22 19:33:41 2013	(r334608)
@@ -4,4 +4,5 @@ bin/lrz
 bin/lsb
 bin/lsx
 bin/lsz
-share/locale/de/LC_MESSAGES/lrzsz.mo
+man/man1/lrz.1.gz
+man/man1/lsz.1.gz
_______________________________________________
svn-ports-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/svn-ports-all
To unsubscribe, send any mail to "svn-ports-all-unsubscribe@freebsd.org"
Comment 4 Dirk Meyer freebsd_committer 2013-11-22 19:33:55 UTC
State Changed
From-To: suspended->closed

a different patch was committed, thanks.