Bug 184509 - benchmarks/bonnie++ incorrectly requires lang/gcc
Summary: benchmarks/bonnie++ incorrectly requires lang/gcc
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: Ganael LAPLANCHE
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-12-05 08:10 UTC by Jeremy Chadwick
Modified: 2013-12-06 10:00 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jeremy Chadwick 2013-12-05 08:10:00 UTC
	PR 183432 has introduced a completely unnecessary dependency
	on gcc 4.6.4 (more specifically, building of ports/lang/gcc):

root@icarus:/usr/ports/benchmarks/bonnie++ # make all-depends-list
/usr/ports/lang/gcc
/usr/ports/devel/binutils
/usr/ports/devel/gmake
/usr/ports/lang/gcc-ecj45
/usr/ports/archivers/zip
/usr/ports/lang/perl5.16
/usr/ports/math/gmp
/usr/ports/math/mpfr
/usr/ports/math/mpc
/usr/ports/converters/libiconv
/usr/ports/devel/bison
/usr/ports/devel/libtool
/usr/ports/devel/m4

	bonnie++ builds just fine using the base system gcc on RELENG_9
	(gcc 4.2.1).  I do not use clang anywhere on my system (I use
	WITHOUT_CLANG=true in /etc/src.conf).

	The cause of this dependency is the introduction of USE_GCC=yes
	into the Makefile.  What you probably should be using is:

	USE_GCC=any

	...which I can verify solves the issue I describe above.

	But please check with folks who use clang first.  I've CC'd the
	author of PR 183432 so he can check to see if USE_GCC=any still
	works for him on his clang-based system.

	If it doesn't, then bapt@ needs to be involved in this discussion
	and explain to ports maintainers how to properly use USE_GCC or
	how to make this port work with both base system gcc as well as
	clang.

Fix: 

See above.
How-To-Repeat: 	See above.
Comment 1 Edwin Groothuis freebsd_committer 2013-12-05 08:10:09 UTC
Responsible Changed
From-To: freebsd-ports-bugs->martymac

Over to maintainer (via the GNATS Auto Assign Tool) 

http://www.freebsd.org/cgi/query-pr.cgi?pr=184509 

Date: Thu, 5 Dec 2013 19:49:13 +0900
Comment 2 dfilter freebsd_committer 2013-12-06 09:51:03 UTC
Author: martymac
Date: Fri Dec  6 09:50:50 2013
New Revision: 335728
URL: http://svnweb.freebsd.org/changeset/ports/335728

Log:
  Replace USE_GCC=yes (introduced in r332956) by USE_GCC=any as base Gcc is
  sufficient to build bonnie++
  
  PR:		ports/184509
  Submitted by:	Jeremy Chadwick <jdc@koitsu.org>

Modified:
  head/benchmarks/bonnie++/Makefile

Modified: head/benchmarks/bonnie++/Makefile
==============================================================================
--- head/benchmarks/bonnie++/Makefile	Fri Dec  6 09:14:13 2013	(r335727)
+++ head/benchmarks/bonnie++/Makefile	Fri Dec  6 09:50:50 2013	(r335728)
@@ -3,7 +3,7 @@
 
 PORTNAME=	bonnie++
 PORTVERSION=	1.97
-PORTREVISION=	1
+PORTREVISION=	2
 CATEGORIES=	benchmarks
 MASTER_SITES=	http://www.coker.com.au/bonnie++/experimental/
 EXTRACT_SUFX=	.tgz
@@ -14,7 +14,7 @@ COMMENT=	Performance Test of Filesystem 
 LICENSE=	GPLv2
 
 GNU_CONFIGURE=	yes
-USE_GCC=	yes
+USE_GCC=	any
 
 USES=	shebangfix
 SHEBANG_FILES=	bon_csv2txt.in
_______________________________________________
svn-ports-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/svn-ports-all
To unsubscribe, send any mail to "svn-ports-all-unsubscribe@freebsd.org"
Comment 3 Ganael LAPLANCHE freebsd_committer 2013-12-06 09:54:56 UTC
State Changed
From-To: open->closed

Committed, thanks!
Comment 4 Ganael LAPLANCHE freebsd_committer 2013-12-06 10:00:01 UTC
Jeremy, Kenji,

Thanks for your help, I've committed the change !

Best regards,

--
Ganael LAPLANCHE <ganael.laplanche@martymac.org>
http://www.martymac.org | http://contribs.martymac.org
FreeBSD: martymac <martymac@FreeBSD.org>, http://www.FreeBSD.org