Bug 184618 - math/parmgridgen: [PATCH] unbreak F10 and head
Summary: math/parmgridgen: [PATCH] unbreak F10 and head
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: John Marino
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-12-09 01:10 UTC by John Marino
Modified: 2013-12-26 13:10 UTC (History)
0 users

See Also:


Attachments
file.diff (327 bytes, patch)
2013-12-09 01:10 UTC, John Marino
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description John Marino 2013-12-09 01:10:00 UTC
This port specifies gmake to be used, but the master makefile has "make" hardcoded, which causes bmake to be used instead on F10 and head (unsuccessfully).

Adding this one-line diff to the port's makefile will unbreak the port.

Fix: Patch attached with submission follows:
Comment 1 Edwin Groothuis freebsd_committer 2013-12-09 01:10:07 UTC
Maintainer of math/parmgridgen,

Please note that PR ports/184618 has just been submitted.

If it contains a patch for an upgrade, an enhancement or a bug fix
you agree on, reply to this email stating that you approve the patch
and a committer will take care of it.

The full text of the PR can be found at:
    http://www.freebsd.org/cgi/query-pr.cgi?pr=ports/184618

-- 
Edwin Groothuis via the GNATS Auto Assign Tool
edwin@FreeBSD.org
Comment 2 Edwin Groothuis freebsd_committer 2013-12-09 01:10:08 UTC
State Changed
From-To: open->feedback

Awaiting maintainers feedback (via the GNATS Auto Assign Tool)
Comment 3 John Marino freebsd_committer 2013-12-09 01:20:43 UTC
Responsible Changed
From-To: freebsd-ports-bugs->marino

I'll take it.
Comment 4 dfilter service freebsd_committer 2013-12-24 21:43:34 UTC
Author: marino
Date: Tue Dec 24 21:43:27 2013
New Revision: 337390
URL: http://svnweb.freebsd.org/changeset/ports/337390

Log:
  math/parmgridgen: Unbreak on FreeBSD 10+
  
  The breakage was caused by processing makefiles with bmake instead of the
  specified gmake.
  
  PR:		ports/184618
  Approved by:	maintainer timeout

Modified:
  head/math/parmgridgen/Makefile

Modified: head/math/parmgridgen/Makefile
==============================================================================
--- head/math/parmgridgen/Makefile	Tue Dec 24 21:35:54 2013	(r337389)
+++ head/math/parmgridgen/Makefile	Tue Dec 24 21:43:27 2013	(r337390)
@@ -21,6 +21,7 @@ MAKE_JOBS_UNSAFE=	yes
 
 NO_STAGE=	yes
 post-patch:
+		@${REINPLACE_CMD} 's|make|$$(MAKE)|g' ${WRKSRC}/Makefile
 #respect CFLAGS
 .		for f in IMlib Lib Programs
 		    @${REINPLACE_CMD} 's|CFLAGS =|CFLAGS+=|g' ${WRKSRC}/MGridGen/${f}/Makefile
_______________________________________________
svn-ports-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/svn-ports-all
To unsubscribe, send any mail to "svn-ports-all-unsubscribe@freebsd.org"
Comment 5 John Marino freebsd_committer 2013-12-24 21:51:49 UTC
State Changed
From-To: feedback->closed

Committed. Thanks!
Comment 6 dfilter service freebsd_committer 2013-12-26 13:06:00 UTC
Author: mat
Date: Thu Dec 26 13:05:51 2013
New Revision: 337491
URL: http://svnweb.freebsd.org/changeset/ports/337491

Log:
  MFH: r337390
  
  math/parmgridgen: Unbreak on FreeBSD 10+
  
  The breakage was caused by processing makefiles with bmake instead of the
  specified gmake.
  
  PR:		ports/184618
  Approved by:	maintainer timeout
  Approved by:	portmgr (implicit)

Modified:
  branches/2014Q1/math/parmgridgen/Makefile
Directory Properties:
  branches/2014Q1/   (props changed)

Modified: branches/2014Q1/math/parmgridgen/Makefile
==============================================================================
--- branches/2014Q1/math/parmgridgen/Makefile	Thu Dec 26 13:05:03 2013	(r337490)
+++ branches/2014Q1/math/parmgridgen/Makefile	Thu Dec 26 13:05:51 2013	(r337491)
@@ -21,6 +21,7 @@ MAKE_JOBS_UNSAFE=	yes
 
 NO_STAGE=	yes
 post-patch:
+		@${REINPLACE_CMD} 's|make|$$(MAKE)|g' ${WRKSRC}/Makefile
 #respect CFLAGS
 .		for f in IMlib Lib Programs
 		    @${REINPLACE_CMD} 's|CFLAGS =|CFLAGS+=|g' ${WRKSRC}/MGridGen/${f}/Makefile
_______________________________________________
svn-ports-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/svn-ports-all
To unsubscribe, send any mail to "svn-ports-all-unsubscribe@freebsd.org"