Bug 185045 - www/w3m : linking fails
Summary: www/w3m : linking fails
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: MANTANI Nobutaka
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-12-20 20:20 UTC by Christoph Moench-Tegeder
Modified: 2014-09-15 11:38 UTC (History)
1 user (show)

See Also:


Attachments
patch for fixing problem (459 bytes, patch)
2014-09-10 16:52 UTC, Radim Kolar
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Christoph Moench-Tegeder freebsd_committer 2013-12-20 20:20:00 UTC
The build fails with
/usr/bin/ld: l: invalid DSO for symbol `XGetWindowAttributes' definition
/usr/local/lib/libX11.so.6: could not read symbols: Bad value
cc: error: linker command failed with exit code 1 (use -v to see invocation)
*** Error code 1

Accorrding to objdump, libX11.so.6 contains XGetWindowAttributes.

Fix: Pass -lX11 to the compiler (that requires the -L):



Regards,
Christoph--dOs0dMf6X3I2L4dCeCEO5mdwYsqgDNKl1MZKjEwhWnJNWQyi
Content-Type: text/plain; name="file.diff"
Content-Transfer-Encoding: 7bit
Content-Disposition: attachment; filename="file.diff"

Index: Makefile
===================================================================
--- Makefile	(revision 337087)
+++ Makefile	(working copy)
@@ -67,7 +67,7 @@
 CONFIGURE_ARGS+=	--enable-keymap=lynx
 .endif
 
-CONFIGURE_ENV=	DEFS="-I${LOCALBASE}/include"
+CONFIGURE_ENV=	DEFS="-I${LOCALBASE}/include" LDFLAGS="-L/usr/local/lib" LIBS="-lX11"
 
 post-patch:
 	@${REINPLACE_CMD} -e \
Comment 1 Edwin Groothuis freebsd_committer 2013-12-20 20:20:08 UTC
Responsible Changed
From-To: freebsd-ports-bugs->nobutaka

Over to maintainer (via the GNATS Auto Assign Tool)
Comment 2 Christoph Moench-Tegeder freebsd_committer 2014-01-06 16:51:47 UTC
Hi,

the problem "went away" - either this was a local issue or some other
change fixed it, but I just cannot reproduce it. I think this PR
might be closed. Sorry for the noise.

Regards,
Christoph

-- 
Spare Space
Comment 3 Christoph Moench-Tegeder freebsd_committer 2014-01-06 16:51:47 UTC
Hi,

the problem "went away" - either this was a local issue or some other
change fixed it, but I just cannot reproduce it. I think this PR
might be closed. Sorry for the noise.

Regards,
Christoph

-- 
Spare Space
Comment 4 MANTANI Nobutaka freebsd_committer 2014-01-14 14:35:45 UTC
State Changed
From-To: open->closed

Closed by submitter's request.
Comment 5 Radim Kolar 2014-09-10 16:46:12 UTC
I have same problem as submitter.
Comment 6 Radim Kolar 2014-09-10 16:52:52 UTC
Created attachment 147179 [details]
patch for fixing problem
Comment 7 MANTANI Nobutaka freebsd_committer 2014-09-15 11:38:33 UTC
Fix committed.