Bug 185203 - japanese/groff cannot be built by undefined reference to `polyfill'
japanese/groff cannot be built by undefined reference to `polyfill'
Status: Closed FIXED
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s)
Latest
Any Any
: Normal Affects Only Me
Assigned To: Hiroki Sato
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-12-26 12:10 UTC by takeharu1219
Modified: 2014-02-07 19:10 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description takeharu1219 2013-12-26 12:10:00 UTC
japanese/groff cannot be built by the following errors:
gmake[4]: Entering directory `/wrkdirs/usr/ports/japanese/groff/work/groff-1.18.1.1/src/preproc/grn'
g++46 -I. -I/wrkdirs/usr/ports/japanese/groff/work/groff-1.18.1.1/src/preproc/grn -I/wrkdirs/usr/ports/japanese/groff/work/groff-1.18.1.1/src/include -I/wrkdirs/usr/ports/japanese/groff/work/groff-1.18.1.1/src/include -DHAVE_CONFIG_H -O2 -pipe -I/usr/local/include -Wl,-rpath=/usr/local/lib/gcc46 -fno-strict-aliasing -Wl,-rpath=/usr/local/lib/gcc46  -c hdb.cc
g++46 -I. -I/wrkdirs/usr/ports/japanese/groff/work/groff-1.18.1.1/src/preproc/grn -I/wrkdirs/usr/ports/japanese/groff/work/groff-1.18.1.1/src/include -I/wrkdirs/usr/ports/japanese/groff/work/groff-1.18.1.1/src/include -DHAVE_CONFIG_H -O2 -pipe -I/usr/local/include -Wl,-rpath=/usr/local/lib/gcc46 -fno-strict-aliasing -Wl,-rpath=/usr/local/lib/gcc46  -c hpoint.cc
g++46 -I. -I/wrkdirs/usr/ports/japanese/groff/work/groff-1.18.1.1/src/preproc/grn -I/wrkdirs/usr/ports/japanese/groff/work/groff-1.18.1.1/src/include -I/wrkdirs/usr/ports/japanese/groff/work/groff-1.18.1.1/src/include -DHAVE_CONFIG_H -O2 -pipe -I/usr/local/include -Wl,-rpath=/usr/local/lib/gcc46 -fno-strict-aliasing -Wl,-rpath=/usr/local/lib/gcc46  -c hgraph.cc
hgraph.cc:48:3: warning: anonymous type with no linkage used to declare variable '<anonymous enum> polyfill' with linkage [enabled by default]
g++46 -I. -I/wrkdirs/usr/ports/japanese/groff/work/groff-1.18.1.1/src/preproc/grn -I/wrkdirs/usr/ports/japanese/groff/work/groff-1.18.1.1/src/include -I/wrkdirs/usr/ports/japanese/groff/work/groff-1.18.1.1/src/include -DHAVE_CONFIG_H -O2 -pipe -I/usr/local/include -Wl,-rpath=/usr/local/lib/gcc46 -fno-strict-aliasing -Wl,-rpath=/usr/local/lib/gcc46  -c main.cc
main.cc:129:20: warning: deprecated conversion from string constant to 'char*' [-Wwrite-strings]
main.cc:129:20: warning: deprecated conversion from string constant to 'char*' [-Wwrite-strings]
main.cc:129:20: warning: deprecated conversion from string constant to 'char*' [-Wwrite-strings]
main.cc:129:20: warning: deprecated conversion from string constant to 'char*' [-Wwrite-strings]
main.cc:165:3: warning: anonymous type with no linkage used to declare variable '<anonymous enum> polyfill' with linkage [enabled by default]
main.cc: In function 'void conv(FILE*, int)':
main.cc:520:14: warning: deprecated conversion from string constant to 'char*' [-Wwrite-strings]
g++46 -O2 -pipe -I/usr/local/include -Wl,-rpath=/usr/local/lib/gcc46 -fno-strict-aliasing -Wl,-rpath=/usr/local/lib/gcc46 -Wl,-rpath=/usr/local/lib/gcc46 -o grn hdb.o hpoint.o hgraph.o main.o /wrkdirs/usr/ports/japanese/groff/work/groff-1.18.1.1/src/libs/libgroff/libgroff.a -L/usr/local/lib  -lm
hgraph.o: In function `HGPrintElt(elmt*, int)':
hgraph.cc:(.text+0x17d5): undefined reference to `polyfill'
collect2: ld returned 1 exit status

Fix: 

The patch which is attached with this PR can avoid this error(As far as I know, this error is caused by specification changes of gcc).
How-To-Repeat: cd /usr/ports/japanese/groff
make install
Comment 1 Edwin Groothuis freebsd_committer 2013-12-26 12:10:21 UTC
Responsible Changed
From-To: freebsd-ports-bugs->hrs

Over to maintainer (via the GNATS Auto Assign Tool)
Comment 2 Hiroki Sato freebsd_committer 2014-02-07 19:06:31 UTC
State Changed
From-To: open->closed

Committed with some other cleanups.  Thank you for your submission!
Comment 3 dfilter freebsd_committer 2014-02-07 19:06:31 UTC
Author: hrs
Date: Fri Feb  7 19:06:19 2014
New Revision: 343288
URL: http://svnweb.freebsd.org/changeset/ports/343288
QAT: https://qat.redports.org/buildarchive/r343288/

Log:
  - Add STAGEDIR support.
  - Add LICENSE.
  - Update MASTER_SITES.
  - Remove old hacks for systems prior 5.1-RELEASE.
  - Fix undefined reference to `polyfill' issue on 10.0 and later. [*]
  - Style clean-ups.
  
  Submitted by:	TAKEHARU KATO [*]
  PR:		ports/185203

Added:
  head/japanese/groff/files/patch-contrib-eqn2graph-Makefile.sub   (contents, props changed)
  head/japanese/groff/files/patch-contrib-groffer-Makfile.sub   (contents, props changed)
  head/japanese/groff/files/patch-contrib-mm-Makefile.sub   (contents, props changed)
  head/japanese/groff/files/patch-contrib-pic2graph-Makefile.sub   (contents, props changed)
  head/japanese/groff/files/patch-src-preproc-eqn-Makefile.sub   (contents, props changed)
  head/japanese/groff/files/patch-src-roff-grog-Makefile.sub   (contents, props changed)
  head/japanese/groff/files/patch-src-roff-nroff-Makefile.sub   (contents, props changed)
  head/japanese/groff/files/patch-src-utils-afmtodit-Makefile.sub   (contents, props changed)
  head/japanese/groff/files/patch-src-utils-indxbib-Makefile.sub   (contents, props changed)
  head/japanese/groff/files/patch-src:preproc:grn:hgraph.cc   (contents, props changed)
  head/japanese/groff/files/patch-src:preproc:grn:main.cc   (contents, props changed)
  head/japanese/groff/files/patch-tmac-Makefile.sub   (contents, props changed)
Modified:
  head/japanese/groff/Makefile
  head/japanese/groff/files/patch-Makefile.comm
  head/japanese/groff/files/patch-contrib-mom-Makefile.sub
  head/japanese/groff/files/patch-doc:Makefile.sub
  head/japanese/groff/pkg-plist   (contents, props changed)

Modified: head/japanese/groff/Makefile
==============================================================================
--- head/japanese/groff/Makefile	Fri Feb  7 18:50:30 2014	(r343287)
+++ head/japanese/groff/Makefile	Fri Feb  7 19:06:19 2014	(r343288)
@@ -4,142 +4,72 @@
 PORTNAME=	groff
 PORTVERSION=	1.18.1
 DISTVERSIONSUFFIX=	.1
-PORTREVISION=	14
+PORTREVISION=	15
 CATEGORIES=	japanese print
-MASTER_SITES=	${MASTER_SITE_LOCAL:S,%SUBDIR%,okazaki/&,} \
-		${MASTER_SITE_DEBIAN:S,$,:debian,}
-MASTER_SITE_SUBDIR=	groff/:DEFAULT pool/main/g/groff/:debian
-DISTFILES=	${DISTNAME:S,-,_,}.orig${EXTRACT_SUFX}:debian ${TMAC_DISTNAME}.tar.gz
+MASTER_SITES=	LOCAL/hrs
+DISTFILES=	${DISTNAME:S,-,_,}.orig${EXTRACT_SUFX} ${TMAC_DISTNAME}.tar.gz
 
-PATCH_SITES=	${MASTER_SITE_DEBIAN}
-PATCH_SITE_SUBDIR=	pool/main/g/groff
+PATCH_SITES=	LOCAL/hrs
 PATCHFILES=	${DISTNAME:S,-,_,}-21.diff.gz
 PATCH_DIST_STRIP=	-p1
 
 MAINTAINER=	hrs@FreeBSD.org
 COMMENT=	Japanese enhancement of GNU groff
 
-.if !defined(PACKAGE_BUILDING)
-RUN_DEPENDS=	pnmcut:${PORTSDIR}/graphics/netpbm
-.endif
-
-TMAC_DATE=	20030521
-TMAC_DISTNAME=	tmac-${TMAC_DATE}_2
+LICENSE=	GPLv2
 
 USE_GCC=	any
 GNU_CONFIGURE=	yes
 USE_GMAKE=	yes
-USES=		iconv
-
-CONFLICTS=	groff-[0-9]*
-
-MAKE_JOBS_UNSAFE=	yes
+USES=		iconv:wchar_t
 
 CONFIGURE_ARGS=	--enable-multibyte
 CONFIGURE_ENV=	INSTALL_MAN="${INSTALL_MAN}" \
 		LIBS="-L${LOCALBASE}/lib ${ICONV_LIB}"
-CFLAGS+=	-I${LOCALBASE}/include
-
-TMACBASE=	${WRKDIR}/${TMAC_DISTNAME}
-TMACDIR=	share/groff/${PORTVERSION}/tmac
-SITETMACDIR=	share/groff/site-tmac
-MDOCDIR=	${TMACDIR}/mdoc
+CPPFLAGS+=	-I${LOCALBASE}/include
+MAKE_JOBS_UNSAFE=	yes
+INSTALL_TARGET=	install install_doc
 PLIST_SUB=	GROFF_VERSION=${PORTVERSION}
-
 SUB_FILES=	mdoc.local
 SUB_LIST=	OSREL=${OSREL}
+PORTDOCS=	*
+DOCSDIR=	${PREFIX}/share/doc/${PORTNAME}/${PORTVERSION}
+INFO=		groff
 
+CONFLICTS=	groff-[0-9]* mdocml-[0-9]*
+
+TMAC_DISTNAME=	tmac-20030521_2
 TMACFILES=	tmac.orig_me tmac.vgrind \
 		an-old.tmac doc.tmac e.tmac
 MDOCFILES=	ja.eucJP doc-common doc-syms
 
-DOCUMENTS=	ChangeLog.jp NEWS PROBLEMS README README.jp
-
-MAN1=		addftinfo.1 afmtodit.1 \
-		eqn.1 eqn2graph.1 \
-		grn.1 grodvi.1 groff.1 groffer.1 grog.1 \
-		grohtml.1 grolbp.1 grolj4.1 grops.1 grotty.1 \
-		hpftodit.1 indxbib.1 lkbib.1 lookbib.1 mmroff.1 \
-		neqn.1 nroff.1 pfbtops.1 pic.1 pic2graph.1 \
-		refer.1 soelim.1 tbl.1 tfmtodit.1 troff.1
-MAN5=		groff_font.5 groff_out.5 groff_tmac.5
-MAN7=		ditroff.7 groff.7 groff_char.7 groff_diff.7 \
-		groff_man.7 groff_mdoc.7 \
-		groff_me.7 groff_mm.7 groff_mmse.7 groff_mom.7 groff_ms.7 \
-		groff_trace.7 groff_www.7 roff.7
-
-NO_STAGE=	yes
-.include <bsd.port.pre.mk>
-
-.if !defined(NOPORTDOCS)
-INSTALL_TARGET=	install install_doc
-PORTDOCS=	${PORTVERSION}
-.endif
-
-# nl_langinfo(CODESET) drops the support of ja_JP.EUC after 5.1-RELEASE
-LOCALE_CMD?=	/usr/bin/locale
-.if exists(${LOCALE_CMD})
-CHARMAP!=	${LOCALE_CMD} charmap
-.if (${CHARMAP} == "EUC")
-MAKE_ENV=	LC_ALL=C
-pre-build:
-	@${ECHO_CMD} "Warning: Your current locale setting is not supported by the system."
-.endif
-.endif
-
-.if defined(WITHOUT_INFO)
-PLIST_SUB+=	INFO="@comment "
-.else
-INFO=		groff
-PLIST_SUB+=	INFO=""
-.endif
-
-POST_INSTALL_SEQ=	install-links
-.if !defined(NOPORTDOCS)
-POST_INSTALL_SEQ+=	install-documents
-.endif
-
 post-patch:
 	${REINPLACE_CMD} -e 's|\(install_data\)|\1 install_doc|g;' \
-		${WRKSRC}/Makefile.in
+	    ${WRKSRC}/Makefile.in
 	${REINPLACE_CMD} -E -e 's|^@setfilename +groff|&.info|g;' \
-		${WRKSRC}/doc/groff.texinfo
-.if defined(WITHOUT_WCHAR_H)
-	${REINPLACE_CMD} -e 's|#include <wchar[.]h>||g;' \
-		${WRKSRC}/src/libs/libgroff/encoding.cc
-.endif
+	    ${WRKSRC}/doc/groff.texinfo
 
 post-build:
 	${RM} -f ${WRKSRC}/doc/groff ${WRKSRC}/doc/groff-*
-.if !defined(WITHOUT_INFO)
 	cd ${WRKSRC}/doc && makeinfo --no-split groff.texinfo
-.endif
 	cd ${WRKSRC} && ${FIND} font -name DESC \
 	| ${XARGS} ${REINPLACE_CMD} -E -e 's|pro +(gxditview)|pro ${LOCALBASE}/bin/\1|g;'
 	cd ${WRKSRC} && ${FIND} font -name DESC \
 	| ${XARGS} ${REINPLACE_CMD} -E -e 's|pro +([^/].*)|pro ${PREFIX}/bin/\1|g;'
 
-post-install: ${POST_INSTALL_SEQ}
-.for F in ${TMACFILES}
-	${INSTALL_DATA} ${TMACBASE}/${F} ${PREFIX}/${TMACDIR}
-.endfor
-.for F in ${MDOCFILES}
-	${INSTALL_DATA} ${TMACBASE}/mdoc/${F} ${PREFIX}/${MDOCDIR}
-.endfor
-	${INSTALL_DATA} ${WRKDIR}/mdoc.local ${PREFIX}/${SITETMACDIR}
-.if !defined(WITHOUT_INFO)
-	${INSTALL_DATA} ${WRKSRC}/doc/groff.info ${PREFIX}/${INFO_PATH}
-.endif
-
-install-documents:
-	@${MKDIR} ${DOCSDIR}/${PORTVERSION}
-.for F in ${DOCUMENTS}
-	${INSTALL_DATA} ${INSTALL_WRKSRC}/${F} ${DOCSDIR}/${PORTVERSION}
-.endfor
-
-install-links:
-.for F in eqn neqn pic tbl
-	${LN} -sf ${F} ${PREFIX}/bin/g${F}
-.endfor
+post-install:
+	cd ${WRKDIR}/${TMAC_DISTNAME} && ${INSTALL_DATA} \
+	    ${TMACFILES} ${STAGEDIR}${DATADIR}/${PORTVERSION}/tmac
+	cd ${WRKDIR}/${TMAC_DISTNAME}/mdoc && ${INSTALL_DATA} \
+	    ${MDOCFILES} ${STAGEDIR}${DATADIR}/${PORTVERSION}/tmac/mdoc
+	${INSTALL_DATA} ${WRKDIR}/mdoc.local ${STAGEDIR}${DATADIR}/site-tmac
+	${INSTALL_DATA} ${WRKSRC}/doc/groff.info \
+	    ${STAGEDIR}${PREFIX}/${INFO_PATH}
+	@${MKDIR} ${STAGEDIR}${DOCSDIR}
+	cd ${INSTALL_WRKSRC} && ${INSTALL_DATA} \
+	    ChangeLog.jp NEWS PROBLEMS README README.jp ${STAGEDIR}${DOCSDIR}
+	for F in eqn neqn pic tbl; do \
+		${LN} -sf $$F ${STAGEDIR}${PREFIX}/bin/g$$F; \
+	done
 
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>

Modified: head/japanese/groff/files/patch-Makefile.comm
==============================================================================
--- head/japanese/groff/files/patch-Makefile.comm	Fri Feb  7 18:50:30 2014	(r343287)
+++ head/japanese/groff/files/patch-Makefile.comm	Fri Feb  7 19:06:19 2014	(r343288)
@@ -1,6 +1,6 @@
---- Makefile.comm.bak	Mon Sep 16 04:42:34 2002
-+++ Makefile.comm	Sun May  8 14:47:56 2005
-@@ -51,14 +51,14 @@
+--- Makefile.comm.orig	2014-02-07 13:35:27.000000000 +0900
++++ Makefile.comm	2014-02-07 13:40:33.000000000 +0900
+@@ -51,19 +51,19 @@
  MANCLEAN=$(MANPAGES)
  fontsubdir=$(fontdir)/dev$(DEV)
  
@@ -17,3 +17,90 @@
  .PHONY: uninstall uninstall_sub
  .PHONY: pure
  
+ prefix_must_exist:
+-	@test -d $(prefix) \
++	@test -d $(DESTDIR)$(prefix) \
+ 	  || (echo ; \
+ 	      echo The prefix directory \`$(prefix)\' doesn\'t exist; \
+ 	      echo ; \
+@@ -169,28 +169,28 @@
+ 
+ .PHONY: install_man
+ install_man:
+-	-test -d $(manroot) || $(mkinstalldirs) $(manroot)
+-	-test -d $(man1dir) || $(mkinstalldirs) $(man1dir)
++	-test -d $(DESTDIR)$(manroot) || $(mkinstalldirs) $(DESTDIR)$(manroot)
++	-test -d $(DESTDIR)$(man1dir) || $(mkinstalldirs) $(DESTDIR)$(man1dir)
+ 	@-pages="$(MAN1)"; \
+ 	for p in $$pages; do \
+ 	 prog=`basename $$p .n`; \
+-	 target=$(man1dir)/$(NAMEPREFIX)$$prog.$(man1ext); \
++	 target=$(DESTDIR)$(man1dir)/$(NAMEPREFIX)$$prog.$(man1ext); \
+ 	 rm -f $$target; \
+ 	 echo $(INSTALL_DATA) $$p $$target; \
+ 	 $(INSTALL_DATA) $$p $$target; \
+ 	done
+-	-test -d $(man5dir) || $(mkinstalldirs) $(man5dir)
++	-test -d $(DESTDIR)$(man5dir) || $(mkinstalldirs) $(DESTDIR)$(man5dir)
+ 	@-pages="$(MAN5)"; \
+ 	for p in $$pages; do \
+-	 target=$(man5dir)/`basename $$p .n`.$(man5ext); \
++	 target=$(DESTDIR)$(man5dir)/`basename $$p .n`.$(man5ext); \
+ 	 rm -f $$target; \
+ 	 echo $(INSTALL_DATA) $$p $$target; \
+ 	 $(INSTALL_DATA) $$p $$target; \
+ 	done
+-	-test -d $(man7dir) || $(mkinstalldirs) $(man7dir)
++	-test -d $(DESTDIR)$(man7dir) || $(mkinstalldirs) $(DESTDIR)$(man7dir)
+ 	@-pages="$(MAN7)"; \
+ 	for p in $$pages; do \
+-	 target=$(man7dir)/`basename $$p .n`.$(man7ext); \
++	 target=$(DESTDIR)$(man7dir)/`basename $$p .n`.$(man7ext); \
+ 	 rm -f $$target; \
+ 	 echo $(INSTALL_DATA) $$p $$target; \
+ 	 $(INSTALL_DATA) $$p $$target; \
+@@ -219,9 +219,9 @@
+ 
+ .PHONY: install_prog
+ install_prog:
+-	-test -d $(bindir) || $(mkinstalldirs) $(bindir)
+-	rm -f $(bindir)/$(NAMEPREFIX)$(PROG)
+-	$(INSTALL_PROGRAM) $(PROG) $(bindir)/$(NAMEPREFIX)$(PROG)
++	-test -d $(DESTDIR)$(bindir) || $(mkinstalldirs) $(DESTDIR)$(bindir)
++	rm -f $(DESTDIR)$(bindir)/$(NAMEPREFIX)$(PROG)
++	$(INSTALL_PROGRAM) $(PROG) $(DESTDIR)$(bindir)/$(NAMEPREFIX)$(PROG)
+ 
+ .PHONY: uninstall_prog
+ uninstall_prog:
+@@ -229,21 +229,21 @@
+ 
+ .PHONY: install_dev
+ install_dev:
+-	-test -d $(datadir) || $(mkinstalldirs) $(datadir)
+-	-test -d $(dataprogramdir) || $(mkinstalldirs) $(dataprogramdir)
+-	-test -d $(datasubdir) || $(mkinstalldirs) $(datasubdir)
+-	-test -d $(fontdir) || $(mkinstalldirs) $(fontdir)
+-	-test -d $(fontsubdir) || $(mkinstalldirs) $(fontsubdir)
++	-test -d $(DESTDIR)$(datadir) || $(mkinstalldirs) $(DESTDIR)$(datadir)
++	-test -d $(DESTDIR)$(dataprogramdir) || $(mkinstalldirs) $(DESTDIR)$(dataprogramdir)
++	-test -d $(DESTDIR)$(datasubdir) || $(mkinstalldirs) $(DESTDIR)$(datasubdir)
++	-test -d $(DESTDIR)$(fontdir) || $(mkinstalldirs) $(DESTDIR)$(fontdir)
++	-test -d $(DESTDIR)$(fontsubdir) || $(mkinstalldirs) $(DESTDIR)$(fontsubdir)
+ 	-if test -d $(srcdir)/generate; then \
+-	  test -d $(fontsubdir)/generate || \
+-	    $(mkinstalldirs) $(fontsubdir)/generate; \
++	  test -d $(DESTDIR)$(fontsubdir)/generate || \
++	    $(mkinstalldirs) $(DESTDIR)$(fontsubdir)/generate; \
+ 	fi
+ 	-for f in $(DEVFILES); do \
+-	  rm -f $(fontsubdir)/$$f; \
++	  rm -f $(DESTDIR)$(fontsubdir)/$$f; \
+ 	  if test -f $$f; then \
+-	    $(INSTALL_DATA) $$f $(fontsubdir)/$$f; \
++	    $(INSTALL_DATA) $$f $(DESTDIR)$(fontsubdir)/$$f; \
+ 	  else \
+-	    $(INSTALL_DATA) $(srcdir)/$$f $(fontsubdir)/$$f; \
++	    $(INSTALL_DATA) $(srcdir)/$$f $(DESTDIR)$(fontsubdir)/$$f; \
+ 	  fi; \
+ 	done
+ 

Added: head/japanese/groff/files/patch-contrib-eqn2graph-Makefile.sub
==============================================================================
--- /dev/null	00:00:00 1970	(empty, because file is newly added)
+++ head/japanese/groff/files/patch-contrib-eqn2graph-Makefile.sub	Fri Feb  7 19:06:19 2014	(r343288)
@@ -0,0 +1,15 @@
+--- contrib/eqn2graph/Makefile.sub.orig	2014-02-07 14:15:24.000000000 +0900
++++ contrib/eqn2graph/Makefile.sub	2014-02-07 14:15:44.000000000 +0900
+@@ -11,9 +11,9 @@
+ 	chmod +x $@
+ 
+ install_data: eqn2graph
+-	-test -d $(bindir) || $(mkinstalldirs) $(bindir)
+-	-rm -f $(bindir)/eqn2graph
+-	$(INSTALL_SCRIPT) eqn2graph $(bindir)/eqn2graph
++	-test -d $(DESTDIR)$(bindir) || $(mkinstalldirs) $(DESTDIR)$(bindir)
++	-rm -f $(DESTDIR)$(bindir)/eqn2graph
++	$(INSTALL_SCRIPT) eqn2graph $(DESTDIR)$(bindir)/eqn2graph
+ 
+ uninstall_sub:
+ 	-rm -f $(bindir)/eqn2graph

Added: head/japanese/groff/files/patch-contrib-groffer-Makfile.sub
==============================================================================
--- /dev/null	00:00:00 1970	(empty, because file is newly added)
+++ head/japanese/groff/files/patch-contrib-groffer-Makfile.sub	Fri Feb  7 19:06:19 2014	(r343288)
@@ -0,0 +1,15 @@
+--- contrib/groffer/Makefile.sub.orig	2014-02-07 14:16:10.000000000 +0900
++++ contrib/groffer/Makefile.sub	2014-02-07 14:16:30.000000000 +0900
+@@ -39,9 +39,9 @@
+ 	chmod +x $@
+ 
+ install_data: groffer
+-	-test -d $(bindir) || $(mkinstalldirs) $(bindir)
+-	-rm -f $(bindir)/groffer
+-	$(INSTALL_SCRIPT) groffer $(bindir)/groffer
++	-test -d $(DESTDIR)$(bindir) || $(mkinstalldirs) $(DESTDIR)$(bindir)
++	-rm -f $(DESTDIR)$(bindir)/groffer
++	$(INSTALL_SCRIPT) groffer $(DESTDIR)$(bindir)/groffer
+ 
+ uninstall_sub:
+ 	-rm -f $(bindir)/groffer

Added: head/japanese/groff/files/patch-contrib-mm-Makefile.sub
==============================================================================
--- /dev/null	00:00:00 1970	(empty, because file is newly added)
+++ head/japanese/groff/files/patch-contrib-mm-Makefile.sub	Fri Feb  7 19:06:19 2014	(r343288)
@@ -0,0 +1,48 @@
+--- contrib/mm/Makefile.sub.orig	2002-05-22 15:26:12.000000000 +0900
++++ contrib/mm/Makefile.sub	2014-02-07 14:34:13.000000000 +0900
+@@ -17,31 +17,31 @@
+ install: install_mm
+ 
+ install_mm: install_mmroff install_m
+-	-test -d $(tmacdir)/mm || $(mkinstalldirs) $(tmacdir)/mm
++	-test -d $(DESTDIR)$(tmacdir)/mm || $(mkinstalldirs) $(DESTDIR)$(tmacdir)/mm
+ 	-for f in $(FILES); do \
+-		rm -f $(tmacdir)/mm/$$f; \
+-		$(INSTALL_DATA) $(srcdir)/mm/$$f $(tmacdir)/mm/$$f; \
++		rm -f $(DESTDIR)$(tmacdir)/mm/$$f; \
++		$(INSTALL_DATA) $(srcdir)/mm/$$f $(DESTDIR)$(tmacdir)/mm/$$f; \
+ 	done
+ 	-for f in $(LOCALE); do \
+-		test -f $(tmacdir)/mm/$$f || touch $(tmacdir)/mm/$$f; \
++		test -f $(DESTDIR)$(tmacdir)/mm/$$f || touch $(DESTDIR)$(tmacdir)/mm/$$f; \
+ 	done
+ 
+ install_m:
+-	-test -d $(tmacdir) || $(mkinstalldirs) $(tmacdir)
+-	-rm -f $(tmacdir)/tmac.$(tmac_m_prefix)m
+-	-rm -f $(tmacdir)/$(tmac_m_prefix)m.tmac
+-	$(INSTALL_DATA) $(srcdir)/m.tmac $(tmacdir)/$(tmac_m_prefix)m.tmac
++	-test -d $(DESTDIR)$(tmacdir) || $(mkinstalldirs) $(DESTDIR)$(tmacdir)
++	-rm -f $(DESTDIR)$(tmacdir)/tmac.$(tmac_m_prefix)m
++	-rm -f $(DESTDIR)$(tmacdir)/$(tmac_m_prefix)m.tmac
++	$(INSTALL_DATA) $(srcdir)/m.tmac $(DESTDIR)$(tmacdir)/$(tmac_m_prefix)m.tmac
+ 	@sed -e "s;^.mso m.tmac;.mso $(tmac_m_prefix)m.tmac;g" \
+-		$(srcdir)/mse.tmac > $(tmacdir)/$(tmac_m_prefix)mse.tmac
++		$(srcdir)/mse.tmac > $(DESTDIR)$(tmacdir)/$(tmac_m_prefix)mse.tmac
+ 	@sed -e "s;^.mso mse.tmac;.mso $(tmac_m_prefix)mse.tmac;g" \
+-		$(srcdir)/mmse.tmac > $(tmacdir)/$(tmac_m_prefix)mmse.tmac
++		$(srcdir)/mmse.tmac > $(DESTDIR)$(tmacdir)/$(tmac_m_prefix)mmse.tmac
+ 	@sed -e "s;^.mso m.tmac;.mso $(tmac_m_prefix)m.tmac;g" \
+-		$(srcdir)/mm.tmac > $(tmacdir)/$(tmac_m_prefix)mm.tmac
++		$(srcdir)/mm.tmac > $(DESTDIR)$(tmacdir)/$(tmac_m_prefix)mm.tmac
+ 
+ install_mmroff: mmroff
+-	-test -d $(bindir) || $(mkinstalldirs) $(bindir)
+-	-rm -f $(bindir)/mmroff
+-	$(INSTALL_SCRIPT) mmroff $(bindir)/mmroff
++	-test -d $(DESTDIR)$(bindir) || $(mkinstalldirs) $(DESTDIR)$(bindir)
++	-rm -f $(DESTDIR)$(bindir)/mmroff
++	$(INSTALL_SCRIPT) mmroff $(DESTDIR)$(bindir)/mmroff
+ 
+ mmroff: mmroff.pl
+ 	-rm -f $@

Modified: head/japanese/groff/files/patch-contrib-mom-Makefile.sub
==============================================================================
--- head/japanese/groff/files/patch-contrib-mom-Makefile.sub	Fri Feb  7 18:50:30 2014	(r343287)
+++ head/japanese/groff/files/patch-contrib-mom-Makefile.sub	Fri Feb  7 19:06:19 2014	(r343288)
@@ -1,19 +1,43 @@
---- contrib/mom/Makefile.sub.bak	Mon Jul 29 01:22:05 2002
-+++ contrib/mom/Makefile.sub	Sun May  8 12:05:26 2005
-@@ -90,13 +90,14 @@
+--- contrib/mom/Makefile.sub.orig	2002-07-29 14:22:05.000000000 +0900
++++ contrib/mom/Makefile.sub	2014-02-07 14:11:58.000000000 +0900
+@@ -90,26 +90,27 @@
  	test -d examples || $(mkinstalldirs) examples
  	test -f penguin.ps || cp $(srcdir)/examples/penguin.ps .
  
 -install_data: $(NORMALFILES) $(HTMLDOCFILES) \
 -              $(EXAMPLEFILES) $(PROCESSEDEXAMPLEFILES)
+-	-test -d $(tmacdir) || $(mkinstalldirs) $(tmacdir)
 +install_data: $(NORMALFILES)
- 	-test -d $(tmacdir) || $(mkinstalldirs) $(tmacdir)
++	-test -d $(DESTDIR)$(tmacdir) || $(mkinstalldirs) $(DESTDIR)$(tmacdir)
  	for f in $(NORMALFILES); do \
- 	  rm -f $(tmacdir)/$$f; \
- 	  $(INSTALL_DATA) $(srcdir)/$$f $(tmacdir)/$$f; \
+-	  rm -f $(tmacdir)/$$f; \
+-	  $(INSTALL_DATA) $(srcdir)/$$f $(tmacdir)/$$f; \
++	  rm -f $(DESTDIR)$(tmacdir)/$$f; \
++	  $(INSTALL_DATA) $(srcdir)/$$f $(DESTDIR)$(tmacdir)/$$f; \
  	done
+-	-test -d $(htmldocdir)/momdoc || $(mkinstalldirs) $(htmldocdir)/momdoc
 +
 +install_doc: $(HTMLDOCFILES) $(EXAMPLEFILES) $(PROCESSEDEXAMPLEFILES)
- 	-test -d $(htmldocdir)/momdoc || $(mkinstalldirs) $(htmldocdir)/momdoc
++	-test -d $(DESTDIR)$(htmldocdir)/momdoc || $(mkinstalldirs) $(DESTDIR)$(htmldocdir)/momdoc
  	for f in $(HTMLDOCFILES); do \
- 	  rm -f $(htmldocdir)/$$f; \
+-	  rm -f $(htmldocdir)/$$f; \
+-	  $(INSTALL_DATA) $(srcdir)/$$f $(htmldocdir)/$$f; \
++	  rm -f $(DESTDIR)$(htmldocdir)/$$f; \
++	  $(INSTALL_DATA) $(srcdir)/$$f $(DESTDIR)$(htmldocdir)/$$f; \
+ 	done
+-	-test -d $(exampledir) || $(mkinstalldirs) $(exampledir)
++	-test -d $(DESTDIR)$(exampledir) || $(mkinstalldirs) $(DESTDIR)$(exampledir)
+ 	for f in $(EXAMPLEFILES); do \
+-	  rm -f $(exampledir)/$$f; \
+-	  $(INSTALL_DATA) $(srcdir)/$$f $(docdir)/$$f; \
++	  rm -f $(DESTDIR)$(exampledir)/$$f; \
++	  $(INSTALL_DATA) $(srcdir)/$$f $(DESTDIR)$(docdir)/$$f; \
+ 	done
+ 	for f in $(PROCESSEDEXAMPLEFILES); do \
+-	  rm -f $(exampledir)/$$f; \
+-	  $(INSTALL_DATA) $$f $(docdir)/$$f; \
++	  rm -f $(DESTDIR)$(exampledir)/$$f; \
++	  $(INSTALL_DATA) $$f $(DESTDIR)$(docdir)/$$f; \
+ 	done
+ 
+ uninstall_sub:

Added: head/japanese/groff/files/patch-contrib-pic2graph-Makefile.sub
==============================================================================
--- /dev/null	00:00:00 1970	(empty, because file is newly added)
+++ head/japanese/groff/files/patch-contrib-pic2graph-Makefile.sub	Fri Feb  7 19:06:19 2014	(r343288)
@@ -0,0 +1,15 @@
+--- contrib/pic2graph/Makefile.sub.orig	2014-02-07 14:14:41.000000000 +0900
++++ contrib/pic2graph/Makefile.sub	2014-02-07 14:15:01.000000000 +0900
+@@ -11,9 +11,9 @@
+ 	chmod +x $@
+ 
+ install_data: pic2graph
+-	-test -d $(bindir) || $(mkinstalldirs) $(bindir)
+-	-rm -f $(bindir)/pic2graph
+-	$(INSTALL_SCRIPT) pic2graph $(bindir)/pic2graph
++	-test -d $(DESTDIR)$(bindir) || $(mkinstalldirs) $(DESTDIR)$(bindir)
++	-rm -f $(DESTDIR)$(bindir)/pic2graph
++	$(INSTALL_SCRIPT) pic2graph $(DESTDIR)$(bindir)/pic2graph
+ 
+ uninstall_sub:
+ 	-rm -f $(bindir)/pic2graph

Modified: head/japanese/groff/files/patch-doc:Makefile.sub
==============================================================================
--- head/japanese/groff/files/patch-doc:Makefile.sub	Fri Feb  7 18:50:30 2014	(r343287)
+++ head/japanese/groff/files/patch-doc:Makefile.sub	Fri Feb  7 19:06:19 2014	(r343288)
@@ -1,5 +1,5 @@
---- doc/Makefile.sub.bak	Fri Jul 26 22:48:54 2002
-+++ doc/Makefile.sub	Thu Mar  6 12:49:07 2003
+--- doc/Makefile.sub.orig	2002-07-26 22:48:54.000000000 +0900
++++ doc/Makefile.sub	2014-02-07 13:42:25.000000000 +0900
 @@ -110,7 +110,7 @@
  	$(GROFF) -Tps -ms -mwww >$@
  
@@ -9,7 +9,7 @@
       $(PROCESSEDEXAMPLEFILES) $(make_html)
  
  html: $(HTMLDOCFILES) $(HTMLEXAMPLEFILES)
-@@ -133,18 +133,8 @@
+@@ -133,35 +133,25 @@
  
  distfiles: groff gnu.eps gnu.png
  
@@ -26,6 +26,33 @@
 -	    $(INSTALL_DATA) $$f $(infodir)/`basename $$f`; \
 -	  done
 -	$(INSTALL_INFO) --info-dir=$(infodir) $(infodir)/groff
- 	-test -d $(docdir) || $(mkinstalldirs) $(docdir)
+-	-test -d $(docdir) || $(mkinstalldirs) $(docdir)
++	-test -d $(DESTDIR)$(docdir) || $(mkinstalldirs) $(DESTDIR)$(docdir)
  	for f in $(DOCFILES); do \
- 	  rm -f $(docdir)/$$f; \
+-	  rm -f $(docdir)/$$f; \
+-	  $(INSTALL_DATA) $(srcdir)/$$f $(docdir)/$$f; \
++	  rm -f $(DESTDIR)$(docdir)/$$f; \
++	  $(INSTALL_DATA) $(srcdir)/$$f $(DESTDIR)$(docdir)/$$f; \
+ 	done
+ 	for f in $(PROCESSEDDOCFILES); do \
+-	  rm -f $(docdir)/$$f; \
+-	  $(INSTALL_DATA) $$f $(docdir)/$$f; \
++	  rm -f $(DESTDIR)$(docdir)/$$f; \
++	  $(INSTALL_DATA) $$f $(DESTDIR)$(docdir)/$$f; \
+ 	done
+-	-test -d $(exampledir) || $(mkinstalldirs) $(exampledir)
++	-test -d $(DESTDIR)$(exampledir) || $(mkinstalldirs) $(DESTDIR)$(exampledir)
+ 	for f in $(EXAMPLEFILES); do \
+-	  rm -f $(exampledir)/$$f; \
+-	  $(INSTALL_DATA) $(srcdir)/$$f $(exampledir)/$$f; \
++	  rm -f $(DESTDIR)$(exampledir)/$$f; \
++	  $(INSTALL_DATA) $(srcdir)/$$f $(DESTDIR)$(exampledir)/$$f; \
+ 	done
+ 	for f in $(PROCESSEDEXAMPLEFILES); do \
+-	  rm -f $(exampledir)/$$f; \
+-	  $(INSTALL_DATA) $$f $(exampledir)/$$f; \
++	  rm -f $(DESTDIR)$(exampledir)/$$f; \
++	  $(INSTALL_DATA) $$f $(DESTDIR)$(exampledir)/$$f; \
+ 	done
+ 
+ install_html: $(HTMLDOCFILES) $(HTMLEXAMPLEFILES)

Added: head/japanese/groff/files/patch-src-preproc-eqn-Makefile.sub
==============================================================================
--- /dev/null	00:00:00 1970	(empty, because file is newly added)
+++ head/japanese/groff/files/patch-src-preproc-eqn-Makefile.sub	Fri Feb  7 19:06:19 2014	(r343288)
@@ -0,0 +1,13 @@
+--- src/preproc/eqn/Makefile.sub.orig	2014-02-07 13:47:49.000000000 +0900
++++ src/preproc/eqn/Makefile.sub	2014-02-07 13:48:06.000000000 +0900
+@@ -52,8 +52,8 @@
+ 	chmod +x $@
+ 
+ install_data: neqn
+-	-rm -f $(bindir)/$(NAMEPREFIX)neqn
+-	$(INSTALL_SCRIPT) neqn $(bindir)/$(NAMEPREFIX)neqn
++	-rm -f $(DESTDIR)$(bindir)/$(NAMEPREFIX)neqn
++	$(INSTALL_SCRIPT) neqn $(DESTDIR)$(bindir)/$(NAMEPREFIX)neqn
+ 
+ uninstall_sub:
+ 	-rm -f $(bindir)/$(NAMEPREFIX)neqn

Added: head/japanese/groff/files/patch-src-roff-grog-Makefile.sub
==============================================================================
--- /dev/null	00:00:00 1970	(empty, because file is newly added)
+++ head/japanese/groff/files/patch-src-roff-grog-Makefile.sub	Fri Feb  7 19:06:19 2014	(r343288)
@@ -0,0 +1,15 @@
+--- src/roff/grog/Makefile.sub.orig	2014-02-07 14:05:54.000000000 +0900
++++ src/roff/grog/Makefile.sub	2014-02-07 14:06:19.000000000 +0900
+@@ -24,9 +24,9 @@
+ 	chmod +x $@
+ 
+ install_data: grog
+-	-test -d $(bindir) || $(mkinstalldirs) $(bindir)
+-	-rm -f $(bindir)/grog
+-	$(INSTALL_SCRIPT) grog $(bindir)/grog
++	-test -d $(DESTDIR)$(bindir) || $(mkinstalldirs) $(DESTDIR)$(bindir)
++	-rm -f $(DESTDIR)$(bindir)/grog
++	$(INSTALL_SCRIPT) grog $(DESTDIR)$(bindir)/grog
+ 
+ uninstall_sub:
+ 	-rm -f $(bindir)/grog

Added: head/japanese/groff/files/patch-src-roff-nroff-Makefile.sub
==============================================================================
--- /dev/null	00:00:00 1970	(empty, because file is newly added)
+++ head/japanese/groff/files/patch-src-roff-nroff-Makefile.sub	Fri Feb  7 19:06:19 2014	(r343288)
@@ -0,0 +1,15 @@
+--- src/roff/nroff/Makefile.sub.orig	2014-02-07 14:07:36.000000000 +0900
++++ src/roff//nroff/Makefile.sub	2014-02-07 14:07:55.000000000 +0900
+@@ -12,9 +12,9 @@
+ 	chmod +x $@
+ 
+ install_data: nroff
+-	-test -d $(bindir) || $(mkinstalldirs) $(bindir)
+-	-rm -f $(bindir)/$(NAMEPREFIX)nroff
+-	$(INSTALL_SCRIPT) nroff $(bindir)/$(NAMEPREFIX)nroff
++	-test -d $(DESTDIR)$(bindir) || $(mkinstalldirs) $(DESTDIR)$(bindir)
++	-rm -f $(DESTDIR)$(bindir)/$(NAMEPREFIX)nroff
++	$(INSTALL_SCRIPT) nroff $(DESTDIR)$(bindir)/$(NAMEPREFIX)nroff
+ 
+ uninstall_sub:
+ 	-rm -f $(bindir)/$(NAMEPREFIX)nroff

Added: head/japanese/groff/files/patch-src-utils-afmtodit-Makefile.sub
==============================================================================
--- /dev/null	00:00:00 1970	(empty, because file is newly added)
+++ head/japanese/groff/files/patch-src-utils-afmtodit-Makefile.sub	Fri Feb  7 19:06:19 2014	(r343288)
@@ -0,0 +1,15 @@
+--- src/utils/afmtodit/Makefile.sub.orig	2014-02-07 14:04:11.000000000 +0900
++++ src/utils/afmtodit/Makefile.sub	2014-02-07 14:04:35.000000000 +0900
+@@ -15,9 +15,9 @@
+ 	chmod +x afmtodit
+ 
+ install_data: afmtodit
+-	-test -d $(bindir) || $(mkinstalldirs) $(bindir)
+-	-rm -f $(bindir)/afmtodit
+-	$(INSTALL_SCRIPT) afmtodit $(bindir)/afmtodit
++	-test -d $(DESTDIR)$(bindir) || $(mkinstalldirs) $(DESTDIR)$(bindir)
++	-rm -f $(DESTDIR)$(bindir)/afmtodit
++	$(INSTALL_SCRIPT) afmtodit $(DESTDIR)$(bindir)/afmtodit
+ 
+ uninstall_sub:
+ 	-rm -f $(bindir)/afmtodit

Added: head/japanese/groff/files/patch-src-utils-indxbib-Makefile.sub
==============================================================================
--- /dev/null	00:00:00 1970	(empty, because file is newly added)
+++ head/japanese/groff/files/patch-src-utils-indxbib-Makefile.sub	Fri Feb  7 19:06:19 2014	(r343288)
@@ -0,0 +1,26 @@
+--- src/utils/indxbib/Makefile.sub.orig	2014-02-07 13:49:35.000000000 +0900
++++ src/utils/indxbib/Makefile.sub	2014-02-07 13:51:45.000000000 +0900
+@@ -12,18 +12,11 @@
+ NAMEPREFIX=$(g)
+ 
+ install_data: eign
+-	-test -d $(datadir) || $(mkinstalldirs) $(datadir)
+-	-test -d $(dataprogramdir) || $(mkinstalldirs) $(dataprogramdir)
+-	-test -d $(datasubdir) || $(mkinstalldirs) $(datasubdir)
+-	if test -f /usr/lib/eign; then \
+-	  rm -f $(common_words_file); \
+-	  ln -s /usr/lib/eign $(common_words_file) 2>/dev/null \
+-	  || ln /usr/lib/eign $(common_words_file) 2>/dev/null \
+-	  || cp /usr/lib/eign $(common_words_file); \
+-	else \
+-	  rm -f $(common_words_file); \
+-	  $(INSTALL_DATA) $(srcdir)/eign $(common_words_file); \
+-	fi
++	-test -d $(DESTDIR)$(datadir) || $(mkinstalldirs) $(DESTDIR)$(datadir)
++	-test -d $(DESTDIR)$(dataprogramdir) || $(mkinstalldirs) $(DESTDIR)$(dataprogramdir)
++	-test -d $(DESTDIR)$(datasubdir) || $(mkinstalldirs) $(DESTDIR)$(datasubdir)
++	rm -f $(common_words_file); \
++	$(INSTALL_DATA) $(srcdir)/eign $(DESTDIR)$(common_words_file); \
+ 
+ uninstall_sub:
+ 	-rm -f $(common_words_file)

Added: head/japanese/groff/files/patch-src:preproc:grn:hgraph.cc
==============================================================================
--- /dev/null	00:00:00 1970	(empty, because file is newly added)
+++ head/japanese/groff/files/patch-src:preproc:grn:hgraph.cc	Fri Feb  7 19:06:19 2014	(r343288)
@@ -0,0 +1,11 @@
+--- src/preproc/grn/hgraph.cc.bak	2013-12-26 00:50:57.243769618 +0900
++++ src/preproc/grn/hgraph.cc	2013-12-26 00:52:09.513467616 +0900
+@@ -43,7 +43,7 @@
+ extern int ybottom;
+ extern int xleft;
+ extern int xright;
+-extern enum {
++extern enum filltype {
+   OUTLINE, FILL, BOTH
+ } polyfill;
+ 

Added: head/japanese/groff/files/patch-src:preproc:grn:main.cc
==============================================================================
--- /dev/null	00:00:00 1970	(empty, because file is newly added)
+++ head/japanese/groff/files/patch-src:preproc:grn:main.cc	Fri Feb  7 19:06:19 2014	(r343288)
@@ -0,0 +1,11 @@
+--- src/preproc/grn/main.cc.bak	2013-12-26 00:51:09.467987940 +0900
++++ src/preproc/grn/main.cc	2013-12-26 00:52:24.577939911 +0900
+@@ -160,7 +160,7 @@
+ double scale = 1.0;		/* no scaling, default */
+ int defpoint = 0;		/* flag for pointsize scaling */
+ char *defstipple = (char *) 0;
+-enum {
++enum filltype {
+   OUTLINE, FILL, BOTH
+ } polyfill;
+ 

Added: head/japanese/groff/files/patch-tmac-Makefile.sub
==============================================================================
--- /dev/null	00:00:00 1970	(empty, because file is newly added)
+++ head/japanese/groff/files/patch-tmac-Makefile.sub	Fri Feb  7 19:06:19 2014	(r343288)
@@ -0,0 +1,65 @@
+--- tmac/Makefile.sub.orig	2014-02-07 14:02:28.000000000 +0900
++++ tmac/Makefile.sub	2014-02-07 14:02:12.000000000 +0900
+@@ -43,39 +43,39 @@
+ 
+ install_data: $(NORMALFILES) $(SPECIALFILES) man.local \
+               stamp-strip stamp-wrap stamp-sed
+-	-test -d $(tmacdir) || $(mkinstalldirs) $(tmacdir)
+-	-test -d $(systemtmacdir) || $(mkinstalldirs) $(systemtmacdir)
+-	-test -d $(localtmacdir) || $(mkinstalldirs) $(localtmacdir)
++	-test -d $(DESTDIR)$(tmacdir) || $(mkinstalldirs) $(DESTDIR)$(tmacdir)
++	-test -d $(DESTDIR)$(systemtmacdir) || $(mkinstalldirs) $(DESTDIR)$(systemtmacdir)
++	-test -d $(DESTDIR)$(localtmacdir) || $(mkinstalldirs) $(DESTDIR)$(localtmacdir)
+ 	if test -n "$(tmac_wrap)"; then \
+ 	  for m in ""$(tmac_wrap); do \
+-	    $(INSTALL_DATA) $$m-wrap $(systemtmacdir)/$$m.tmac; \
++	    $(INSTALL_DATA) $$m-wrap $(DESTDIR)$(systemtmacdir)/$$m.tmac; \
+ 	  done; \
+ 	fi
+ 	for f in $(NORMALFILES); do \
+-	  rm -f $(tmacdir)/$$f; \
+-	  $(INSTALL_DATA) $(srcdir)/$$f $(tmacdir)/$$f; \
++	  rm -f $(DESTDIR)$(tmacdir)/$$f; \
++	  $(INSTALL_DATA) $(srcdir)/$$f $(DESTDIR)$(tmacdir)/$$f; \
+ 	done
+-	-rm -f $(tmacdir)/$(tmac_s_prefix)s.tmac
+-	$(INSTALL_DATA) $(srcdir)/s.tmac $(tmacdir)/$(tmac_s_prefix)s.tmac
+-	-rm -f $(tmacdir)/ms.tmac
+-	$(INSTALL_DATA) ms.tmac-sed $(tmacdir)/ms.tmac
+-	-rm -f $(tmacdir)/$(tmac_an_prefix)an.tmac
+-	$(INSTALL_DATA) $(srcdir)/an.tmac $(tmacdir)/$(tmac_an_prefix)an.tmac
+-	-rm -f $(tmacdir)/man.tmac
+-	$(INSTALL_DATA) man.tmac-sed $(tmacdir)/man.tmac
++	-rm -f $(DESTDIR)$(tmacdir)/$(tmac_s_prefix)s.tmac
++	$(INSTALL_DATA) $(srcdir)/s.tmac $(DESTDIR)$(tmacdir)/$(tmac_s_prefix)s.tmac
++	-rm -f $(DESTDIR)$(tmacdir)/ms.tmac
++	$(INSTALL_DATA) ms.tmac-sed $(DESTDIR)$(tmacdir)/ms.tmac
++	-rm -f $(DESTDIR)$(tmacdir)/$(tmac_an_prefix)an.tmac
++	$(INSTALL_DATA) $(srcdir)/an.tmac $(DESTDIR)$(tmacdir)/$(tmac_an_prefix)an.tmac
++	-rm -f $(DESTDIR)$(tmacdir)/man.tmac
++	$(INSTALL_DATA) man.tmac-sed $(DESTDIR)$(tmacdir)/man.tmac
+ 	for f in $(STRIPFILES); do \
+-	  rm -f $(tmacdir)/$$f; \
+-	  $(INSTALL_DATA) $$f-s $(tmacdir)/$$f; \
++	  rm -f $(DESTDIR)$(tmacdir)/$$f; \
++	  $(INSTALL_DATA) $$f-s $(DESTDIR)$(tmacdir)/$$f; \
+ 	done
+-	-test -d $(mdocdir) || $(mkinstalldirs) $(mdocdir)
++	-test -d $(DESTDIR)$(mdocdir) || $(mkinstalldirs) $(DESTDIR)$(mdocdir)
+ 	for f in $(MDOCFILES); do \
+-	  rm -f $(mdocdir)/$$f; \
+-	  $(INSTALL_DATA) $$f-s $(mdocdir)/$$f; \
++	  rm -f $(DESTDIR)$(mdocdir)/$$f; \
++	  $(INSTALL_DATA) $$f-s $(DESTDIR)$(mdocdir)/$$f; \
+ 	done
+-	-test -f $(localtmacdir)/man.local || \
+-	  $(INSTALL_DATA) $(srcdir)/man.local $(localtmacdir)/man.local
+-	-test -f $(localtmacdir)/mdoc.local || \
+-	  $(INSTALL_DATA) mdoc.local-s $(localtmacdir)/mdoc.local
++	-test -f $(DESTDIR)$(localtmacdir)/man.local || \
++	  $(INSTALL_DATA) $(srcdir)/man.local $(DESTDIR)$(localtmacdir)/man.local
++	-test -f $(DESTDIR)$(localtmacdir)/mdoc.local || \
++	  $(INSTALL_DATA) mdoc.local-s $(DESTDIR)$(localtmacdir)/mdoc.local
+ 
+ stamp-strip: $(STRIPFILES) $(MDOCFILES) mdoc.local
+ 	for f in $(STRIPFILES) $(MDOCFILES) mdoc.local; do \

Modified: head/japanese/groff/pkg-plist
==============================================================================
--- head/japanese/groff/pkg-plist	Fri Feb  7 18:50:30 2014	(r343287)
+++ head/japanese/groff/pkg-plist	Fri Feb  7 19:06:19 2014	(r343288)
@@ -1,3 +1,4 @@
+@comment $FreeBSD$
 bin/addftinfo
 bin/afmtodit
 bin/eqn
@@ -385,6 +386,52 @@ bin/troff
 %%DATADIR%%/site-tmac/man.local
 %%DATADIR%%/site-tmac/mdoc.local
 @exec mkdir -p %D/lib/groff/site-tmac
+man/man1/addftinfo.1.gz
+man/man1/afmtodit.1.gz
+man/man1/eqn.1.gz
+man/man1/eqn2graph.1.gz
+man/man1/grn.1.gz
+man/man1/grodvi.1.gz
+man/man1/groff.1.gz
+man/man1/groffer.1.gz
+man/man1/grog.1.gz
+man/man1/grohtml.1.gz
+man/man1/grolbp.1.gz
+man/man1/grolj4.1.gz
+man/man1/grops.1.gz
+man/man1/grotty.1.gz
+man/man1/hpftodit.1.gz
+man/man1/indxbib.1.gz
+man/man1/lkbib.1.gz
+man/man1/lookbib.1.gz
+man/man1/mmroff.1.gz
+man/man1/neqn.1.gz
+man/man1/nroff.1.gz
+man/man1/pfbtops.1.gz
+man/man1/pic.1.gz
+man/man1/pic2graph.1.gz
+man/man1/refer.1.gz
+man/man1/soelim.1.gz
+man/man1/tbl.1.gz
+man/man1/tfmtodit.1.gz
+man/man1/troff.1.gz
+man/man5/groff_font.5.gz
+man/man5/groff_out.5.gz
+man/man5/groff_tmac.5.gz
+man/man7/ditroff.7.gz
+man/man7/groff.7.gz
+man/man7/groff_char.7.gz
+man/man7/groff_diff.7.gz
+man/man7/groff_man.7.gz
+man/man7/groff_mdoc.7.gz
+man/man7/groff_me.7.gz
+man/man7/groff_mm.7.gz
+man/man7/groff_mmse.7.gz
+man/man7/groff_mom.7.gz
+man/man7/groff_ms.7.gz
+man/man7/groff_trace.7.gz
+man/man7/groff_www.7.gz
+man/man7/roff.7.gz
 @dirrm lib/groff/site-tmac
 @dirrm lib/groff
 @dirrm %%DATADIR%%/%%GROFF_VERSION%%/font/devX100
@@ -411,3 +458,4 @@ bin/troff
 @dirrm %%DATADIR%%/%%GROFF_VERSION%%
 @dirrm %%DATADIR%%/site-tmac
 @dirrm %%DATADIR%%
+@dirrmtry share/doc/groff
_______________________________________________
svn-ports-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/svn-ports-all
To unsubscribe, send any mail to "svn-ports-all-unsubscribe@freebsd.org"