Bug 185389 - freebsd-update(8) man page does not list -v option
Summary: freebsd-update(8) man page does not list -v option
Status: Closed FIXED
Alias: None
Product: Documentation
Classification: Unclassified
Component: Manual Pages (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: Ed Maste
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-01-01 16:50 UTC by freebsd
Modified: 2019-07-22 06:05 UTC (History)
5 users (show)

See Also:


Attachments
Manpage documentation for -v and aliases (2.95 KB, patch)
2019-01-18 15:48 UTC, Gerald Aryeetey
no flags Details | Diff
Manpage documentation for -v and aliases (4.45 KB, patch)
2019-01-18 18:16 UTC, Gerald Aryeetey
no flags Details | Diff
Manpage documentation for -v and aliases (4.45 KB, patch)
2019-01-18 18:18 UTC, Gerald Aryeetey
no flags Details | Diff
Manpage documentation for -v and aliases (3.55 KB, patch)
2019-01-18 18:22 UTC, Gerald Aryeetey
no flags Details | Diff
Manpage documentation for -v and aliases (3.07 KB, patch)
2019-01-21 23:20 UTC, Gerald Aryeetey
gndaryee: maintainer-approval? (cperciva)
gndaryee: maintainer-approval? (bcr)
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description freebsd 2014-01-01 16:50:00 UTC
the freebsd-update script has an option, -v, which sets a verbosity level.
It is not documented on the man page.

It also has aliases --debug and --no-stats which are not documented.

How-To-Repeat: man freebsd-update
view /usr/sbin/freebsd-update about line 440
Comment 1 Benedict Reuschling freebsd_committer 2014-01-01 19:59:43 UTC
Responsible Changed
From-To: freebsd-doc->cperciva

Over to maintainer. Colin, can you provide a patch for the man page? 
Thanks!
Comment 2 Gerald Aryeetey 2019-01-14 16:26:25 UTC
--debug and --no-stats are undocumented by design it seems. On Line 34, it says "Usage instructions. Options not listed:"

These options can also be configurable by "VerboseLevel" in the config file however it's not documented in there also.
Comment 3 Gerald Aryeetey 2019-01-18 15:48:45 UTC
Created attachment 201239 [details]
Manpage documentation for -v and aliases

Here's a patch for the manpage and help text to include verbosity options. Additionally, default settings and description of "VerbosityLevel" is described and documented in the configuration file.
Comment 4 Benedict Reuschling freebsd_committer 2019-01-18 16:10:46 UTC
Hello Gerald, glad you're taking this on. There seems to be at least one instance to fix in the man page. First, run "mandoc -Tlint" on it for the markup. Then, install textproc/igor and let it run over your patched file. It will perform a few checks and tell you where to fix things in the code.
Comment 5 Gerald Aryeetey 2019-01-18 18:16:53 UTC
Created attachment 201245 [details]
Manpage documentation for -v and aliases

Updated to pass `igor` and `mandoc -Tlint`. Required some changes to code I didn't add.
Comment 6 Gerald Aryeetey 2019-01-18 18:18:10 UTC
Created attachment 201246 [details]
Manpage documentation for -v and aliases

Fix backwards patch.
Comment 7 Gerald Aryeetey 2019-01-18 18:22:12 UTC
Created attachment 201247 [details]
Manpage documentation for -v and aliases

Remove other changes from patch ...
Comment 8 commit-hook freebsd_committer 2019-01-18 18:23:20 UTC
A commit references this bug:

Author: emaste
Date: Fri Jan 18 18:22:47 UTC 2019
New revision: 343153
URL: https://svnweb.freebsd.org/changeset/base/343153

Log:
  freebsd-update.8: mandoc -Tlint fixes

  PR:		185389
  Reported by:	bcr
  MFC after:	3 days
  Sponsored by:	The FreeBSD Foundation

Changes:
  head/usr.sbin/freebsd-update/freebsd-update.8
Comment 9 commit-hook freebsd_committer 2019-01-21 18:35:30 UTC
A commit references this bug:

Author: emaste
Date: Mon Jan 21 18:34:33 UTC 2019
New revision: 343266
URL: https://svnweb.freebsd.org/changeset/base/343266

Log:
  MFC r343153: freebsd-update.8: mandoc -Tlint fixes

  PR:		185389

Changes:
_U  stable/12/
  stable/12/usr.sbin/freebsd-update/freebsd-update.8
Comment 10 commit-hook freebsd_committer 2019-01-21 18:36:34 UTC
A commit references this bug:

Author: emaste
Date: Mon Jan 21 18:35:40 UTC 2019
New revision: 343267
URL: https://svnweb.freebsd.org/changeset/base/343267

Log:
  MFC r343153:     freebsd-update.8: mandoc -Tlint fixes

  PR:		185389

Changes:
_U  stable/11/
  stable/11/usr.sbin/freebsd-update/freebsd-update.8
Comment 11 Gerald Aryeetey 2019-01-21 23:20:14 UTC
Created attachment 201318 [details]
Manpage documentation for -v and aliases

Rebase to no longer include committed manpage fixes.
Comment 12 Benedict Reuschling freebsd_committer 2019-03-09 14:40:21 UTC
Can we close this one now that there is a committed fix?
Comment 13 Benedict Reuschling freebsd_committer 2019-07-22 06:05:25 UTC
Set PR state to closed as all the necessary commits have been done a while ago.