Bug 185523 - [PATCH] ports-mgmt/portupgrade: use ruby-bdb with ruby 2.0 again
Summary: [PATCH] ports-mgmt/portupgrade: use ruby-bdb with ruby 2.0 again
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: Bryan Drewery
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-01-06 00:20 UTC by Yasuhiro Kimura
Modified: 2014-10-13 17:08 UTC (History)
0 users

See Also:


Attachments
patch-portupgrade (625 bytes, text/plain)
2014-01-06 00:20 UTC, Yasuhiro Kimura
no flags Details
patch-portupgrade (1.06 KB, text/plain; charset=Shift_JIS)
2014-03-22 09:27 UTC, Yasuhiro Kimura
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Yasuhiro Kimura 2014-01-06 00:20:00 UTC
	
	Use ruby-bdb with ruby 2.0 again because breakage is fixed.
Comment 1 Edwin Groothuis freebsd_committer 2014-01-06 00:20:08 UTC
Responsible Changed
From-To: freebsd-ports-bugs->bdrewery

Over to maintainer (via the GNATS Auto Assign Tool)
Comment 2 Yasuhiro Kimura 2014-02-08 08:39:22 UTC
Hello,

Would you please commit this PR?

Best Regards.

---
Yasuhiro KIMURA
Comment 3 Bryan Drewery freebsd_committer 2014-02-08 14:23:55 UTC
On 2/8/2014 2:39 AM, Yasuhiro KIMURA wrote:
> Hello,
> 
> Would you please commit this PR?
> 
> Best Regards.
> 
> ---
> Yasuhiro KIMURA
> 

Do you have evidence that the issue was fixed and that it didn't just
'work for you'?

I had many reports of portsdb -u and pkgdb -u crashing.

-- 
Regards,
Bryan Drewery
Comment 4 Yasuhiro Kimura 2014-03-22 09:27:46 UTC
Hello Bryan, and sorry for very late response.

(2014/02/08 23:23), Bryan Drewery wrote:
> Do you have evidence that the issue was fixed and that it didn't just
> 'work for you'?
>
> I had many reports of portsdb -u and pkgdb -u crashing.

I thought dependency to ruby-bdb was removed when ruby is 2.0 because 
ruby-bdb couldn't be built with ruby 2.0. But later the breakage was 
fixed and now it can be build with ruby 2.0. That was why I submitted 
this PR.

But futher later lang/ruby21 was connected to port tree. And I found 
ruby-bdb fails to build with it. I changed Makefile of portupgrade port 
so it doesn't depend on ruby-bdb if ruby21 is used, and installed both 
ruby21 and portupgrade to some of FreeBSD machines I maintain. Then I 
faced annoying problem as following:

There are two 10.0-RELEASE machines. One is for regular operation and 
the other is for testing. From now on I call the formar 'REGULAR' and 
the latter 'TESTING'. Both REGULAR and TESTING shares ports tree with 
NFS which exists on another file server. I upgrade TESTING to 
lang/ruby21 while staying REGULAR to lang/rub19. As a result on TESTING 
database/ruby-bdb is not installed and portupgrade uses bdb in base 
system while on REGULAR ruby-bdb is installed and portupgrade uses bdb 
in ports. And this is the cause of problem.

Now I update ports tree and /usr/ports/INDEX-10 on file server, then 
login to REGULAR and execute 'portversion -vL ='. Since INDEX file is 
updated /usr/ports/INDEX-10.db is rebuilt at first and then some 
outdated ports are displayed if exists. I may execute 'portupgrade -a' 
to update these outdated ports. Next I login to TESTING and execute 
'portversion -vL=' in the same way, and then the problem happens.
Since INDEX-10 is not updated, this time there is no need to rebuild 
INDEX-10.db. However data format of db file is imcompatible between bdb 
in base system and one in ports. So portversion complains INDEX-10.db is 
broken and rebuild it again before showing outdated ports.

Such rebuilding occurs every time when I do something about portupgrade 
on the other side of two machines, and it is much annoying. Especially 
for my case because , though I don't know why this happens, rebuilding 
.db file on NFS takes much longer time than rebulding on local file system.

Therefore now I think dependency to databases/ruby-bdb should be removed 
from portupgrade regardless of which version of ruby is used.
So if you agree with me please commit attached patch instead of original 
one.

Best Regards.

---
Yasuhiro KIMURA
Comment 5 Bryan Drewery freebsd_committer 2014-03-22 10:30:36 UTC
On 3/22/2014 4:27 AM, Yasuhiro KIMURA wrote:
> Therefore now I think dependency to databases/ruby-bdb should be removed
> from portupgrade regardless of which version of ruby is used.
> So if you agree with me please commit attached patch instead of original
> one.

I think I do agree. If I remember correctly this was mostly for 1.8.
1.9+ had a more reliable builtin bdb I think. I'll need to research and
test more. Thanks!

Bryan
Comment 6 Bryan Drewery freebsd_committer 2014-10-13 15:55:18 UTC
Dependency restored for ruby-bdb.
Comment 7 commit-hook freebsd_committer 2014-10-13 15:55:30 UTC
A commit references this bug:

Author: bdrewery
Date: Mon Oct 13 15:55:00 UTC 2014
New revision: 370790
URL: https://svnweb.freebsd.org/changeset/ports/370790

Log:
  - Add dependency back for ruby-bdb for Ruby 2.0.

  PR:		188084
  PR:		185523

Changes:
  head/ports-mgmt/portupgrade/Makefile
  head/ports-mgmt/portupgrade-devel/Makefile
Comment 8 commit-hook freebsd_committer 2014-10-13 17:08:44 UTC
A commit references this bug:

Author: bdrewery
Date: Mon Oct 13 17:07:45 UTC 2014
New revision: 370800
URL: https://svnweb.freebsd.org/changeset/ports/370800

Log:
  MFH: r370790

  - Add dependency back for ruby-bdb for Ruby 2.0.

  PR:		188084
  PR:		185523

Changes:
_U  branches/2014Q4/
  branches/2014Q4/ports-mgmt/portupgrade/Makefile
  branches/2014Q4/ports-mgmt/portupgrade-devel/Makefile