Bug 186056 - New port: databases/cassandra2 The latest stable release of Apache Cassandra
Summary: New port: databases/cassandra2 The latest stable release of Apache Cassandra
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: Kurt Jaeger
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-01-23 21:50 UTC by admins
Modified: 2014-08-29 18:10 UTC (History)
1 user (show)

See Also:


Attachments
file.shar (17.68 KB, text/plain)
2014-01-23 21:50 UTC, admins
no flags Details
Updated port shar file (18.45 KB, text/plain)
2014-08-26 20:22 UTC, admins
no flags Details
Fixed pkg-plist as compained by poudriere (18.46 KB, text/plain)
2014-08-27 09:14 UTC, admins
no flags Details
poudriere log (14.38 KB, text/plain)
2014-08-27 09:15 UTC, admins
no flags Details
Updated Makefile per @John comment (18.36 KB, text/plain)
2014-08-27 19:26 UTC, admins
no flags Details
Latest poudriere log (16.83 KB, text/plain)
2014-08-27 19:26 UTC, admins
no flags Details
Removed DOC condition (18.35 KB, text/plain)
2014-08-27 20:28 UTC, admins
no flags Details
Latest poudriere log (16.79 KB, text/plain)
2014-08-27 20:28 UTC, admins
no flags Details
Fixed duplicate LATEST_LINKs (17.92 KB, text/plain)
2014-08-29 15:35 UTC, admins
no flags Details
Latest poudriere log (19.70 KB, text/plain)
2014-08-29 15:35 UTC, admins
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description admins 2014-01-23 21:50:02 UTC
The latest stable release of Apache Cassandra version 2.0.4

Fix: Patch attached with submission follows:
Comment 1 John Marino freebsd_committer 2014-08-07 14:24:41 UTC
Hi, if you are still interested in having this port in FreeBSD, it may need to be reworked to support stage, and it could need updating to other newer conventions such as "USES" which is expanding all time.
See http://lists.freebsd.org/pipermail/freebsd-ports-announce/2014-May/000080.html


Additionally, you need to provide some sort of quality assurance.    
In order of preference, we are looking for:

1) "poudriere testport" or "poudriere bulk -t" logs
2) Redports or tinderbox logs

Please provide an updated shar file and attach a test log.  Alternatively, please indicate if you are no longer interested in having this software in the Ports Collection and that we can close the PR.

Thanks!
Comment 2 John Marino freebsd_committer 2014-08-24 18:50:35 UTC
I apologize, but after 30 September I'm going to close all *unstaged* "new port" PRs, even if it is through no fault of the submitter.  If you are still interested in getting the port into tree, please provide an updated share and some build verification (poudriere logs, redports logs, or Porter's Handbook[1]).  If you do that, we'll fast-track the port into the tree.  I'm sorry about this.


"make check-plist" followed by "make stage-qa" output  (https://www.freebsd.org/doc/en/books/porters-handbook/porting-testing.html)
Comment 3 admins 2014-08-26 20:22:11 UTC
Created attachment 146342 [details]
Updated port shar file

Here is an updated shar file to support staging. It also has latest Cassandra version.
Comment 4 admins 2014-08-26 20:25:10 UTC
The updated patch passed all tests as described in https://www.freebsd.org/doc/en/books/porters-handbook/porting-testing.html. I will provide poudriere logs when I get them (building java will take a LOT of time and space).

Yours,
Aleksey
Comment 5 John Marino freebsd_committer 2014-08-26 20:28:55 UTC
great!  understood and looking forward to seeing them.
Comment 6 admins 2014-08-27 09:14:30 UTC
Created attachment 146364 [details]
Fixed pkg-plist as compained by poudriere
Comment 7 admins 2014-08-27 09:15:22 UTC
Created attachment 146365 [details]
poudriere log
Comment 8 John Marino freebsd_committer 2014-08-27 09:34:30 UTC
I sometimes feel very strict when I insist on logs, but when I see new submissions prior to the log attachment, I feel better. :)

I was going to move this to patch-ready, but I see some immediate minor issues.


MUST BE FIXED:
1) in the post-install and do-install targets, you precede all commands with "@".  This suppresses the output and it is not allowed (with an exception made for mkdir commands)

2) It looks like tab alignment is all over the place.  Use tabs=8 spaces

3) PORTDOCS is defined unconditionally.  Remove the PORT_OPTIONS:MDOCS condition around it.  staging takes care of this.  (see https://www.freebsd.org/doc/en/books/porters-handbook/install.html#install-documentation )

4) Remove post-install target, not necessary anymore (done automatically)


NOT STRICTLY NECESSSARY BUT FIX IT ANYWAY
A) Convert this to OPTIONS_SUB=yes to remove the need for PLIST_SUB
https://www.freebsd.org/doc/en/books/porters-handbook/makefile-options.html

B) use <OPT>_RUN_DEPENDS and <OPT>_USES (see same page above)



Thanks!  sorry about that, but either you fix it or a committer has to.
Comment 9 John Marino freebsd_committer 2014-08-27 12:32:09 UTC
oops, i didn't mean to put this as patch-ready.  That was my original plan though..
Comment 10 admins 2014-08-27 19:26:15 UTC
Created attachment 146388 [details]
Updated Makefile per @John comment
Comment 11 admins 2014-08-27 19:26:54 UTC
Created attachment 146389 [details]
Latest poudriere log
Comment 12 John Marino freebsd_committer 2014-08-27 19:37:01 UTC
it looks like you got everything except for 3)
did you have issue with that?  disagree?  forgot it?
Comment 13 admins 2014-08-27 20:23:25 UTC
Sorry, John. I missed the second condition. Working on it.
Comment 14 admins 2014-08-27 20:28:31 UTC
Created attachment 146401 [details]
Removed DOC condition
Comment 15 admins 2014-08-27 20:28:57 UTC
Created attachment 146402 [details]
Latest poudriere log
Comment 16 admins 2014-08-27 20:30:43 UTC
John,

Any chance someone look at two other Cassandra's related ports:
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=186055
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=186057

They were submitter about same time. I updated them to work with stage today.

--
A
Comment 17 John Marino freebsd_committer 2014-08-27 20:35:53 UTC
Okay, I think I've tortured you enough, moving this up to patch-ready pool.

I'll take a quick look at the other PRs you mention.
Comment 18 John Marino freebsd_committer 2014-08-27 20:39:59 UTC
As I mentioned on one of those PRs, they are already assigned to perl@ so there is nothing more I can do.  The right people are in control of them.
Comment 19 admins 2014-08-27 20:41:39 UTC
I hope so. Just no comments from them for 8 months...
Comment 20 Kurt Jaeger freebsd_committer 2014-08-29 05:27:22 UTC
With option CQL this happens:

.if ${PORT_OPTIONS:MCQL}
        ${PYTHON_CMD} -m compileall ${WRKSRC}/pylib
.endif

ends with:

===>  Configuring for cassandra-2.0.10
===>  Building for cassandra-2.0.10
-m compileall /usr/local/home/pi/myp/databases/cassandra2/work/apache-cassandra-2.0.10/pylib
make[1]: exec(-m) failed (No such file or directory)
*** Error code 1

I don't know where PYTHON_CMD should be defined. If we find a fix for this,
I can commit it.
Comment 21 Kurt Jaeger freebsd_committer 2014-08-29 05:30:57 UTC
> I don't know where PYTHON_CMD should be defined. If we find a fix for this,
> I can commit it.

Ah: USES=python:2 brings in the _CMD...

One annoyance: portlint -AC has lots of SPACE vrs. TAB issues.
Comment 22 commit-hook freebsd_committer 2014-08-29 07:18:23 UTC
A commit references this bug:

Author: pi
Date: Fri Aug 29 07:18:12 UTC 2014
New revision: 366464
URL: http://svnweb.freebsd.org/changeset/ports/366464

Log:
  New port: databases/cassandra2

  Cassandra is a highly scalable, eventually consistent, distributed,
  structured key-value store. Cassandra brings together the distributed
  systems technologies from Dynamo and the data model from Google's
  BigTable. Like Dynamo, Cassandra is eventually consistent. Like
  BigTable, Cassandra provides a ColumnFamily-based data model richer
  than typical key/value systems.

  Cassandra was open sourced by Facebook in 2008, where it was designed
  by one of the authors of Amazon's Dynamo. In a lot of ways you can
  think of Cassandra as Dynamo 2.0. Cassandra is in production use at
  Facebook but is still under heavy development.

  WWW: http://cassandra.apache.org/

  The previous version is still available as databases/cassandra.

  PR:		186056
  Submitted by:	admins@perceptyx.com

Changes:
  head/databases/Makefile
  head/databases/cassandra2/
  head/databases/cassandra2/Makefile
  head/databases/cassandra2/distinfo
  head/databases/cassandra2/files/
  head/databases/cassandra2/files/cassandra.in
  head/databases/cassandra2/files/patch-env
  head/databases/cassandra2/files/repaircluster.in
  head/databases/cassandra2/pkg-deinstall
  head/databases/cassandra2/pkg-descr
  head/databases/cassandra2/pkg-install
  head/databases/cassandra2/pkg-plist
Comment 23 Kurt Jaeger freebsd_committer 2014-08-29 07:19:39 UTC
Committed with minor changes, thank you for your patience!
Comment 24 admins 2014-08-29 15:35:23 UTC
Created attachment 146486 [details]
Fixed duplicate LATEST_LINKs
Comment 25 admins 2014-08-29 15:35:51 UTC
Created attachment 146487 [details]
Latest poudriere log
Comment 26 admins 2014-08-29 15:36:56 UTC
I added PKGNAMESUFFIX to avoid LATEST_LINKs duplicate.
Comment 27 Kurt Jaeger freebsd_committer 2014-08-29 18:10:31 UTC
Already fixed by antoine@ in r366508.