Bug 186167 - devel/subversion 1.8.5 can not build
Summary: devel/subversion 1.8.5 can not build
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: Olli Hauer
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-01-27 12:40 UTC by Tang Jianfeng
Modified: 2014-02-02 16:51 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tang Jianfeng 2014-01-27 12:40:00 UTC
===>  Building for subversion-1.8.5
--- mkdir-init ---
--- subversion/mod_dav_svn/mod_dav_svn.la ---
--- tools/server-side/svn-rep-sharing-stats ---
--- subversion/mod_dav_svn/mod_dav_svn.la ---
if true ; then cd subversion/mod_dav_svn && /usr/local/bin/libtool --tag=CC --silent --mode=link cc  -Werror=unknown-warning-option -O3 -pipe -mssse3 -march=nocona -fpic -DPIC -fno-strict-aliasing    -L/usr/local/lib -L/usr/local/lib/db46 -L/usr/local/lib  -rpath /usr/local/libexec/apache24 -avoid-version -module  -inst-prefix-dir   -o mod_dav_svn.la  activity.lo authz.lo deadprops.lo liveprops.lo lock.lo merge.lo mirror.lo mod_dav_svn.lo posts/create_txn.lo reports/dated-rev.lo reports/deleted-rev.lo reports/file-revs.lo reports/get-location-segments.lo reports/get-locations.lo reports/get-locks.lo reports/inherited-props.lo reports/log.lo reports/mergeinfo.lo reports/replay.lo reports/update.lo repos.lo util.lo version.lo ../../subversion/libsvn_repos/libsvn_repos-1.la ../../subversion/libsvn_fs/libsvn_fs-1.la ../../subversion/libsvn_delta/libsvn_delta-1.la ../../subversion/libsvn_subr/libsvn_subr-1.la -lintl ; else echo "fake" > subversion/mod_dav_svn/mod_dav_svn.la ; fi
--- tools/server-side/svn-rep-sharing-stats ---
cd tools/server-side && /usr/local/bin/libtool --tag=CC --silent --mode=link cc  -Werror=unknown-warning-option -O3 -pipe -mssse3 -march=nocona -fpic -DPIC -fno-strict-aliasing    -L/usr/local/lib -L/usr/local/lib/db46 -L/usr/local/lib  -rpath /usr/local/lib  -o svn-rep-sharing-stats  svn-rep-sharing-stats.lo ../../subversion/libsvn_repos/libsvn_repos-1.la ../../subversion/libsvn_fs/libsvn_fs-1.la ../../subversion/libsvn_fs_fs/libsvn_fs_fs-1.la ../../subversion/libsvn_subr/libsvn_subr-1.la -L/usr/local/lib -laprutil-1 -L/usr/local/lib -lapr-1 -lintl
--- subversion/mod_dav_svn/mod_dav_svn.la ---
libtool: link: you must specify an output file
libtool: link: Try `libtool --help --mode=link' for more information.
*** [subversion/mod_dav_svn/mod_dav_svn.la] Error code 1

make[2]: stopped in /usr/ports/devel/subversion/work/subversion-1.8.5
1 error

make[2]: stopped in /usr/ports/devel/subversion/work/subversion-1.8.5
===> Compilation failed unexpectedly.
Try to set MAKE_JOBS_UNSAFE=yes and rebuild before reporting the failure to
the maintainer.
*** Error code 1

Stop.
make[1]: stopped in /usr/ports/devel/subversion
*** Error code 1

Stop.
make: stopped in /usr/ports/devel/subversion

How-To-Repeat: cd /usr/ports/devel/subversion
make
Comment 1 Edwin Groothuis freebsd_committer 2014-01-27 17:10:33 UTC
Responsible Changed
From-To: freebsd-ports-bugs->lev

Over to maintainer (via the GNATS Auto Assign Tool)
Comment 2 Yuichiro NAITO 2014-01-31 05:24:50 UTC
I had the same error, too.
This problem occurs only when MOD_DAV_SVN option is enabled.

I fixed files/patch-Makefile.in as following.

> ========================================================================
> This patch is required to build SVN Apache modules with staging support
> ========================================================================
> --- ./Makefile.in.orig 2013-10-21 21:12:04.000000000 +0200
> +++ ./Makefile.in 2013-10-21 21:13:30.000000000 +0200
> @@ -85,7 +85,7 @@
> swig_pydir_extra = @libdir@/svn-python/svn
> swig_pldir = @libdir@/svn-perl
> swig_rbdir = $(SWIG_RB_SITE_ARCH_DIR)/svn/ext
> -toolsdir = @bindir@/svn-tools
> +toolsdir = @bindir@
>
> javahl_javadir = @libdir@/svn-javahl
> javahl_javahdir = @libdir@/svn-javahl/include

This fix is to delete "-inst-prefix-dir ${DESTDIR}" line.
Because ${DESTDIR} gets empty string.
But I'm not sure why ${DESTDIR} is empty.

I succeeded compiling by this fix.
Comment 3 Olli Hauer freebsd_committer 2014-02-02 16:16:06 UTC
Responsible Changed
From-To: lev->ohauer

I'll take it
Comment 4 dfilter service freebsd_committer 2014-02-02 16:40:16 UTC
Author: ohauer
Date: Sun Feb  2 16:40:08 2014
New Revision: 342334
URL: http://svnweb.freebsd.org/changeset/ports/342334
QAT: https://qat.redports.org/buildarchive/r342334/

Log:
  - fix apache module building (r341335 regression) [1]
  - add all necessary KDE dependencies to KDE_KWALLET (r331808 regression) [2]
  - fix shebank (the old way!)  [3]
  
  PR: ports/186167 , Tang Jianfeng <tangjfn@gmail.com> [1]
  PR: ports/186361 , PeterK <fbsdq@peterk.org> [1]
  PR: ports/185494 , Raphael Kubo da Costa <rakuco@FreeBSD.org> [2]
  PR: ports/184295 , Matthias Andree <mandree@FreeBSD.org> [3]
  
  Approved by:	lev (implicit)

Deleted:
  head/devel/subversion17/files/patch-Makefile.in
Modified:
  head/devel/subversion/Makefile.common
  head/devel/subversion/files/patch-Makefile.in
  head/devel/subversion17/Makefile
  head/devel/subversion17/Makefile.common

Modified: head/devel/subversion/Makefile.common
==============================================================================
--- head/devel/subversion/Makefile.common	Sun Feb  2 16:38:22 2014	(r342333)
+++ head/devel/subversion/Makefile.common	Sun Feb  2 16:40:08 2014	(r342334)
@@ -3,7 +3,7 @@
 
 PORTNAME=	subversion
 PORTVERSION=	1.8.5
-PORTREVISION?=	0
+PORTREVISION?=	1
 CATEGORIES+=	devel
 MASTER_SITES=	${MASTER_SITE_APACHE}
 DIST_SUBDIR=	subversion18
@@ -45,7 +45,7 @@ GNOME_KEYRING_LIB_DEPENDS=	libgcr.so:${P
 
 KDE_KWALLET_CONFIGURE_OFF=	--without-kwallet
 KDE_KWALLET_CONFIGURE_ON=	--with-kwallet=${KDE4_PREFIX}
-KDE_KWALLET_USE=		KDE4=kdelibs runtime
+KDE_KWALLET_USE=		KDE4=kdelibs,runtime
 
 MAINTAINER_DEBUG_CFLAGS=	-g
 MAINTAINER_DEBUG_CONFIGURE_ON=	--enable-maintainer-mode --enable-debug
@@ -113,3 +113,9 @@ post-patch:
 .if ${PORT_OPTIONS:MFREEBSD_TEMPLATE} && defined(ORGANIZATION)
 	@${ECHO_CMD} "#define ORGANIZATION_NAME \"${ORGANIZATION}\"" > ${WRKSRC}/subversion/freebsd-organization.h
 .endif
+# shebangfix
+	${GREP} -Rl -e '#!/bin/b' -e '#!/bin/env' -e '#!/usr/bin/p' ${WRKSRC}/tools/ \
+		| ${XARGS} ${REINPLACE_CMD} -e '1s|#\!/bin/b|#\!/usr/local/bin/b|' \
+		-e '1s|#\!/bin/env|#\!/usr/bin/env|' \
+		-e '1s|#\!/usr/bin/p|#\!/usr/local/bin/p|'
+

Modified: head/devel/subversion/files/patch-Makefile.in
==============================================================================
--- head/devel/subversion/files/patch-Makefile.in	Sun Feb  2 16:38:22 2014	(r342333)
+++ head/devel/subversion/files/patch-Makefile.in	Sun Feb  2 16:40:08 2014	(r342334)
@@ -12,12 +12,3 @@ This patch is required to build SVN Apac
  
  javahl_javadir = @libdir@/svn-javahl
  javahl_javahdir = @libdir@/svn-javahl/include
-@@ -207,7 +207,7 @@
- LINK_CXX_LIB = $(LINK_CXX) $(LT_SO_VERSION)
- 
- # special link rule for mod_dav_svn
--LINK_APACHE_MOD = $(LIBTOOL) $(LTFLAGS) --mode=link $(CC) $(LT_LDFLAGS) $(CFLAGS) $(LDFLAGS) -rpath $(APACHE_LIBEXECDIR) -avoid-version -module $(APACHE_LDFLAGS)
-+LINK_APACHE_MOD = $(LIBTOOL) $(LTFLAGS) --mode=link $(CC) $(LT_LDFLAGS) $(CFLAGS) $(LDFLAGS) -rpath $(APACHE_LIBEXECDIR) -avoid-version -module $(APACHE_LDFLAGS) -inst-prefix-dir ${DESTDIR}
- 
- # Special LDFLAGS for some libraries
- libsvn_auth_gnome_keyring_LDFLAGS = @libsvn_auth_gnome_keyring_LDFLAGS@

Modified: head/devel/subversion17/Makefile
==============================================================================
--- head/devel/subversion17/Makefile	Sun Feb  2 16:38:22 2014	(r342333)
+++ head/devel/subversion17/Makefile	Sun Feb  2 16:40:08 2014	(r342334)
@@ -199,7 +199,7 @@ post-install:	${MKREPOS_TARGET}
 	@${MAKE} -C ${WRKSRC} install-tools ${MAKE_ARGS}
 .endif
 	@${MKDIR} ${STAGEDIR}${DATADIR}
-	@(cd ${WRKSRC}/tools.examples && ${TAR} --exclude '*.in' -cf - * | ${TAR} -C ${STAGEDIR}${DATADIR} -xof - )
+	@(cd ${WRKSRC}/tools.examples && ${TAR} --exclude '*.in' --exclude '*.bak' -cf - * | ${TAR} -C ${STAGEDIR}${DATADIR} -xof - )
 
 	@${MKDIR} ${STAGEDIR}${DOCSDIR}
 	${INSTALL_MAN} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}

Modified: head/devel/subversion17/Makefile.common
==============================================================================
--- head/devel/subversion17/Makefile.common	Sun Feb  2 16:38:22 2014	(r342333)
+++ head/devel/subversion17/Makefile.common	Sun Feb  2 16:40:08 2014	(r342334)
@@ -3,7 +3,7 @@
 
 PORTNAME=	subversion
 PORTVERSION=	1.7.14
-PORTREVISION?=	0
+PORTREVISION?=	1
 CATEGORIES+=	devel
 MASTER_SITES=	${MASTER_SITE_APACHE}
 DIST_SUBDIR=	subversion17
@@ -47,7 +47,7 @@ GNOME_KEYRING_LIB_DEPENDS=	libgcr.so:${P
 
 KDE_KWALLET_CONFIGURE_OFF=	--without-kwallet
 KDE_KWALLET_CONFIGURE_ON=	--with-kwallet=${KDE4_PREFIX}
-KDE_KWALLET_USE=		KDE4=kdelibs runtime
+KDE_KWALLET_USE=		KDE4=kdelibs,runtime
 
 MAINTAINER_DEBUG_CFLAGS=	-g
 MAINTAINER_DEBUG_CONFIGURE_ON=	--enable-maintainer-mode --enable-debug
@@ -123,3 +123,9 @@ post-patch:
 .if ${PORT_OPTIONS:MFREEBSD_TEMPLATE} && defined(ORGANIZATION)
 	@${ECHO_CMD} "#define ORGANIZATION_NAME \"${ORGANIZATION}\"" > ${WRKSRC}/subversion/freebsd-organization.h
 .endif
+# shebangfix
+	${GREP} -Rl -e '#!/bin/b' -e '#!/bin/env' -e '#!/usr/bin/p' ${WRKSRC}/tools/ \
+		| ${XARGS} ${REINPLACE_CMD} -e '1s|#\!/bin/b|#\!/usr/local/bin/b|' \
+		-e '1s|#\!/bin/env|#\!/usr/bin/env|' \
+		-e '1s|#\!/usr/bin/p|#\!/usr/local/bin/p|'
+
_______________________________________________
svn-ports-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/svn-ports-all
To unsubscribe, send any mail to "svn-ports-all-unsubscribe@freebsd.org"
Comment 5 Olli Hauer freebsd_committer 2014-02-02 16:51:11 UTC
State Changed
From-To: open->closed

Thanks for your report. 
A fix was committed with svn r342334