Bug 186239 - unbound using missing after upgrading
Summary: unbound using missing after upgrading
Status: Closed Unable to Reproduce
Alias: None
Product: Base System
Classification: Unclassified
Component: misc (show other bugs)
Version: 10.0-RELEASE
Hardware: Any Any
: Normal Affects Only Me
Assignee: freebsd-bugs mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-01-29 14:50 UTC by oz42
Modified: 2015-06-08 10:52 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description oz42 2014-01-29 14:50:00 UTC
after upgrading from 9.2 to 10.0 DNS resolving fails due to missing user:

# getent passwd unbound

# grep unbound /etc/passwd
unbound:*:59:59:Unbound DNS Resolver:/var/unbound:/usr/sbin/nologin

Fix: 

# pw useradd -n unbound -u 59 -g 59 -s /usr/sbin/nologin -d /var/unbound
# /etc/rc.d/local_unbound onestart
Comment 1 Christian Brueffer freebsd_committer 2014-02-19 16:39:09 UTC
State Changed
From-To: open->feedback

Hi Olaf, how did you perform the update, by updating from source or through 
freebsd-update?  If by source, did you run mergemaster or etcmerge afterwards? 
If by freebsd-update, do you have local modifications to freebsd-update.conf 
that prohibit updates to /etc to your local version? 

Generally, the user was added as part of the unbound import before 10-RELEASE, 
so this sounds more like a local issue.
Comment 2 oz42 2015-06-08 10:52:35 UTC
Let us close this, it is too old to reproduce. Sorry for not giving feedback!