Bug 186392 - www/rubygem-sinatra: requires rubygem-tilt 1.3.x, not 2.0.0
Summary: www/rubygem-sinatra: requires rubygem-tilt 1.3.x, not 2.0.0
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: Po-Chuan Hsieh
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-02-02 22:10 UTC by Daniel Roethlisberger
Modified: 2014-02-05 20:10 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Daniel Roethlisberger 2014-02-02 22:10:00 UTC
Sinatra 1.4.4 requires Tilt 1.3.x and does not run with Tilt 2.0.0.  With
latest packages installed, running a Sinatra app results in the following
exception, AFAICS breaking all Sinatra apps using the gem from ports/packages:

/usr/local/lib/ruby/site_ruby/1.9/rubygems/dependency.rb:247:in `to_specs': Could not find tilt (>= 1.3.4, ~> 1.3) amongst [daemons-1.1.9, diff-lcs-1.2.5, eventmachine-1.0.3, git-1.2.5, grit-2.5.0, haml-4.0.4, kgio-2.8.0, mime-types-1.25.1, posix-spawn-0.3.6, rack-1.4.5, rack-protection-1.5.0, raindrops-0.11.0, rdiscount-2.1.6, sinatra-1.4.4, thin-1.2.11, tilt-2.0.0, unicorn-4.6.3] (Gem::LoadError)
	from /usr/local/lib/ruby/site_ruby/1.9/rubygems/specification.rb:778:in `block in activate_dependencies'
	from /usr/local/lib/ruby/site_ruby/1.9/rubygems/specification.rb:767:in `each'
	from /usr/local/lib/ruby/site_ruby/1.9/rubygems/specification.rb:767:in `activate_dependencies'
	from /usr/local/lib/ruby/site_ruby/1.9/rubygems/specification.rb:751:in `activate'
	from /usr/local/lib/ruby/site_ruby/1.9/rubygems.rb:212:in `rescue in try_activate'
	from /usr/local/lib/ruby/site_ruby/1.9/rubygems.rb:209:in `try_activate'
	from /usr/local/lib/ruby/site_ruby/1.9/rubygems/custom_require.rb:59:in `rescue in require'
	from /usr/local/lib/ruby/site_ruby/1.9/rubygems/custom_require.rb:35:in `require'
	from ./helloworld.rb:2:in `<main>'

How-To-Repeat: # pkg install rubygem-sinatra
$ cat >helloworld.rb <<EOF
#!/usr/bin/env ruby
require 'sinatra'
get '/hi' do
  "Hello World!"
end
EOF
$ chmod 755 helloworld.rb
$ ./helloworld.rb
Comment 1 Edwin Groothuis freebsd_committer 2014-02-02 22:10:21 UTC
Responsible Changed
From-To: freebsd-ports-bugs->ruby

Over to maintainer (via the GNATS Auto Assign Tool)
Comment 2 Po-Chuan Hsieh freebsd_committer 2014-02-05 19:23:21 UTC
Responsible Changed
From-To: ruby->sunpoet

I'll take it.
Comment 3 dfilter service freebsd_committer 2014-02-05 20:03:54 UTC
Author: sunpoet
Date: Wed Feb  5 20:03:46 2014
New Revision: 342834
URL: http://svnweb.freebsd.org/changeset/ports/342834
QAT: https://qat.redports.org/buildarchive/r342834/

Log:
  - Fix .gemspec for rubygem-tilt 2.0.0
  - Bump PORTREVISION for package change
  
  PR:		ports/186392
  Submitted by:	Daniel Roethlisberger <daniel@roe.ch>

Modified:
  head/www/rubygem-sinatra/Makefile

Modified: head/www/rubygem-sinatra/Makefile
==============================================================================
--- head/www/rubygem-sinatra/Makefile	Wed Feb  5 20:03:40 2014	(r342833)
+++ head/www/rubygem-sinatra/Makefile	Wed Feb  5 20:03:46 2014	(r342834)
@@ -3,6 +3,7 @@
 
 PORTNAME=	sinatra
 PORTVERSION=	1.4.4
+PORTREVISION=	1
 CATEGORIES=	www rubygems
 MASTER_SITES=	RG
 
@@ -19,4 +20,7 @@ USE_RUBY=	yes
 USE_RUBYGEMS=	yes
 RUBYGEM_AUTOPLIST=	yes
 
+post-patch:
+	@${REINPLACE_CMD} -e '34 s|~>|">="|' ${WRKSRC}/${GEM_NAME}.gemspec
+
 .include <bsd.port.mk>
_______________________________________________
svn-ports-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/svn-ports-all
To unsubscribe, send any mail to "svn-ports-all-unsubscribe@freebsd.org"
Comment 4 Po-Chuan Hsieh freebsd_committer 2014-02-05 20:05:47 UTC
State Changed
From-To: open->closed

Committed. Thanks!