Bug 186402 - net/delegate can't compile
net/delegate can't compile
Status: Closed FIXED
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s)
Any Any
: Normal Affects Only Me
Assigned To: John Marino
Depends on:
  Show dependency treegraph
Reported: 2014-02-03 09:10 UTC by ribbon
Modified: 2014-06-20 16:40 UTC (History)
2 users (show)

See Also:


Note You need to log in before you can comment on or make changes to this bug.
Description ribbon 2014-02-03 09:10:00 UTC
   /usr/ports/net/delegate make fail.

Fix: # diff -urN Makefile.org Makefile

NO_STAGE=      yes
        @cd ${WRKSRC} && ${MV} COPYRIGHT doc/--qPXoezAvUrYsgHNklqmg15ASrPaLCZl8J6oSQLgJc6oHRdGW
Content-Type: text/plain; name="file.diff"
Content-Transfer-Encoding: 7bit
Content-Disposition: attachment; filename="file.diff"

--- Makefile.org        2014-01-23 02:00:46.000000000 +0900
+++ Makefile    2014-02-03 09:51:55.000000000 +0900
@@ -20,6 +20,7 @@
Comment 1 Edwin Groothuis freebsd_committer 2014-02-03 09:10:07 UTC
State Changed
From-To: open->feedback

Awaiting maintainers feedback (via the GNATS Auto Assign Tool)
Comment 2 Edwin Groothuis freebsd_committer 2014-02-03 09:10:07 UTC
Maintainer of net/delegate,

Please note that PR ports/186402 has just been submitted.

If it contains a patch for an upgrade, an enhancement or a bug fix
you agree on, reply to this email stating that you approve the patch
and a committer will take care of it.

The full text of the PR can be found at:

Edwin Groothuis via the GNATS Auto Assign Tool
Comment 3 John Marino freebsd_committer 2014-06-10 12:48:13 UTC
Hi Chifeng Qu,
Can you respond to this PR?

It looks straight-forward, and presumably reproducible with MAKE_JOBS set higher (e.g. 4 or 8 or whatever)
Comment 4 John Marino freebsd_committer 2014-06-19 11:43:54 UTC
I'm about to reset maintainership on this this port due to lack of response.  it's not staged and it's an interactive port, which is a very bad combination.  Are you interested in:

1) making the port non-interactive
2) providing stage support
3) being the maintainer


if not, unless I hear from Chifeng Qu extremely soon, I'm going to deprecate the port for eventual removal.
Comment 5 commit-hook freebsd_committer 2014-06-20 16:36:13 UTC
A commit references this bug:

Author: marino
Date: Fri Jun 20 16:36:11 UTC 2014
New revision: 358602
URL: http://svnweb.freebsd.org/changeset/ports/358602

  net/delegate: Mark jobs unsafe, reset maintainer

  Maintainer is non-responsive, no communication since 2010.  Port is
  unstaged but will be deprecated in imminent commit.

  PR:		186402
  Submitted by:	ribbon (ribbon.or.jp)
  Approved by:	maintainer timeout (4 months)
  Approved by:	portmgr (implicit)

Comment 6 John Marino freebsd_committer 2014-06-20 16:40:28 UTC
This port will be removed in 2 months if it's not significantly updated (meaning not converted to a regular port).  Until this, it builds with a single core.