Bug 186431 - BROKEN www/hiawatha fails to start after make install: Error creating work directory '/usr/local/var/lib/hiawatha'
Summary: BROKEN www/hiawatha fails to start after make install: Error creating work di...
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: Tijl Coosemans
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-02-03 22:30 UTC by Chris Hutchinson
Modified: 2014-09-01 20:45 UTC (History)
3 users (show)

See Also:


Attachments
proposed patch (2.02 KB, patch)
2014-08-08 14:24 UTC, Tijl Coosemans
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Chris Hutchinson 2014-02-03 22:30:00 UTC
The build && install process completed w/o errors,
using the bare minimum to test the operation in:

/usr/local/etc/hiawatha/mimetype.conf

then followed by:

/usr/local/etc/rc.d/hiawatha start

results in:

Starting hiawatha.
Error creating work directory '/usr/local/var/lib/hiawatha'

I have made NO references to /usr/local/var/lib/hiawatha anywhere.
I have no idea where this could come from, except within the Makefile
provided within www/hiawatha

Fix: 

UNKNOWN
How-To-Repeat: cd /usr/ports/www/hiawatha
make install
Comment 1 Edwin Groothuis freebsd_committer 2014-02-03 22:30:08 UTC
State Changed
From-To: open->feedback

Awaiting maintainers feedback (via the GNATS Auto Assign Tool)
Comment 2 Edwin Groothuis freebsd_committer 2014-02-03 22:30:08 UTC
Maintainer of www/hiawatha,

Please note that PR ports/186431 has just been submitted.

If it contains a patch for an upgrade, an enhancement or a bug fix
you agree on, reply to this email stating that you approve the patch
and a committer will take care of it.

The full text of the PR can be found at:
    http://www.freebsd.org/cgi/query-pr.cgi?pr=ports/186431

-- 
Edwin Groothuis via the GNATS Auto Assign Tool
edwin@FreeBSD.org
Comment 3 Chris Hutchinson 2014-02-03 22:53:40 UTC
Found the problen and Solution
The cure can be created within www/hiawatha/Makefile

find the line containing:

PLIST_SUB+=	ECHO_MSG=${ECHO_MSG}

and change into:

PLIST_SUB+=	ECHO_MSG=${ECHO_MSG}

NO_STAGE= yes

save, and make install as normal.
Comment 4 John Marino freebsd_committer 2014-07-11 23:09:52 UTC
er, what? 

Adding "NO_STAGE=yes" is not a solution.  :)


Notifying maintainer.
Comment 5 John Marino freebsd_committer 2014-07-11 23:10:16 UTC
notifying maintainer
Comment 6 Tijl Coosemans freebsd_committer 2014-07-12 10:29:30 UTC
The port should be be fixed to use /var instead of PREFIX/var
Comment 7 Anonymous 2014-07-13 21:12:05 UTC
I will fix this when I get back home, I'm out of the country atm.
Comment 8 Anonymous 2014-07-13 21:21:13 UTC
(In reply to chris from comment #7)
> I will fix this when I get back home, I'm out of the country atm.
Inet on here is way to slow to even mess with the Makefile this will have to wait 2 weeks.
Comment 9 Chris Hutchinson 2014-07-15 20:45:42 UTC
(In reply to John Marino from comment #4)
> er, what? 
> 
> Adding "NO_STAGE=yes" is not a solution.  :)
> 
> 
> Notifying maintainer.

LOL. I get away with _nothing_, when you're on duty, John. :)

--Chris
Comment 10 Anonymous 2014-08-08 13:25:02 UTC
I can't reproduce this?
Comment 11 Tijl Coosemans freebsd_committer 2014-08-08 14:24:05 UTC
Created attachment 145523 [details]
proposed patch

Please try this patch.  The problem is that PREFIX/var/lib/hiawatha is an empty directory which requires special treatment (@exec mkdir) with the old pkg_install tools.  The patch also sets LOCALSTATEDIR=/var so PREFIX/var/lib/hiawatha moves to /var/lib/hiawatha.  It has been tested on Redports: https://redports.org/buildarchive/20140808140009-75695/
Comment 12 commit-hook freebsd_committer 2014-09-01 20:44:26 UTC
A commit references this bug:

Author: tijl
Date: Mon Sep  1 20:43:26 UTC 2014
New revision: 366954
URL: http://svnweb.freebsd.org/changeset/ports/366954

Log:
  Use /var instead of PREFIX/var

  PR:		186431
  Approved by:	maintainer timeout (3 weeks)

Changes:
  head/www/hiawatha/Makefile
  head/www/hiawatha/pkg-plist