Bug 186455 - editors/libreoffice crashes with Signal 10 bus error on i386
Summary: editors/libreoffice crashes with Signal 10 bus error on i386
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: FreeBSD Office Team (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-02-04 16:10 UTC by Dwayne MacKinnon
Modified: 2018-01-12 09:09 UTC (History)
3 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dwayne MacKinnon 2014-02-04 16:10:00 UTC
This is an odd one. For one thing, it only exists on i386. On amd64 everything works just fine. 

When compiled with KDE4 desktop environment support *and* run in KDE, libreoffice will crash & create a core file. Running the core file in gdb gives:
Core was generated by `soffice.bin'.
Program terminated with signal 10, Bus error.

If you start X with TWM, this problem does not occur. If compiled without KDE4 desktop environment support this problem does not occur within KDE.

How-To-Repeat: On FreeBSD 9.2-RELEASE i386 compile libreoffice with the KDE4 desktop environment support option enabled.

Start KDE4.

Start libreoffice.
Comment 1 Edwin Groothuis freebsd_committer 2014-02-04 16:10:08 UTC
Responsible Changed
From-To: freebsd-ports-bugs->office

Over to maintainer (via the GNATS Auto Assign Tool)
Comment 2 Torsten Zühlsdorff 2015-09-23 10:37:08 UTC
(In reply to dmk from comment #0)

Hello,

since this month editor/libreoffice contains libreoffice 5. Can you reproduce the error with the new version? 

Greetings,
Torsten
Comment 3 Walter Schwarzenfeld freebsd_triage 2018-01-12 01:26:30 UTC
9.2 is gone. Could be closed.
Comment 4 Torsten Zuehlsdorff freebsd_committer 2018-01-12 09:09:39 UTC
I second that! Closed.