Bug 186535 - textproc/libvisio: configure: error: Required boost headers not found. install boost >= 1.36
Summary: textproc/libvisio: configure: error: Required boost headers not found. instal...
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: FreeBSD Office Team
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-02-07 16:20 UTC by O. Hartmann
Modified: 2014-02-07 23:01 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description O. Hartmann 2014-02-07 16:20:00 UTC
Update of port textproc/libvisio fails with:


[...]

configure: error: Required boost headers not found. install boost >= 1.36
===>  Script "configure" failed unexpectedly.
Please report the problem to office@FreeBSD.org [maintainer] and attach the
"/usr/ports/textproc/libvisio/work/libvisio-0.0.31/config.log" including the
output of the failure of your make command. Also, it might be a good idea to
provide an overview of all packages installed on your system (e.g. a
/usr/local/sbin/pkg-static info -g -Ea).
*** Error code 1

BOOST is installed and has recently been updated:

pkg info -x boost

boost-jam-1.55.0
boost-libs-1.55.0
boost-python-libs-1.55.0
Comment 1 Edwin Groothuis freebsd_committer 2014-02-07 16:20:07 UTC
Responsible Changed
From-To: freebsd-ports-bugs->office

Over to maintainer (via the GNATS Auto Assign Tool)
Comment 2 Baptiste Daroussin freebsd_committer 2014-02-07 17:46:35 UTC
On Fri, Feb 07, 2014 at 04:13:48PM +0000, O. Hartmann wrote:
> 
> >Number:         186535
> >Category:       ports
> >Synopsis:       textproc/libvisio: configure: error: Required boost headers not found. install boost >= 1.36
> >Confidential:   no
> >Severity:       non-critical
> >Priority:       low
> >Responsible:    freebsd-ports-bugs
> >State:          open
> >Quarter:        
> >Keywords:       
> >Date-Required:
> >Class:          sw-bug
> >Submitter-Id:   current-users
> >Arrival-Date:   Fri Feb 07 16:20:00 UTC 2014
> >Closed-Date:
> >Last-Modified:
> >Originator:     O. Hartmann
> >Release:        FreeBSD 11.0-CURRENT/amd64
> >Organization:
> >Environment:
> FreeBSD 11.0-CURRENT #0 r261490: Tue Feb  4 18:17:50 CET 2014 amd64
> >Description:
> Update of port textproc/libvisio fails with:
> 
> 
> [...]
> 
> configure: error: Required boost headers not found. install boost >= 1.36
> ===>  Script "configure" failed unexpectedly.
> Please report the problem to office@FreeBSD.org [maintainer] and attach the
> "/usr/ports/textproc/libvisio/work/libvisio-0.0.31/config.log" including the
> output of the failure of your make command. Also, it might be a good idea to
> provide an overview of all packages installed on your system (e.g. a
> /usr/local/sbin/pkg-static info -g -Ea).
> *** Error code 1
> 
> BOOST is installed and has recently been updated:
> 
> pkg info -x boost
> 
> boost-jam-1.55.0
> boost-libs-1.55.0
> boost-python-libs-1.55.0
> 
> 

I cannot reproduce can you send me your config.log?

regards,
Bapt
Comment 3 Michael Moll freebsd_committer 2014-02-07 18:29:40 UTC
to work around this,
#include <algorithm>
can be added to
/usr/local/include/boost/archive/iterators/transform_width.hpp
Comment 4 Jung-uk Kim freebsd_committer 2014-02-07 23:00:06 UTC
State Changed
From-To: open->closed

This should be fixed with r343304.  Thanks!