Bug 186629 - multimedia/vlc fails to build when 'pulseaudio' option is selected
multimedia/vlc fails to build when 'pulseaudio' option is selected
Status: Closed Rejected
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s)
Latest
Any Any
: Normal Affects Only Me
Assigned To: freebsd-multimedia
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-02-10 14:10 UTC by bobf
Modified: 2014-09-11 11:02 UTC (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description bobf 2014-02-10 14:10:00 UTC
when attempting to build multimedia/vlc the vlc-cache-gen program crashes near the end of the build, if the 'PULSEAUDIO' option has been selected in the port configuration screen.  Un-selecting this single option in the config screen enabled the port to build.  Port version is vlc-2.1.2_2,4

Fix: 

de-select the PULSEAUDIO option in 'make config'
How-To-Repeat: select the 'PULSEAUDIO' option in 'make config', then 'make' or 'make install'
Comment 1 Edwin Groothuis freebsd_committer 2014-02-11 00:50:06 UTC
Responsible Changed
From-To: freebsd-ports-bugs->freebsd-multimedia

Over to maintainer (via the GNATS Auto Assign Tool)
Comment 2 nox 2014-04-25 21:37:38 UTC
This might be a duplicate of ports/172185 - seems the rtld
fix mentioned there was not MFC'd all the way back to 8...
Comment 3 Tijl Coosemans freebsd_committer 2014-06-11 12:49:43 UTC
This should work on FreeBSD 9 and up.  Is it possible for you to upgrade FreeBSD?  Because then I don't have to spend time trying to figure out which patches need to be merged to 8.
Comment 4 commit-hook freebsd_committer 2014-09-11 10:46:32 UTC
A commit references this bug:

Author: riggs
Date: Thu Sep 11 10:45:59 UTC 2014
New revision: 367917
URL: http://svnweb.freebsd.org/changeset/ports/367917

Log:
  - Mark IGNORE when trying to use pulseaudio with vlc on
    pre-9.x systems due to an rtld issue during build

  PR:		186629
  Submitted by:	bobf@mrp3.com

Changes:
  head/multimedia/vlc/Makefile
Comment 5 Thomas Zander freebsd_committer 2014-09-11 11:02:32 UTC
For now, mark port IGNORE if pulseaudio is selected on 8.x systems.
Rationale:
1) It is not enabled by default
2) There will not be another release from stable/8
3) Works as intended on 9.x and later

If it is possible to fix this on a port level, patches are, of course, always welcome!