Bug 186947 - [PATCH] java/dbvis: update to 9.1.6, move to databases/, take maintainership
Summary: [PATCH] java/dbvis: update to 9.1.6, move to databases/, take maintainership
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: John Marino
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-02-21 15:00 UTC by jim
Modified: 2014-07-12 10:56 UTC (History)
1 user (show)

See Also:


Attachments
dbvis-9.1.6.patch (1.41 KB, patch)
2014-02-21 15:00 UTC, jim
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description jim 2014-02-21 15:00:00 UTC
- Update to 9.1.6
- Take maintainership
- Add license
- Adjust "Categories" to more intuitive - will need entry in "MOVED"

Generated with FreeBSD Port Tools 1.00.2014.02.18 (mode: update, diff: SVN)
Comment 1 John Marino freebsd_committer 2014-07-11 23:28:41 UTC
I don't think it needs a MOVED entry since it's primary in java category, so this would only affect package symlinks I believe.
Comment 2 John Marino freebsd_committer 2014-07-12 10:28:59 UTC
the install target is a mess (wrong: it symlinks to stagedir and sets permissions there too) but that part wasn't caused by this patch.  It was there before, but poudriere 3.0 doesn't catch it.
Comment 3 John Marino freebsd_committer 2014-07-12 10:34:41 UTC
okay, I misunderstood what it was doing.  it's making an absolute dangling symlink that points to a directory upon installation.  So technically it worked, although I think a relative link would be better.
Comment 4 commit-hook freebsd_committer 2014-07-12 10:47:18 UTC
A commit references this bug:

Author: marino
Date: Sat Jul 12 10:46:36 UTC 2014
New revision: 361608
URL: http://svnweb.freebsd.org/changeset/ports/361608

Log:
  java/dbvis: Update version 7.1 => 9.1.6 and stage

  Also:
    * Annotate dbVisualizer license
    * Switch categories from "java devel" to "java databases"
    * Switch absolute dbvis symlink to relative one (marino)
    * passing maintainership to submitter

  PR:		186947
  Submitted by:	jim (ohlste.in)

Changes:
  head/java/dbvis/Makefile
  head/java/dbvis/distinfo