Bug 187130 - lang/mono: unbreak relative paths for xbuild
Summary: lang/mono: unbreak relative paths for xbuild
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: freebsd-mono (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-02-28 07:50 UTC by Marcus von Appen
Modified: 2014-03-14 11:28 UTC (History)
1 user (show)

See Also:


Attachments
mono.diff (1.33 KB, patch)
2014-02-28 07:50 UTC, Marcus von Appen
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Marcus von Appen freebsd_committer freebsd_triage 2014-02-28 07:50:00 UTC
	The update of mono to version 3.2.8 introduced a bug, which breaks
    lang/ironpython due to relative paths with wildcards.
    The attached patch fixes xbuild to use the correct paths.
    A revision bump is necessary.

How-To-Repeat: 	Try to build lang/ironpython
Comment 1 Edwin Groothuis freebsd_committer 2014-03-01 18:21:03 UTC
Class Changed
From-To: sw-bug->maintainer-update

Fix category (submitter is maintainer) (via the GNATS Auto Assign Tool)
Comment 2 Edwin Groothuis freebsd_committer 2014-03-01 18:21:04 UTC
Responsible Changed
From-To: freebsd-ports-bugs->mva

Submitter is maintainer and has GNATS access (via the GNATS Auto Assign 
Tool)
Comment 3 Marcus von Appen freebsd_committer freebsd_triage 2014-03-02 11:05:00 UTC
Responsible Changed
From-To: mva->mono

Assign to correct maintainre 
Fix synopsis
Comment 4 Romain Tartière 2014-03-12 11:07:19 UTC
Hi!

Has the problem been reported upstream ?

The commit introducting this regression seems to be
https://github.com/mono/mono/commit/f7a787b140751c2650319d63bf06fb7ca1a769a8

Thanks for your feedback

-- 
Romain Tartière <romain@blogreen.org>        http://romain.blogreen.org/
pgp: 8234 9A78 E7C0 B807 0B59  80FF BA4D 1D95 5112 336F (ID: 0x5112336F)
(plain text =non-HTML= PGP/GPG encrypted/signed e-mail much appreciated)
Comment 5 dfilter service freebsd_committer 2014-03-12 11:46:11 UTC
Author: romain
Date: Wed Mar 12 11:46:03 2014
New Revision: 347977
URL: http://svnweb.freebsd.org/changeset/ports/347977
QAT: https://qat.redports.org/buildarchive/r347977/

Log:
  Unbreak relative paths for xbuild
  
  PR:		ports/187130
  Submitted by:	mva

Added:
  head/lang/mono/files/patch-mcs_class_Microsoft.Build.Engine_Microsoft.Build.BuildEngine_DirectoryScanner.cs   (contents, props changed)
Modified:
  head/lang/mono/Makefile

Modified: head/lang/mono/Makefile
==============================================================================
--- head/lang/mono/Makefile	Wed Mar 12 11:36:05 2014	(r347976)
+++ head/lang/mono/Makefile	Wed Mar 12 11:46:03 2014	(r347977)
@@ -3,6 +3,7 @@
 
 PORTNAME=	mono
 PORTVERSION=	3.2.8
+PORTREVISION=	1
 CATEGORIES=	lang
 MASTER_SITES=	http://download.mono-project.com/sources/${PORTNAME}/
 

Added: head/lang/mono/files/patch-mcs_class_Microsoft.Build.Engine_Microsoft.Build.BuildEngine_DirectoryScanner.cs
==============================================================================
--- /dev/null	00:00:00 1970	(empty, because file is newly added)
+++ head/lang/mono/files/patch-mcs_class_Microsoft.Build.Engine_Microsoft.Build.BuildEngine_DirectoryScanner.cs	Wed Mar 12 11:46:03 2014	(r347977)
@@ -0,0 +1,11 @@
+--- mcs/class/Microsoft.Build.Engine/Microsoft.Build.BuildEngine/DirectoryScanner.cs.orig	2014-02-28 08:27:40.000000000 +0100
++++ mcs/class/Microsoft.Build.Engine/Microsoft.Build.BuildEngine/DirectoryScanner.cs	2014-02-28 08:28:16.000000000 +0100
+@@ -98,7 +98,7 @@
+ 				int offset = 0;
+ 				string full_path;
+ 				if (Path.IsPathRooted (name)) {
+-					full_path = name;
++					full_path = Path.GetFullPath (name);
+ 					baseDirectory = new DirectoryInfo (Path.GetPathRoot (name));
+ 					if (IsRunningOnWindows)
+ 						// skip the "drive:"
_______________________________________________
svn-ports-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/svn-ports-all
To unsubscribe, send any mail to "svn-ports-all-unsubscribe@freebsd.org"
Comment 6 Romain Tartière freebsd_committer 2014-03-12 11:46:39 UTC
State Changed
From-To: open->feedback

A fix was committed, but the problem may need to be reported upstream.
Comment 7 Marcus von Appen freebsd_committer freebsd_triage 2014-03-13 19:51:37 UTC
Romain Tartière <romain@blogreen.org>:

> Hi!
>
> Has the problem been reported upstream ?

Yes, a pull request is available at https://github.com/mono/mono/pull/924.

Cheers
Marcus
Comment 8 Romain Tartière freebsd_committer 2014-03-14 11:28:23 UTC
State Changed
From-To: feedback->closed

Okay, I close the PR then.