Bug 187133 - www/trac: fix rc script; backport fix for upstream #11345
Summary: www/trac: fix rc script; backport fix for upstream #11345
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: John Marino
URL:
Keywords:
: 189320 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-02-28 09:50 UTC by lorne
Modified: 2014-09-16 22:09 UTC (History)
2 users (show)

See Also:


Attachments
trac.patch (1.88 KB, patch)
2014-02-28 09:50 UTC, lorne
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description lorne 2014-02-28 09:50:02 UTC
1. Add PYTHON_CMD to SUB_LIST to fix the following in the rc script:

    command="%%PYTHON_CMD%%"

2. Backport a fix from upstream #11345 [1]. Not a FreeBSD or ports
specific problem, but prevents some functionality from working by
default. If this is an inappropriate change for ports please
cherry-pick the SUB_LIST fix.

[1] http://trac.edgewall.org/ticket/11345
Comment 1 Edwin Groothuis freebsd_committer 2014-02-28 09:50:15 UTC
Responsible Changed
From-To: freebsd-ports-bugs->clsung

Over to maintainer (via the GNATS Auto Assign Tool)
Comment 2 John Marino freebsd_committer 2014-07-28 08:26:55 UTC
port now unmaintained, resetting assignee
Comment 3 John Marino freebsd_committer 2014-08-26 07:52:55 UTC
*** Bug 189320 has been marked as a duplicate of this bug. ***
Comment 4 John Marino freebsd_committer 2014-08-26 07:54:04 UTC
move this to patch-ready for evaluation
Comment 5 commit-hook freebsd_committer 2014-09-16 22:08:52 UTC
A commit references this bug:

Author: marino
Date: Tue Sep 16 22:08:37 UTC 2014
New revision: 368350
URL: http://svnweb.freebsd.org/changeset/ports/368350

Log:
  www/trac: Backport fix for upstream issue #11345

  PR:		187133
  Submitted by:	lorne (cons.org.nz)

Changes:
  head/www/trac/Makefile
  head/www/trac/files/patch-trac_util_translation.py
Comment 6 John Marino freebsd_committer 2014-09-16 22:09:56 UTC
The first part has been done for months, so I only take care of the backport.