Bug 187191 - devel/yaml-cpp to 0.5.1
Summary: devel/yaml-cpp to 0.5.1
Status: Closed DUPLICATE of bug 192330
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: freebsd-ports-bugs mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-03-02 11:10 UTC by gergely.czuczy
Modified: 2014-08-03 21:52 UTC (History)
4 users (show)

See Also:


Attachments
file.diff (2.83 KB, patch)
2014-03-02 11:10 UTC, gergely.czuczy
no flags Details | Diff
patch.txt (4.11 KB, patch)
2014-04-09 06:43 UTC, hiroto.kagotani
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description gergely.czuczy 2014-03-02 11:10:00 UTC
The attached patch updates devel/yaml-cpp from 0.3.0 to 0.5.1

Fix: apply the patch


Patch attached with submission follows:
How-To-Repeat: port is outdated
Comment 1 Edwin Groothuis freebsd_committer 2014-03-02 11:38:21 UTC
Maintainer of devel/yaml-cpp,

Please note that PR ports/187191 has just been submitted.

If it contains a patch for an upgrade, an enhancement or a bug fix
you agree on, reply to this email stating that you approve the patch
and a committer will take care of it.

The full text of the PR can be found at:
    http://www.freebsd.org/cgi/query-pr.cgi?pr=ports/187191

-- 
Edwin Groothuis via the GNATS Auto Assign Tool
edwin@FreeBSD.org
Comment 2 Edwin Groothuis freebsd_committer 2014-03-02 11:38:22 UTC
State Changed
From-To: open->feedback

Awaiting maintainers feedback (via the GNATS Auto Assign Tool)
Comment 3 hiroto.kagotani 2014-04-09 06:43:40 UTC
I've made an alternative patch for updating yaml-cpp to 0.5.1.

The difference is:
* installs libyaml-cpp.so.0 instead of libyaml-cpp.so.0.5
* "port test" & redports clean

-- 
Hiroto Kagotani
<hiroto.kagotani@gmail.com>
Comment 4 Raphael Kubo da Costa freebsd_committer 2014-06-20 15:47:41 UTC
CC'ing maintainer.
Comment 5 John Marino freebsd_committer 2014-07-27 15:55:36 UTC
maintainer timed out, anyone can commit this patch
Comment 6 Raphael Kubo da Costa freebsd_committer 2014-07-27 19:44:15 UTC
(In reply to hiroto.kagotani from comment #3)
> I've made an alternative patch for updating yaml-cpp to 0.5.1.
> 
> The difference is:
> * installs libyaml-cpp.so.0 instead of libyaml-cpp.so.0.5
> * "port test" & redports clean

I've tested this one locally. While the port itself builds fine, the ones that
depend on it (chinese/librime, games/openxcom and graphics/opencolorio) all
fail to build with it, possibly due to 0.5 being API-incompatible with 0.3.x.

Additionally, the dependency on boost must be a LIB_DEPENDS, not a build one,
since one of the port's headers includes boost's shared_ptr.hpp.
Comment 7 John Marino freebsd_committer 2014-08-03 21:37:32 UTC
alright, I guess it's not "patch-ready", move it back to "open"
Comment 8 Guido Falsi freebsd_committer 2014-08-03 21:42:06 UTC
Please note that I also filed a new port yaml-cpp05 in the following PR 192330 as part of an update to games/openxcom.

yaml-cpp 0.5 has a different API than 0.3, so we need both ports to coexist.

At present all ports using it depend on the 0.3 API.

New versions of openxcom will require the 0.5 API. There are no other ports using the 0.5 API at present.
Comment 9 Guido Falsi freebsd_committer 2014-08-03 21:43:34 UTC
(In reply to Guido Falsi from comment #8)

> PR 192330 as part of an update to games/openxcom.


Bug 192330 (hope this one gets transformed in a link)
Comment 10 John Marino freebsd_committer 2014-08-03 21:45:30 UTC
So we should close this PR then, right?  There's not going to be any action to take IIUC.
Comment 11 Guido Falsi freebsd_committer 2014-08-03 21:52:01 UTC
Marking as duplicate of bug 192330.

That bug is an update for games/openxcom, which includes a new port of yaml-cpp 0.5.1 which can coexist on the same machine with yaml-cpp 0.3.x.

*** This bug has been marked as a duplicate of bug 192330 ***