Bug 187700 - FreeBSD Guest in Virtual Box NAT environment - PCnet-FAST III(Am79C973) - not receiving IP address
Summary: FreeBSD Guest in Virtual Box NAT environment - PCnet-FAST III(Am79C973) - not...
Status: Open
Alias: None
Product: Base System
Classification: Unclassified
Component: misc (show other bugs)
Version: 10.0-RELEASE
Hardware: Any Any
: Normal Affects Only Me
Assignee: vbox
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-03-18 16:30 UTC by Sastry Tumuluri
Modified: 2015-07-30 20:54 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sastry Tumuluri 2014-03-18 16:30:00 UTC
I'm trying to use FreeBSD 10.0-RELEASE (amd64) on VirtualBox (3.2.x and 3.3.8) with the network setting (on VirtualBox) in NAT mode.

When I choose either of these adapters in VirtualBox Settings->network->NAT->Advanced:
-- PCnet-FAST III(Am79C973) 
-- Intel PRO/1000 MT Server (82545EM)
Upon boot, there is no IP address and the VM can't reach out to the internet. 

I tried assigning the IP address manually, but still can't reach out (ping can't reach the VirtualBox-internal default gateway: 10.0.2.2)

Boot time messages show 6x DHCPDISCOVER but no DHCPOFFER response.
Manually invoking dhclient shows the same symptom (6x DHCPDISCOVER, no DHCPOFFER).

The following adapters seem to work (obtain the IP address 10.0.2.15 from VirtualBox and get out to the Internet) just fine:
-- Intel PRO/1000 MT Desktop (82540EM) -- default
-- Intel PRO/1000 T Server (82543GC)
-- PCnet-PCI II(Am79C970A)

All the five adapters work fine on other guest OSes (e.g., xubuntu Linux).

Other info: 
1. All this, on Acer Travelmate 8372 running Xubuntu 13.10 (all updates and patches are current) as Host OS. I haven't tried this on any other system (will do if someone feels it may be relevant).

2. The problem exists in 9.2-RELEASE (amd64) as well.
Comment 1 Sean Bruno freebsd_committer 2015-07-23 16:46:35 UTC
Can re@ test this out as VM images are now being built?  I assume this works as it is what I have configured on my home machine for VMs
Comment 2 Glen Barber freebsd_committer 2015-07-24 00:32:38 UTC
We do not test with every knob turned and button pushed for testing.

To the OP:  Can you please confirm if this is still an issue with 10.2-BETA2 and later?
Comment 3 Warren Block freebsd_committer 2015-07-24 03:27:55 UTC
For an additional data point:

Host: FreeBSD 10.2-BETA2 #0 r285817 amd64
VirtualBox 4.3.30 installed from ports
VM network set to NAT

Same performance on an i386 FreeBSD client running 10.2-PRERELEASE either r285148 or r285832:

PCnet-FAST III (Am79C973) (pcn0) - no DHCPOFFER, does not work
Intel PRO/1000 MT Server (82545EM) - DHCP lease received, works
Comment 4 Glen Barber freebsd_committer 2015-07-28 12:12:28 UTC
This has been an issue as far back as 9.x, without resolution.

Marking this as an EN candidate post-release, should a solution become available.
Comment 5 Sean Bruno freebsd_committer 2015-07-30 20:54:15 UTC
Currently, only pcn(4) is failing.  I guess someone should look into it?