Bug 188319 - Update: mail/greyfix to 0.4.0
Summary: Update: mail/greyfix to 0.4.0
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: Danilo Egea Gondolfo
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-04-06 17:40 UTC by Keith Gaughan
Modified: 2014-06-14 20:58 UTC (History)
1 user (show)

See Also:


Attachments
file.diff (1.89 KB, patch)
2014-04-06 17:40 UTC, Keith Gaughan
no flags Details | Diff
greyfix.diff (2.50 KB, patch)
2014-04-26 04:23 UTC, Keith Gaughan
no flags Details | Diff
greyfix.diff (7.41 KB, patch)
2014-04-26 16:00 UTC, Keith Gaughan
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Keith Gaughan 2014-04-06 17:40:00 UTC
Update mail/greyfix to 0.4.0.

There are a few minor issues with this port. First is that greyfix has no license attached, so I can't fill out that fields. Second is that the socket patch included needs to be moved upstream. I intend on contacting the author about both issues as soon as is feasible.

Fix: Patch attached with submission follows:
Comment 1 Edwin Groothuis freebsd_committer 2014-04-06 17:40:04 UTC
Class Changed
From-To: update->maintainer-update

Fix category (submitter is maintainer) (via the GNATS Auto Assign Tool)
Comment 2 Keith Gaughan 2014-04-22 20:07:42 UTC
If the delay on processing this PR is due to the issues I mentioned,
they can be disregarded for now. The developer won't be able to get back
to me until May.

As things stand, the port is fit for use to the best of my knowledge.
Comment 3 Keith Gaughan 2014-04-26 04:23:05 UTC
I figured that while I'm at it, I'd might as well see where I could
clean the port up. This update to the port is slimmer than my previous
one, and ought to be easier to apply as I did it against a Subversion
checkout of the port.
Comment 4 Keith Gaughan 2014-04-26 16:00:00 UTC
Further improvements. I've created a basic man page, which I intend on
submitting upstream, and have fixed an issue with the database directory
caused by permissions not being preserved when the package is built.
Comment 5 Danilo Egea Gondolfo freebsd_committer 2014-06-14 19:25:48 UTC
I've made some changes. Can you check this [1], please? What do you think?

[1] - https://phabric.freebsd.org/D224
Comment 6 Keith Gaughan 2014-06-14 19:46:53 UTC
Thanks for taking the port!

Yeah, I'm fine with those changes. You can probably also remove the PLIST_SUB line from the Makefile and replace:

@dirrmtry %%GREYFIXDBDIR%%

With:

@dirrmtry /var/db/greyfix

The way you did it solves the problem better than the way I tried.
Comment 7 commit-hook freebsd_committer 2014-06-14 20:55:32 UTC
A commit references this bug:

Author: danilo
Date: Sat Jun 14 20:54:44 UTC 2014
New revision: 357806
URL: http://svnweb.freebsd.org/changeset/ports/357806

Log:
  - Update from 0.3.9 to 0.4.0
  - Update MASTER_SITES
  - Install the man page

  PR:		ports/188319
  Submitted by:	Keith Gaughan <k@stereochro.me>

Changes:
  head/mail/greyfix/Makefile
  head/mail/greyfix/distinfo
  head/mail/greyfix/files/greyfix.8
  head/mail/greyfix/files/patch-sockets
  head/mail/greyfix/pkg-plist
Comment 8 Danilo Egea Gondolfo freebsd_committer 2014-06-14 20:58:00 UTC
Committed, thanks!