Bug 188327 - math/py-numpy: Numpy is broken
Summary: math/py-numpy: Numpy is broken
Status: Closed DUPLICATE of bug 188114
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: freebsd-python mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-04-06 21:30 UTC by Rusmir Dusko
Modified: 2016-08-12 08:06 UTC (History)
3 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Rusmir Dusko freebsd_committer 2014-04-06 21:30:00 UTC
NumPy not works, have it reinstalled more times with and without ATLAS option.

This say is working:

python -c "import numpy; print numpy"
<module 'numpy' from '/usr/local/lib/python2.7/site-packages/numpy/__init__.pyc'>


But when I try to use my port games/krank get

krank
krank version 07
/usr/local/share/krank/src/Effect.py:25: RuntimeWarning: use surfarray: no module named numpy or Numeric found
(ImportError: no module named numpy or Numeric found)
  array = pygame.surfarray.pixels_alpha(self.sparkImages[-1])
Traceback (most recent call last):
  File "/usr/local/share/krank/src/Main.py", line 83, in <module>
    Effects()
  File "/usr/local/share/krank/src/Effect.py", line 25, in __init__
    array = pygame.surfarray.pixels_alpha(self.sparkImages[-1])
  File "/usr/local/lib/python2.7/site-packages/pygame/__init__.py", line 70, in __getattr__
    raise NotImplementedError(MissingPygameModule)
NotImplementedError: surfarray module not available
(ImportError: no module named numpy or Numeric found


When i try to use my new port graphics/pyggel

/usr/local/share/examples/pyggel/ > python example1-speed.py         
Traceback (most recent call last):
  File "example1-speed.py", line 7, in <module>
    import pyggel
  File "/usr/local/lib/python2.7/site-packages/pyggel/__init__.py", line 7, in <module>
    from include import *
  File "/usr/local/lib/python2.7/site-packages/pyggel/include.py", line 21, in <module>
    raise MissingModule("Numpy - you can it from: http://sourceforge.net/projects/numpy/files/")
pyggel.include.MissingModule: Numpy - you can it from: http://sourceforge.net/projects/numpy/files/


Please solve this and update to newest Version at

http://sourceforge.net/projects/numpy/files/NumPy/1.8.1/

Fix: 

Update NumPy to 1.8.1 and try games/krank or other port which use NumPy
How-To-Repeat: Try to use some port which need NumPy.
Comment 1 Edwin Groothuis freebsd_committer 2014-04-06 21:30:07 UTC
Responsible Changed
From-To: freebsd-ports-bugs->freebsd-python

Over to maintainer (via the GNATS Auto Assign Tool)
Comment 2 Rusmir Dusko freebsd_committer 2014-04-07 02:30:28 UTC
Have ported games/robocalypto which not works because broken NumPy
get only this:

robocalypto
/usr/local/bin/robocalypto: Cannot fork: Resource temporarily unavailable
Traceback (most recent call last):
  File "./run_game.py", line 7, in <module>
    import pyggel
  File "/usr/local/lib/python2.7/site-packages/pyggel/__init__.py", line 7, in <module>
    from include import *
  File "/usr/local/lib/python2.7/site-packages/pyggel/include.py", line 21, in <module>
    raise MissingModule("Numpy - you can it from: http://sourceforge.net/projects/numpy/files/")
pyggel.include.MissingModule: Numpy - you can it from: http://sourceforge.net/projects/numpy/files/
Traceback (most recent call last):
  File "./run_game.py", line 7, in <module>
    import pyggel
  File "/usr/local/lib/python2.7/site-packages/pyggel/__init__.py", line 7, in <module>
    from include import *
  File "/usr/local/lib/python2.7/site-packages/pyggel/include.py", line 21, in <module>
    raise MissingModule("Numpy - you can it from: http://sourceforge.net/projects/numpy/files/")
pyggel.include.MissingModule: Numpy - you can it from: http://sourceforge.net/projects/numpy/files/
Traceback (most recent call last):
  File "./run_game.py", line 7, in <module>
    import pyggel
  File "/usr/local/lib/python2.7/site-packages/pyggel/__init__.py", line 7, in <module>
    from include import *
  File "/usr/local/lib/python2.7/site-packages/pyggel/include.py", line 21, in <module>
    raise MissingModule("Numpy - you can it from: http://sourceforge.net/projects/numpy/files/")
pyggel.include.MissingModule: Numpy - you can it from: http://sourceforge.net/projects/numpy/files/


Pyggel is needed for many Games, which I wish to port. Please fix soon than possible NumPy.

-- 
Best regards,
Rusmir Dusko
Comment 3 Vladimir Chukharev 2014-04-08 08:11:12 UTC
Could you check if the work around from ports/188114 helps in you case?
Try:

  LD_LIBRARY_PATH=/usr/local/lib/gcc47 robocalypto

You might need to change the version of gcc according to the installed on you computer,
or even find out a correct directory for clang...

-- 
Vladimir Chukharev
Comment 4 Rusmir Dusko freebsd_committer 2014-04-08 09:32:39 UTC
On Tue, 08 Apr 2014 10:11:12 +0300
"Vladimir Chukharev" <Vladimir.Chukharev@tut.fi> wrote:

> Could you check if the work around from ports/188114 helps in you case?
> Try:
> 
>   LD_LIBRARY_PATH=/usr/local/lib/gcc47 robocalypto
> 
> You might need to change the version of gcc according to the installed on you computer,
> or even find out a correct directory for clang...
> 

Yes this works thanks. This is GCC library PATH issue.

-- 
Best regards,
Rusmir Dusko
Comment 5 Thierry Thomas freebsd_committer 2014-04-17 22:03:05 UTC
The proposed work-around with LD_LIBRARY_PATH has been used to fix the
port french/eficas: it works!
-- 
Th. Thomas.
Comment 6 vladimir.chukharev 2014-08-13 07:02:13 UTC
This PR can be closed as a duplicate of bug 188114.

The originator confirmed that the proposed work-around solved the problem for him, and all the important information is present in bug 188114.
Comment 7 Kubilay Kocak freebsd_committer freebsd_triage 2014-08-13 07:08:45 UTC
Thank you Vladimir

*** This bug has been marked as a duplicate of bug 188114 ***