Bug 188852 - change-request, maintainer-update for the soon to be removed; www/spreadlogd
change-request, maintainer-update for the soon to be removed; www/spreadlogd
Status: Closed FIXED
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s)
Latest
Any Any
: Normal Affects Only Me
Assigned To: Ruslan Makhmatkhanov
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-04-21 16:00 UTC by Chris Hutchinson
Modified: 2014-05-20 07:16 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Chris Hutchinson 2014-04-21 16:00:00 UTC
www/spreadlogd is marked to be removed on 2014-05-01.
It's reason for removal is based upon the fact that
it's currently listed dependency upon net/spread
source (http://www.edu-linux.org/down/spread-src-3.17.4.tar.gz)
no longer exists.
I was able to retrieve the source from it's original
location: www.spread.org, and would be willing to
maintain a reliable link. To insure this port, as well
as the port net/spread continue to build, and work
as intended.

This is an attempt to take over maintainership of this
port to insure it's continued availability to those
who choose to use it.

Fix: 

Allow me to maintain this port.

Attachments of requisite patch(1)es
will soon follow...
How-To-Repeat: Attempt to build this port in it's current condition.
Comment 1 Edwin Groothuis freebsd_committer 2014-04-21 16:00:04 UTC
Responsible Changed
From-To: freebsd-ports-bugs->apache

Over to maintainer (via the GNATS Auto Assign Tool)
Comment 2 Ruslan Makhmatkhanov freebsd_committer 2014-04-21 16:24:03 UTC
Responsible Changed
From-To: apache->rm

I will take it.
Comment 3 Chris Hutchinson 2014-04-21 17:16:07 UTC
> Synopsis: change-request, maintainer-update for the soon to be removed; www/spreadlogd
>
> Responsible-Changed-From-To: apache->rm
> Responsible-Changed-By: rm
> Responsible-Changed-When: Mon Apr 21 15:24:03 UTC 2014
> Responsible-Changed-Why:
> I will take it.
>
> http://www.freebsd.org/cgi/query-pr.cgi?pr=188852
> _______________________________________________
> freebsd-apache@freebsd.org mailing list
> http://lists.freebsd.org/mailman/listinfo/freebsd-apache
> To unsubscribe, send any mail to "freebsd-apache-unsubscribe@freebsd.org"
>

FIXED.
Please see:

http://www.freebsd.org/cgi/query-pr.cgi?pr=188853

for details.

--chris
Comment 4 dfilter freebsd_committer 2014-05-20 07:08:40 UTC
Author: rm
Date: Tue May 20 06:08:36 2014
New Revision: 354598
URL: http://svnweb.freebsd.org/changeset/ports/354598
QAT: https://qat.redports.org/buildarchive/r354598/

Log:
  www/spreadlogd: remove broken and deprecated
  
  - remove broken and deprecated, because the dependency was fixed
  - pass maintainership to submitter
  
  PR:		188852
  Submitted by:	C Hutchinson <portmaster@bsdforge.com>

Modified:
  head/www/spreadlogd/Makefile

Modified: head/www/spreadlogd/Makefile
==============================================================================
--- head/www/spreadlogd/Makefile	Tue May 20 06:06:35 2014	(r354597)
+++ head/www/spreadlogd/Makefile	Tue May 20 06:08:36 2014	(r354598)
@@ -6,12 +6,9 @@ PORTVERSION=	1.4.2
 CATEGORIES=	www net
 MASTER_SITES=	http://www.lethargy.org/mod_log_spread/
 
-MAINTAINER=	apache@FreeBSD.org
+MAINTAINER=	portmaster@bsdforge.com
 COMMENT=	The backend of mod_log_spread
 
-DEPRECATED=	Depends on expired net/spread
-EXPIRATION_DATE=2014-05-01
-
 LICENSE=	ART10
 
 LIB_DEPENDS=	libspread.so:${PORTSDIR}/net/spread
_______________________________________________
svn-ports-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/svn-ports-all
To unsubscribe, send any mail to "svn-ports-all-unsubscribe@freebsd.org"
Comment 5 Ruslan Makhmatkhanov freebsd_committer 2014-05-20 07:16:12 UTC
State Changed
From-To: open->closed

Committed, thank you!