Bug 188904 - java/eclipse-devel fails to build
Summary: java/eclipse-devel fails to build
Status: Closed DUPLICATE of bug 188659
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: freebsd-ports-bugs (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-04-23 04:30 UTC by Jonathan Chen
Modified: 2014-06-06 07:00 UTC (History)
0 users

See Also:


Attachments
file.diff (2.38 KB, patch)
2014-04-23 04:30 UTC, Jonathan Chen
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Jonathan Chen 2014-04-23 04:30:01 UTC
On r351891, java/eclipse-devel fails to build with:

[...]
     [exec] cp *.so /usr/ports/java/eclipse-devel/work/eclipse-build-7b07d10488eb9d6e2880eac320b09c16d1ae78e3/build/eclipse-4.2.0-I20120608-1400-src/plugins/org.eclipse.swt.gtk.freebsd.x86_64
     [exec] gmake[1]: Leaving directory `/usr/ports/java/eclipse-devel/work/eclipse-build-7b07d10488eb9d6e2880eac320b09c16d1ae78e3/build/eclipse-4.2.0-I20120608-1400-src/plugins/org.eclipse.swt.gtk.freebsd.x86_64/library'
     [exec] Building FreeBSD launcher. Defaults: -os freebsd -arch x86_64 -ws gtk
     [exec] gmake[1]: Entering directory `/usr/ports/java/eclipse-devel/work/eclipse-build-7b07d10488eb9d6e2880eac320b09c16d1ae78e3/build/eclipse-4.2.0-I20120608-1400-src/features/org.eclipse.equinox.executable/library/gtk'
     [exec] rm -f eclipse eclipse_1503.so eclipseMain.o eclipseConfig.o eclipseCommon.o eclipseGtkCommon.o eclipseGtkInit.o eclipse.o eclipseGtk.o eclipseUtil.o eclipseJNI.o eclipseMozilla.o eclipseShm.o eclipseNix.o
     [exec] gmake[1]: Leaving directory `/usr/ports/java/eclipse-devel/work/eclipse-build-7b07d10488eb9d6e2880eac320b09c16d1ae78e3/build/eclipse-4.2.0-I20120608-1400-src/features/org.eclipse.equinox.executable/library/gtk'
     [exec] gmake[1]: Entering directory `/usr/ports/java/eclipse-devel/work/eclipse-build-7b07d10488eb9d6e2880eac320b09c16d1ae78e3/build/eclipse-4.2.0-I20120608-1400-src/features/org.eclipse.equinox.executable/library/gtk'
     [exec] gcc -g -s -Wall -fpic -DFREEBSD -DMOZILLA_FIX -DDEFAULT_OS="\"freebsd\"" -DDEFAULT_OS_ARCH="\"x86_64\"" -DDEFAULT_WS="\"gtk\"" -DDEFAULT_JAVA_EXEC -DGTK_LIB="\"libgtk-x11-2.0.so.0\"" -DGDK_LIB="\"libgdk-x11-2.0.so.0\"" -DPIXBUF_LIB="\"libgdk_pixbuf-2.0.so.0\"" -DGOBJ_LIB="\"libgobject-2.0.so.0\"" -DX11_LIB="\"libX11.so.6\"" -I. -I.. -I/usr/local/openjdk6/include -I/usr/local/openjdk6/include/freebsd `pkg-config --cflags gtk+-2.0` -c ../eclipseMain.c -o eclipseMain.o
     [exec] gmake[1]: Leaving directory `/usr/ports/java/eclipse-devel/work/eclipse-build-7b07d10488eb9d6e2880eac320b09c16d1ae78e3/build/eclipse-4.2.0-I20120608-1400-src/features/org.eclipse.equinox.executable/library/gtk'
     [exec] gcc: not found
     [exec] gmake[1]: *** [eclipseMain.o] Error 127

BUILD FAILED
/usr/ports/java/eclipse-devel/work/eclipse-build-7b07d10488eb9d6e2880eac320b09c16d1ae78e3/build.xml:612: Warning: Could not find file /usr/ports/java/eclipse-devel/work/eclipse-build-7b07d10488eb9d6e2880eac320b09c16d1ae78e3/build/eclipse-4.2.0-I20120608-1400-src/features/org.eclipse.equinox.executable/library/gtk/eclipse to copy.

Total time: 1 minute 47 seconds
*** Error code 1

Stop.
make: stopped in /usr/ports/java/eclipse-devel

Fix: Patch attached with submission follows:
How-To-Repeat: cd /usr/ports/java/eclipse-devel && make clean install
Comment 1 Edwin Groothuis freebsd_committer 2014-04-23 04:30:06 UTC
Responsible Changed
From-To: freebsd-ports-bugs->freebsd-eclipse

Over to maintainer (via the GNATS Auto Assign Tool)
Comment 2 Baptiste Daroussin freebsd_committer 2014-04-29 08:28:12 UTC
Responsible Changed
From-To: freebsd-eclipse->freebsd-ports-bugs

Over to all volunteers
Comment 3 Jonathan Chen 2014-06-06 07:00:28 UTC
Please close this in favour of 188659

*** This bug has been marked as a duplicate of bug 188659 ***