Bug 189060 - [pf] pf + altq doesn't work on octe (Edgerouter Lite) [regression]
Summary: [pf] pf + altq doesn't work on octe (Edgerouter Lite) [regression]
Status: Closed Feedback Timeout
Alias: None
Product: Base System
Classification: Unclassified
Component: kern (show other bugs)
Version: unspecified
Hardware: Any Any
: Normal Affects Only Me
Assignee: freebsd-bugs mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-04-27 21:40 UTC by daniel.engberg.lists
Modified: 2019-06-16 14:04 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description daniel.engberg.lists 2014-04-27 21:40:00 UTC
Adding queues in pf gets ignored, same ruleset works fine on 9-STABLE
using em drivers. All bandwidth limits gets ignored. This bug has been
around in -CURRENT since at least July last year. Output using pfctl -vvsq
shows zero hits/misses/total traffic.

How-To-Repeat: Setup a ruleset with queues and watch matches.
Comment 1 Mark Linimon freebsd_committer freebsd_triage 2014-05-04 05:30:33 UTC
Responsible Changed
From-To: freebsd-bugs->freebsd-pf

Over to maintainer(s).
Comment 2 daniel.engberg.lists 2014-05-05 22:18:26 UTC
The issue is that octe uses the new framework (if_transmit()) for 
network handling while altq only supports the old one (if_start()). As 
for now, there are no plans on adding support for the old framework 
making it support both as the em driver. There's a plan by glebius@ of 
adding altq support or equivalent funtionality to FreeBSD 11 but there a 
no solid promises as for now.
Comment 3 Eitan Adler freebsd_committer freebsd_triage 2017-12-31 07:58:29 UTC
For bugs matching the following criteria:

Status: In Progress Changed: (is less than) 2014-06-01

Reset to default assignee and clear in-progress tags.

Mail being skipped
Comment 4 daniel.engberg.lists 2019-06-16 14:04:29 UTC
Closing due to timeout