Bug 189217 - www/firefox does not compile if audio/soundtouch is built with INTEGER_SAMPLES
www/firefox does not compile if audio/soundtouch is built with INTEGER_SAMPLES
Status: Closed Works As Intended
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s)
Latest
Any Any
: Normal Affects Only Me
Assigned To: gecko
:
: 189488 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-05-02 02:40 UTC by lenzi.sergio
Modified: 2014-06-16 13:19 UTC (History)
1 user (show)

See Also:


Attachments
file.diff (1.46 KB, patch)
2014-05-02 02:40 UTC, lenzi.sergio
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description lenzi.sergio 2014-05-02 02:40:00 UTC

Fix: patch to put in the files directory

Patch attached with submission follows:
Comment 1 Mark Linimon freebsd_committer 2014-05-02 03:54:16 UTC
Responsible Changed
From-To: freebsd-bugs->freebsd-ports-bugs

ports PR.
Comment 2 Edwin Groothuis freebsd_committer 2014-05-02 03:54:35 UTC
Responsible Changed
From-To: freebsd-ports-bugs->gecko

Over to maintainer (via the GNATS Auto Assign Tool)
Comment 3 Jan Beich (N/A in 06/27..07/14) freebsd_committer 2014-06-11 22:08:21 UTC
INTEGER_SAMPLES isn't supported when building www/firefox against audio/soundtouch. After r357413 there's a note in UPDATING and the build would fail more early, at configure.

Do you confirm it as a configuration error or really want INTEGER_SAMPLES regardless of what firefox wants?
Comment 4 Jan Beich (N/A in 06/27..07/14) freebsd_committer 2014-06-11 22:11:04 UTC
*** Bug 189488 has been marked as a duplicate of this bug. ***
Comment 5 lenzi.sergio 2014-06-11 23:45:53 UTC
(In reply to Jan Beich from comment #3)
> INTEGER_SAMPLES isn't supported when building www/firefox against
> audio/soundtouch. After r357413 there's a note in UPDATING and the build
> would fail more early, at configure.
> 
> Do you confirm it as a configuration error or really want INTEGER_SAMPLES
> regardless of what firefox wants?

I changed the soundtouch to the default (no integer samples) 
and the problem goes away it compiles now