Bug 189777 - [patch] www/codeigniter staging, change url
Summary: [patch] www/codeigniter staging, change url
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: John Marino
URL:
Keywords:
: 189970 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-05-13 18:10 UTC by Zsolt Udvari
Modified: 2014-09-06 05:16 UTC (History)
3 users (show)

See Also:


Attachments
codeigniter.diff (2.64 KB, patch)
2014-05-13 18:10 UTC, Zsolt Udvari
no flags Details | Diff
codeigniter-2.diff (6.64 KB, patch)
2014-05-22 18:05 UTC, Zsolt Udvari
no flags Details | Diff
codeigniter.conf.in (406 bytes, patch)
2014-05-22 18:05 UTC, Zsolt Udvari
no flags Details | Diff
pkg-message.in (840 bytes, patch)
2014-05-22 18:05 UTC, Zsolt Udvari
no flags Details | Diff
codeigniter-2.diff (6.64 KB, patch)
2014-05-23 09:36 UTC, Zsolt Udvari
no flags Details | Diff
codeigniter.conf.in (406 bytes, text/plain)
2014-05-23 09:36 UTC, Zsolt Udvari
no flags Details
pkg-message.in (840 bytes, text/plain)
2014-05-23 09:36 UTC, Zsolt Udvari
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Zsolt Udvari 2014-05-13 18:10:01 UTC
www/codeigniter staging support
change url to http://ellislab.com/codeigniter
Comment 1 Edwin Groothuis freebsd_committer 2014-05-13 18:10:06 UTC
Maintainer of www/codeigniter,

Please note that PR ports/189777 has just been submitted.

If it contains a patch for an upgrade, an enhancement or a bug fix
you agree on, reply to this email stating that you approve the patch
and a committer will take care of it.

The full text of the PR can be found at:
    http://www.freebsd.org/cgi/query-pr.cgi?pr=ports/189777

-- 
Edwin Groothuis via the GNATS Auto Assign Tool
edwin@FreeBSD.org
Comment 2 Edwin Groothuis freebsd_committer 2014-05-13 18:10:07 UTC
State Changed
From-To: open->feedback

Awaiting maintainers feedback (via the GNATS Auto Assign Tool)
Comment 3 Bo-Yi Wu 2014-05-14 02:51:35 UTC
Please commit it. Thanks.

--
About me: http://about.me/appleboy
Comment 4 Mark Linimon freebsd_committer freebsd_triage 2014-05-14 07:31:42 UTC
State Changed
From-To: feedback->open

Maintainer approved.
Comment 5 Guido Falsi freebsd_committer 2014-05-14 21:51:19 UTC
While looking at this patch I noticed it has a problem.

The staging conversion is incomplete.

The port is still echoing pkg-message by itself, which is unnecessary
with staging.

The port also echoes various user message during installation, this is
wrong when using staging, since thee messages will appear at the wrong
time, and will never be seen by people using binary packages.

Such messages should be moved to the pkg-message, or, is conditionally
shown, a pkg-install script should be created to show them if necessary.

Can this patch be fixed keeping all this in mind?

The port is also redefining WWWDIR to it's default value, why is this
needed?

Thanks in advance.

-- 
Guido Falsi <madpilot@FreeBSD.org>
Comment 6 Zsolt Udvari 2014-05-18 16:43:35 UTC
To maintainer: do you think files/codeigniter-*.conf.in are needed?
I think it's enough to ship a sample apache configuration file (if
build with APACHE support) and show a simple message with an attention
to check, configure and restart webserver (apache, lighttpd, nginx,
etc.).
I think the "PROD" option should drop - the developer can configure
his/her webserver. And this option is useful _only_ with Apache -
doesn't include any lighttpd/nginx config.
And I think the PHP_CGI check is unnecessary too because of it's
Apache-specific.

Summary (of my thinks):
- drop PROD option (and "confighelp" target too)
- drop PHP_CGI check and cgi-specific message
- drop apache configuration files, except a simple one (or maybe can
install apache config file into codeigniter's doc/examplesdir without
any APACHE-option)
- drop any option-specific message
- message content is: attention about check/config/reload webserver,
create a correct index.php from index.php.sample (I think shouldn't
create index.php because it's modified because of database settings -
but I think nobody use this index.php, for example I'm copying it into
my ~/public_html/app and modify this copied version). Maybe a simple
plus message about production/develop installation (point to
codeigniter/user_guide/installation/index.html)

With this changes the port will be more simplier. If you think these
changes are correct I'll create a patch.

Zsolt
Comment 7 Zsolt Udvari 2014-05-22 18:05:08 UTC
Here are the updated files, patches. The changes are made as I wrote
some day ago.
I hope they are right now.
Comment 8 Zsolt Udvari 2014-05-23 09:36:58 UTC
---------- Forwarded message ----------
From: Zsolt Udvari <udvzsolt@gmail.com>
Date: 2014-05-22 19:05 GMT+02:00
Subject: Re: ports/189777: [patch] www/codeigniter staging, change url
To: Guido Falsi <madpilot@freebsd.org>
Másolatot kap: bug-followup@freebsd.org, Bo-Yi Wu <appleboy.tw@gmail.com>


Here are the updated files, patches. The changes are made as I wrote
some day ago.
I hope they are right now.
Comment 9 Zsolt Udvari 2014-05-23 09:50:16 UTC
Modified patches and files:

http://uzsolt.hu/freebsd/codeigniter-2.diff
http://uzsolt.hu/freebsd/codeigniter.conf.in
http://uzsolt.hu/freebsd/pkg-message.in

The emails with attachments does not appear.
Comment 10 John Marino freebsd_committer 2014-06-18 23:45:34 UTC
I'll take it even though maintainer never commented on the final iteration.
Comment 11 commit-hook freebsd_committer 2014-06-19 00:01:43 UTC
A commit references this bug:

Author: marino
Date: Thu Jun 19 00:01:39 UTC 2014
New revision: 358331
URL: http://svnweb.freebsd.org/changeset/ports/358331

Log:
  www/codeigniter: Support stage and update URL

  PR:		189777
  Submitted by:	Zsolt Udvari
  Approved by:	maintainer (Bo-Yi Wu) (first version)
  Verified by:	Redports 8x pass

Changes:
  head/www/codeigniter/Makefile
  head/www/codeigniter/files/codeigniter.conf.in
  head/www/codeigniter/files/pkg-message.in
  head/www/codeigniter/pkg-descr
  head/www/codeigniter/pkg-plist
Comment 12 John Marino freebsd_committer 2014-06-19 00:03:13 UTC
Thanks!
Comment 13 John Marino freebsd_committer 2014-08-06 09:28:13 UTC
*** Bug 189970 has been marked as a duplicate of this bug. ***