Bug 189844 - lang/python27: dependent packages fail to build when python is built with both PTH and THREADS
Summary: lang/python27: dependent packages fail to build when python is built with bot...
Status: Closed DUPLICATE of bug 187979
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: freebsd-python (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-05-15 23:40 UTC by pasko.boris
Modified: 2014-07-29 16:48 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description pasko.boris 2014-05-15 23:40:00 UTC
When python is built with both options, seems like it excludes PTH support, but dependent packages (talloc as an example) THINK pthreads are available and fail to build:

http://www.freebsd.org/cgi/query-pr.cgi?pr=187979

Fix: 

Python.h:

#ifdef HAVE_PTH
/* GNU pth user-space thread support */
-#include <pth.h>
+#include <pth/pth.h>            # GWM
#endif
How-To-Repeat: See http://www.freebsd.org/cgi/query-pr.cgi?pr=187979
Comment 1 Edwin Groothuis freebsd_committer 2014-05-20 04:41:53 UTC
Responsible Changed
From-To: freebsd-ports-bugs->freebsd-python

Over to maintainer (via the GNATS Auto Assign Tool)
Comment 2 pasko.boris 2014-07-11 19:49:49 UTC
Duplicate of https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=187979

I suggest closing it as Not a Bug
Comment 3 Marcus von Appen freebsd_committer freebsd_triage 2014-07-29 16:48:53 UTC
Closed as duplicate per submitter request

*** This bug has been marked as a duplicate of bug 187979 ***