Bug 189898 - [stage] Add staging support to www/squid
Summary: [stage] Add staging support to www/squid
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: John Marino
URL:
Keywords:
: 191681 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-05-17 21:40 UTC by joe
Modified: 2014-09-06 05:16 UTC (History)
2 users (show)

See Also:


Attachments
file.diff (1.81 KB, patch)
2014-05-17 21:40 UTC, joe
no flags Details | Diff
squid-staging-orphans.patch.txt (2.68 KB, patch)
2014-05-17 22:50 UTC, joe
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description joe 2014-05-17 21:40:00 UTC
Adds staging support, added shebangfixes, and USES tar:bzip2 to www/squid.

Fix: Patch attached with submission follows:
Comment 1 Edwin Groothuis freebsd_committer 2014-05-17 21:40:03 UTC
Responsible Changed
From-To: freebsd-ports-bugs->tmseck

Over to maintainer (via the GNATS Auto Assign Tool)
Comment 2 joe 2014-05-17 22:50:45 UTC
The attached patch also takes care of orphan files left over.

-Joe
Comment 3 John Marino freebsd_committer 2014-08-11 13:22:39 UTC
*** Bug 191681 has been marked as a duplicate of this bug. ***
Comment 4 John Marino freebsd_committer 2014-08-11 13:23:29 UTC
maintainer reset, moving to patch-ready (untested, take at your own risk)
Comment 5 commit-hook freebsd_committer 2014-08-12 14:58:31 UTC
A commit references this bug:

Author: marino
Date: Tue Aug 12 14:57:49 UTC 2014
New revision: 364707
URL: http://svnweb.freebsd.org/changeset/ports/364707

Log:
  Stage www/squid

  I went further than this PR, removing post-install script invocation
  and cat messages, preinstall too.  This unmaintained port needs some
  more modernizing, particularly involving options.

  PR:		189898
  Submitted by:	Joe (thrallingpenguin.com)

Changes:
  head/www/squid/Makefile