Bug 189902 - [stage] Add staging support to www/squid32
Summary: [stage] Add staging support to www/squid32
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: John Marino
URL:
Keywords:
: 191673 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-05-18 01:20 UTC by joe
Modified: 2014-09-06 05:16 UTC (History)
2 users (show)

See Also:


Attachments
file.diff (3.51 KB, patch)
2014-05-18 01:20 UTC, joe
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description joe 2014-05-18 01:20:00 UTC
Adds staging support, added shebangfixes, and USES tar:bzip2 to www/squid32.

Fix: Patch attached with submission follows:
Comment 1 Edwin Groothuis freebsd_committer 2014-05-18 01:20:04 UTC
Responsible Changed
From-To: freebsd-ports-bugs->tmseck

Over to maintainer (via the GNATS Auto Assign Tool)
Comment 2 John Marino freebsd_committer 2014-08-11 13:20:02 UTC
*** Bug 191673 has been marked as a duplicate of this bug. ***
Comment 3 John Marino freebsd_committer 2014-08-11 13:21:10 UTC
maintainer reset, move to patch-ready (untested, take at your own risk)
Comment 4 John Marino freebsd_committer 2014-08-16 20:55:47 UTC
get back into the thralling ring...
Comment 5 commit-hook freebsd_committer 2014-08-17 00:04:10 UTC
A commit references this bug:

Author: marino
Date: Sun Aug 17 00:03:33 UTC 2014
New revision: 365144
URL: http://svnweb.freebsd.org/changeset/ports/365144

Log:
  Stage www/squid32

  PR:		189902
  Submitted by:	joe (thralling.com)
  Lotsa TLC:	marino

Changes:
  head/www/squid32/Makefile
  head/www/squid32/files/extra-patch-src-cf.data.pre.aufs
Comment 6 John Marino freebsd_committer 2014-08-17 00:05:46 UTC
This is a very complex (too complex) port, so it's no surprise that I found lots of issues.

It didn't pass poudriere out of the box either.  Anyway, it's done.