Bug 189912 - mail/spamassassin: p5-Net-DNS update breaks spamassassin's sa-update
mail/spamassassin: p5-Net-DNS update breaks spamassassin's sa-update
Status: Closed FIXED
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s)
Latest
Any Any
: Normal Affects Only Me
Assigned To: Adam Weinberger
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-05-18 16:50 UTC by brian
Modified: 2014-06-20 19:15 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description brian 2014-05-18 16:50:01 UTC
I update ports frequently.  The recent update to p5-Net-DNS to 0.75 appears to have caused spamassassin updates to fail (spamassassin-3.4.0_10). Running sa-update with -D, I got (edited for brevity):


May 18 07:47:51.975 [9033] dbg: dns: query failed: 0.4.3.sought.rules.yerp.org => REFUSED
May 18 07:47:52.142 [9033] dbg: dns: query failed: mirrors.sought.rules.yerp.org => REFUSED
May 18 07:47:52.312 [9033] dbg: dns: query failed: 0.4.3.updates.spamassassin.org => REFUSED
May 18 07:47:52.479 [9033] dbg: dns: query failed: mirrors.updates.spamassassin.org => REFUSED


Except I can do a TXT DNS query on them just fine:


# dig -t TXT 0.4.3.sought.rules.yerp.org
0.4.3.sought.rules.yerp.org. 300 IN     TXT     "3402014020421"


When I rolled back to p5-Net-DNS 0.74_1, I was able to successfully run sa-update.  There have been DNS issues with SA before, see:

https://issues.apache.org/SpamAssassin/show_bug.cgi?id=6872

So maybe this is a similar issue?

How-To-Repeat: Run spamassassin-3.4.0_10 and p5-Net-DNS-0.75 (current revisions in HEAD of ports) and attempt to run sa-update.
Comment 1 Edwin Groothuis freebsd_committer 2014-05-18 23:38:59 UTC
Responsible Changed
From-To: freebsd-ports-bugs->adamw

Over to maintainer (via the GNATS Auto Assign Tool)
Comment 2 adamw 2014-05-19 17:15:43 UTC
It works for me.....

[root@apnoea ~] sa-update -v -D 2>&1|fgrep dns
May 19 12:14:38.575 [9691] dbg: dns: 0.4.3.updates.spamassassin.org => 
1588424, parsed as 1588424

Any chance it is a local problem?

# Adam


--
Adam Weinberger
adamw@adamw.org
http://www.adamw.org
Comment 3 brian 2014-05-19 17:48:41 UTC
On Mon, 19 May 2014, Adam Weinberger wrote:
> Any chance it is a local problem?

Tested with multiple pkg add/deletes, the p5-Net-DNS-0.75 package fails 
as described, but the p5-Net-DNS-0.74_1 does not.

I'm using the following arguments to sa-update:
-v --gpgkey 6C6191E3 --channel sought.rules.yerp.org --gpgkey 24F434CE --channel updates.spamassassin.org

I don't see anything in the 0.75 Changes file that looks like a culprit:
http://cpansearch.perl.org/src/NLNETLABS/Net-DNS-0.75/Changes

Brian
Comment 4 brian 2014-05-19 18:17:11 UTC
See also:
https://svn.apache.org/repos/asf/spamassassin/branches/3.4/build/announcements/3.4.0.txt

"Several incompatibilities with newer versions of a perl module Net::DNS
as used by sa-update and by the SpamAssassin library were fixed.
See Net::DNS problem [rt.cpan.org #83451]."

https://rt.cpan.org/Public/Bug/Display.html?id=83451

Weird that this was marked as "rejected".  I wonder if not all of the 
problems have been resolved.

I'll add I run a local (127.0.0.1) DNS resolver, so the "edns" options 
added in 3.4.0 should also not be a problem.

Brian
Comment 5 linimon 2014-05-20 04:45:47 UTC
----- Forwarded message from Adam Weinberger <adamw@adamw.org> -----

Date: Sun, 18 May 2014 20:02:45 -0400
From: Adam Weinberger <adamw@adamw.org>
To: edwin@FreeBSD.org, freebsd-ports-bugs@FreeBSD.org, adamw@FreeBSD.org
Subject: Re: ports/189912: mail/spamassassin: p5-Net-DNS update breaks spamassassin's sa-update
User-Agent: K-9 Mail for Android

Yikes! That looks ugly.

If you see an upstream patch for this please let me know! I'm away from home right now so I'm limited in the amount of investigation I can do right now. 

# Adam
-- 
Adam Weinberger
adamw@adamw.org
http://www.adamw.org

----- End forwarded message -----
Comment 6 Kurt Jaeger freebsd_committer 2014-06-19 19:34:26 UTC
See also: 191082, 191101
Comment 7 Adam Weinberger freebsd_committer 2014-06-19 19:41:37 UTC
Is this still an issue after r358436? I was never able to replicate the problem myself.
Comment 8 Kurt Jaeger freebsd_committer 2014-06-19 19:45:34 UTC
I don't know, this bug needs a easily reproducable testcase to debug further.
Comment 9 Kurt Jaeger freebsd_committer 2014-06-20 08:20:30 UTC
Testcase:

spamassassin -D dns -t < /dev/null

displays [among other things]

Jun 20 09:56:20.309 [53326] dbg: dns: eval failed: available_nameservers: No DNS
 servers available!

Fix: See

https://issues.apache.org/SpamAssassin/show_bug.cgi?id=7057

and the patch in 191101.

All three PRs should probably be merged.
Comment 10 Adam Weinberger freebsd_committer 2014-06-20 18:31:03 UTC
I have committed SA's patch for this. Can you please verify for me that it fixes the problem?
Comment 11 brian 2014-06-20 19:02:04 UTC
Updated spamssassin to 3.4.0_11 and p5-net-dns to 0.77, an it now works as expected.  Not sure if there's other testing or steps involved, but I would mark this as resolved IMHO.
Comment 12 Adam Weinberger freebsd_committer 2014-06-20 19:15:44 UTC
Good deal. Thanks, Brian.