Bug 189958 - crypt(1): broken /usr/bin/crypt [regression]
Summary: crypt(1): broken /usr/bin/crypt [regression]
Status: Closed DUPLICATE of bug 192277
Alias: None
Product: Base System
Classification: Unclassified
Component: bin (show other bugs)
Version: 9.3-PRERELEASE
Hardware: Any Any
: Normal Affects Only Me
Assignee: freebsd-bugs mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-05-19 17:30 UTC by safonov.paul
Modified: 2015-02-25 20:48 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description safonov.paul 2014-05-19 17:30:00 UTC
Result of /usr/bin/crypt changed.

9.2-RELEASE:
% jot 10 | /usr/bin/crypt 123 | md5
45bdbb4e4a69c284a40d796c4c4f9a0f

9.3-PRERELEASE:
% jot 10 | /usr/bin/crypt 123 | md5
9d835aa71b0733d4c2f05c9fbb244ead

How-To-Repeat: jot 10 | /usr/bin/crypt 123 | md5
Comment 1 Gavin Atkinson freebsd_committer freebsd_triage 2015-02-24 19:19:02 UTC
Close, an Errata Notice (EN-14:11) has been published to resolve this.

*** This bug has been marked as a duplicate of bug 192277 ***
Comment 2 commit-hook freebsd_committer 2015-02-25 20:48:14 UTC
A commit references this bug:

Author: delphij
Date: Wed Feb 25 20:47:26 UTC 2015
New revision: 279296
URL: https://svnweb.freebsd.org/changeset/base/279296

Log:
  Explicitly crypt_set_format("des") and bail out if we
  can't.  This would prevent problem when we changed the
  default crypt(3) algorithm or removed it in the future.

  PR:		bin/189958
  MFC after:	1 month

Changes:
  head/usr.bin/enigma/enigma.c