Bug 190013 - [maintainer-update] net/spread: location change, and archive type
Summary: [maintainer-update] net/spread: location change, and archive type
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: Ruslan Makhmatkhanov
URL:
Keywords:
: 190327 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-05-20 16:20 UTC by Chris Hutchinson
Modified: 2014-06-04 18:14 UTC (History)
2 users (show)

See Also:


Attachments
file.shar (1.50 KB, text/plain)
2014-05-20 16:20 UTC, Chris Hutchinson
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Chris Hutchinson 2014-05-20 16:20:00 UTC
Modifies:
Makefile (source location, archive type, and $PORTREVISION)
distinfo (updates filename, SHA256, and SIZE)

Note; the previous location will remain for a reasonable
amount of time.

Fix: Apply the attached diff(1).

Patch attached with submission follows:
Comment 1 Dmitry Marakasov freebsd_committer 2014-05-20 20:38:28 UTC
State Changed
From-To: open->feedback

The port needs to be staged in order to be updated. See 
https://wiki.freebsd.org/ports/StageDir for details.
Comment 2 Chris Hutchinson 2014-05-20 21:01:45 UTC
I don't understand. This makes no sense. This port is already staged.
Why wasn't this port examined before changing it's status?

--Chris

> Synopsis: [maintainer-update] net/spread: location change, and archive type
>
> State-Changed-From-To: open->feedback
> State-Changed-By: amdmi3
> State-Changed-When: Tue May 20 19:38:28 UTC 2014
> State-Changed-Why:
> The port needs to be staged in order to be updated. See
> https://wiki.freebsd.org/ports/StageDir for details.
>
> http://www.freebsd.org/cgi/query-pr.cgi?pr=190013
>
Comment 3 Jonathan Chu freebsd_committer 2014-06-02 04:56:26 UTC
I'll take this.
Comment 4 Jonathan Chu freebsd_committer 2014-06-02 04:58:04 UTC
*** Bug 190327 has been marked as a duplicate of this bug. ***
Comment 5 Jonathan Chu freebsd_committer 2014-06-02 05:09:04 UTC
Reassigning to @rm. rm already made a commit for this.
Comment 6 Ruslan Makhmatkhanov freebsd_committer 2014-06-02 05:32:50 UTC
Oops, didn't know about this one. 
Chris, I still can't email to you because of filter, so this is why I committed without your approval. Would you please update your patch to exclude already committed changes and attach it here as unified diff, not shar? Thank you.
Comment 7 Ruslan Makhmatkhanov freebsd_committer 2014-06-02 07:51:36 UTC
Mmm, no. It looks like you are using shar(1) after diff(1). But shar is only needed when submitting the new port.
Just try to do "diff -uN > patch.txt" in the port directory or "svn di > patch.txt" in case you are using svn. 

PS. No email issue is still is the case:
"""
Reporting-MTA: dns; forward11.mail.yandex.net
X-Yandex-Queue-ID: 3EC9BE8111E
X-Yandex-Sender: rfc822; cvs-src@yandex.ru
Arrival-Date: Mon,  2 Jun 2014 11:47:56 +0400 (MSK)

Final-Recipient: rfc822; portmaster@bsdforge.com
Original-Recipient: rfc822;portmaster@bsdforge.com
Action: failed
Status: 5.0.0
Remote-MTA: dns; mx99.ultimatedns.net
Diagnostic-Code: smtp; 550 5.0.0 SPAM and BULK mail REJECTED
"""
Comment 8 Jonathan Chu freebsd_committer 2014-06-02 14:52:20 UTC
I'd like to point out as well that there is an embedded LICENSE with an advertising clause as well as an embedded perl module that could be broken out into a separate port.
Comment 9 commit-hook freebsd_committer 2014-06-02 18:58:09 UTC
A commit references this bug:

Author: rm
Date: Mon Jun  2 18:57:56 UTC 2014
New revision: 356246
URL: http://svnweb.freebsd.org/changeset/ports/356246

Log:
  net/spread: update MASTER_SITES and other changes

  - update MASTER_SITES
  - switch to tar.xz distribution [1]
  - use fixpacklist instead of manual fix [2]
  - strip shared libraries [2]
  - whitespace fix in pkg-plist
  - bump PORTREVISION because of STRIP_CMD

  [1] both tar.gz and tar.xz are identical
  [2] obtained from https://phabric.freebsd.org/D126

  PR:		190013
  Submitted by:	portmaster@bsdforge.com (maintainer)

Changes:
  head/net/spread/Makefile
  head/net/spread/distinfo
  head/net/spread/pkg-plist
Comment 10 Ruslan Makhmatkhanov freebsd_committer 2014-06-02 19:00:23 UTC
Just committed in r356246, with addition of STRIP_CMD and fixpacklist.
LICENSE and perl slave-port is up to maintainer. Sadly, I have not much time to deal with ports this days.