Bug 190050 - [ahci] AHCI does not detect Plextor M6e PCI-Express SSD
Summary: [ahci] AHCI does not detect Plextor M6e PCI-Express SSD
Status: Closed FIXED
Alias: None
Product: Base System
Classification: Unclassified
Component: amd64 (show other bugs)
Version: unspecified
Hardware: Any Any
: Normal Affects Only Me
Assignee: freebsd-amd64 mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-05-21 03:00 UTC by John Hickey
Modified: 2014-09-29 04:28 UTC (History)
3 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description John Hickey 2014-05-21 03:00:00 UTC
The Plextor M6e PCI-E SSD is a relatively new device, but it uses the Marvell 88SS9183 controller.  This controller was added in revision 254987 to support the 2013 Macbook Air.

After a camcontrol rescan all I get this error:

(aprobe0:ahcich0:0:0:0): Unexpected signature 0xffff

pciconf for the Plextor M6e:

ahci0@pci0:4:0:0:       class=0x010601 card=0x91831b4b chip=0x01221c28 rev=0x14 hdr=0x00
    class      = mass storage
    subclass   = SATA
    bar   [10] = type I/O Port, range 32, base rxc050, size 8, enabled
    bar   [14] = type I/O Port, range 32, base rxc040, size 4, enabled
    bar   [18] = type I/O Port, range 32, base rxc030, size 8, enabled
    bar   [1c] = type I/O Port, range 32, base rxc020, size 4, enabled
    bar   [20] = type I/O Port, range 32, base rxc000, size 32, enabled
    bar   [24] = type Memory, range 32, base rxdf120000, size 512, enabled
    cap 01[40] = powerspec 3  supports D0 D3  current D0
    cap 05[50] = MSI supports 1 message enabled with 1 message
    cap 10[70] = PCI-Express 2 legacy endpoint max data 256(512) link x2(x2)
                 speed 5.0(5.0) ASPM disabled(L0s/L1)
    ecap 0001[100] = AER 1 0 fatal 0 non-fatal 0 corrected
Comment 1 Martijn Kools 2014-08-24 12:42:23 UTC
Same problem here with this drive. Tried with latest current and 9.3, both same result.

Any fix/workaround?
Comment 2 Dimitar Boyn 2014-08-25 20:28:12 UTC
MemoRight use the same Marvell controller and I am experiencing the same problem with our PCIe switch card.

#cat /etc/version
FreeNAS-9.2.1.7-RELEASE-x64 (fdbe9a0)

#uname -a
FreeBSD freenas.local 9.2-RELEASE-p10 FreeBSD 9.2-RELEASE-p10 #0 r262572+4fb5adc: Wed Aug  6 17:07:16 PDT 2014     root@build3.ixsystems.com:/fusion/jkh/921/freenas/os-base/amd64/fusion/jkh/921/freenas/FreeBSD/src/sys/FREENAS.amd64  amd64

should we be getting ahci driver fix? These SSDs both from Plextor and Memoright work transparently with no any additioanl touches in VMware, Mac OS X, Windows 7,8 and server 2008 and 2012, Linux.

Some thing is off with the AHCI driver in FreeBSD - no additional patches should be needed to support a standard device?
Comment 3 Alexander Motin freebsd_committer 2014-09-29 04:27:27 UTC
Not all controllers implement AHCI equally. Marvell is slightly different in few places. Patch to better support random Marvell AHCI controllers was committed couple weeks ago.
Comment 4 Alexander Motin freebsd_committer 2014-09-29 04:28:48 UTC
FreeNAS 9.2.1.8 that should be released soon should include this change.