Bug 190082 - [stage] mail/postgrey stage support
Summary: [stage] mail/postgrey stage support
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: John Marino
URL:
Keywords:
: 190468 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-05-21 19:40 UTC by freebsd
Modified: 2014-09-06 05:16 UTC (History)
4 users (show)

See Also:


Attachments
postgrey.patch (2.06 KB, patch)
2014-05-21 19:40 UTC, freebsd
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description freebsd 2014-05-21 19:40:00 UTC
	mail/postgrey does not support staging

Fix: Apply attached patch.
Comment 1 Edwin Groothuis freebsd_committer 2014-05-21 19:40:06 UTC
Maintainer of mail/postgrey,

Please note that PR ports/190082 has just been submitted.

If it contains a patch for an upgrade, an enhancement or a bug fix
you agree on, reply to this email stating that you approve the patch
and a committer will take care of it.

The full text of the PR can be found at:
    http://www.freebsd.org/cgi/query-pr.cgi?pr=ports/190082

-- 
Edwin Groothuis via the GNATS Auto Assign Tool
edwin@FreeBSD.org
Comment 2 Edwin Groothuis freebsd_committer 2014-05-21 19:40:07 UTC
State Changed
From-To: open->feedback

Awaiting maintainers feedback (via the GNATS Auto Assign Tool)
Comment 3 Mel Pilgrim 2014-05-29 18:43:31 UTC
Hey this has been sitting for a week.  I've gotten super busy with work 
and haven't tested out the patch yet.  The changes look ok, but I need 
to test it before I give the ok to commit.

This is just a quick follow-up to ACK the PR and avoid maintainer 
timeout.  I'll test and follow-up with a commit req this weekend.
Comment 4 Martin Wilke freebsd_committer 2014-06-06 06:01:54 UTC
Darren, 

Thanks for your quick reply. Did you had time to check on that patch?

- Martin
Comment 5 William Grzybowski freebsd_committer 2014-06-19 12:52:04 UTC
*** Bug 190468 has been marked as a duplicate of this bug. ***
Comment 6 John Marino freebsd_committer 2014-08-05 13:51:41 UTC
Two months have passed and only 4 weeks to stage all ports, so marking this as maintainer timeout, patch-ready (Although I would have liked to have seen poudriere testlogs first)
Comment 7 commit-hook freebsd_committer 2014-08-06 15:20:22 UTC
A commit references this bug:

Author: marino
Date: Wed Aug  6 15:20:08 UTC 2014
New revision: 364191
URL: http://svnweb.freebsd.org/changeset/ports/364191

Log:
  Stage mail/postgrey

  PR:		190082
  Submitted by:	freebsd (nagilum.org)
  Add'l work by:	marino
  Approved by:	maintainer timeout (2.5 months)

Changes:
  head/mail/postgrey/Makefile
  head/mail/postgrey/pkg-plist
Comment 8 John Marino freebsd_committer 2014-08-06 15:24:39 UTC
I made a few changes, off the top of my head:

- reordered pkg-plist to something more standard
- renamed MAN1 variable to MPAGES (MAN1 was used by old code, confusing)
- two more files need shebang fixes (caught by stage-qa_
- The first shebangfix file was not listed corrected (had ${WRKSRC} prefix)
- Lots of 80-column wrapping
- All the install commands were masked, this is against policy
- switched INSTALL -d to MKDIR command (equivalent but cleaner)
- joined directory creation to single command
- removed pre- and post- install targets, redundant now (it does this already)

It passed poudriere cleanly for me after all that.